Jump to content
GuildDarts

[Plugin] Docker Folder

315 posts in this topic Last Reply

Recommended Posts

Posted (edited)
21 hours ago, GooseGoose said:

first time i have made a gif. Hopefully that worked

 

ezgif.com-video-to-gif.gif.2a680cbec1d600a43040a3e8b4285833.gif

Im unable to reproduce this :(. Would you be willing to let me teamviewer?

If you are PM me ^_^ (im usually online between 11-19 UTC)

 

Edit

two more things :)
could you send your folders.json (goto "add folder" top right button import/export then "export all")
also you said its the 2nd folder that has issues, does that mean all others still sort?

Edited by GuildDarts
Extra info

Share this post


Link to post
Posted (edited)
19 hours ago, GuildDarts said:

Im unable to reproduce this :(. Would you be willing to let me teamviewer?

If you are PM me ^_^ (im usually online between 11-19 UTC)

 

Edit

two more things :)
could you send your folders.json (goto "add folder" top right button import/export then "export all")
also you said its the 2nd folder that has issues, does that mean all others still sort?

I will PM you when i am available for teamviewer. 

 

Yeah i could move my downloaders folder around no problem. 

 

Attached is the json for all folders. Hope that helps :)

docker.folder-AllFolders-2020_04_27.json

 

edit: I just checked the time zone and it is 11pm NZST to 7am NZST so i might have to skip the teamviewer session :(

Edited by GooseGoose
timezone

Share this post


Link to post
9 hours ago, GooseGoose said:

edit: I just checked the time zone and it is 11pm NZST to 7am NZST so i might have to skip the teamviewer session :(

yeah looks like we are in pretty opposite time zones :(
I was unable to reproduce it even with your folders
One thing you could try would be to export all your folders, uninstall plugin, "Reset sorting", install plugin and import folders. Then try sorting (not confident this will fix it but its worth a try)
Reset sorting

Share this post


Link to post

hey, 

 

That fixed it! Weird little bug!

 

the next thing, how do you expand out the folders on the dashboard? I don't seem to have that option? 

 

 

Share this post


Link to post

Great work GuildDarts! I'm not sure "Docker Folder" does it justice. The organization is great, but the real feature is the ability to stop and start groups of dockers. I'm doing so much less clicking now.

 

Feel free to put up a donate button. I'd be happy to throw a few bucks your way for this.

Share this post


Link to post
9 hours ago, GooseGoose said:

hey, 

 

That fixed it! Weird little bug!

 

the next thing, how do you expand out the folders on the dashboard? I don't seem to have that option? 

 

 

Thats awesome, glad that its fixed ^_^
Its under "Advanced View" (really need to add some help info, like the blue ones unraid has)
ym4EYeK8.thumb.png.c892c46d560b91d9e3e281e1c67bb5c0.png

Share this post


Link to post

oh awesome, i didnt notice the advanced settings. The lines are not lining up very well. Is there any way in getting it toggle-able on the dashboard?

image.png.3315c1df1692d00b1b94089626f3b5f8.png

Share this post


Link to post
2 hours ago, GooseGoose said:

oh awesome, i didnt notice the advanced settings. The lines are not lining up very well. Is there any way in getting it toggle-able on the dashboard?

image.png.3315c1df1692d00b1b94089626f3b5f8.png

will try and look into the lines not lining up (thought i had tested it *sigh)
about getting it toggle-able, the original requester for the feature and i decided against it.
tho i cloud add a option for a toggle button kinda like on the docker tab if you want ^_^

Share this post


Link to post
5 minutes ago, GuildDarts said:

will try and look into the lines not lining up (thought i had tested it *sigh)
about getting it toggle-able, the original requester for the feature and i decided against it.
tho i cloud add a option for a toggle button kinda like on the docker tab if you want ^_^

I think a toggle button would be cool! maybe as another setting?

Share this post


Link to post
3 minutes ago, GooseGoose said:

I think a toggle button would be cool! maybe as another setting?

Will do :)
also just the expand to break xD
353809935_Annotation2020-04-29020235.png.a87a89a2c04986bdc82af1bff09d0724.png

Share this post


Link to post

Update

This update changes how folders are create. Before there was a hidden docker for each folderO.o
Also added a option to have a button for the dashboard expanded, as well as maybe fixing a bug with dashboard expanded.

Expanding with the buttons can cause visual issues as in the posts above. Will try and fix this but might not be worth the hassle (sorry)

@GooseGoose hope this fixes your issue with the lines, if not will try again ^_^

Share this post


Link to post
Posted (edited)

this plugin is wreaking havoc with my webui. When I try to press a start/stop menu item with the UI, nothing happens. But when I disabled the plugin, worked fine.

The log shows an exception while loading...

I am on the beta version, as testing things out before I buy...

I am not really using the plugin at this time... but it looked interesting so installed it.

 

thought you would want to know... snip follows:

 

3 16:45:06 buckyu root: Installing package docker.folder-2020.04.30-x86_64-1.txz: May 3 16:45:06 buckyu root: PACKAGE DESCRIPTION: May 3 16:45:06 buckyu root: Package docker.folder-2020.04.30-x86_64-1.txz installed. May 3 16:45:06 buckyu root: plugin: running: anonymous May 3 16:45:06 buckyu root: folders.json already exists May 3 16:45:06 buckyu root: Fatal error: Uncaught ArgumentCountError: Too few arguments to function finish(), 2 passed in /usr/local/emhttp/plugins/docker.folder/scripts/migration.php on line 22 and exactly 4 expected in /usr/local/emhttp/plugins/docker.folder/scripts/migration.php:42 May 3 16:45:06 buckyu root: Stack trace: May 3 16:45:06 buckyu root: #0 /usr/local/emhttp/plugins/docker.folder/scripts/migration.php(22): finish('/boot/config/pl...', Array) May 3 16:45:06 buckyu root: #1 /usr/local/emhttp/plugins/docker.folder/scripts/migration.php(12): init('/boot/config/pl...', '{\n "foldersV...', '{\n "foldersV...', false) May 3 16:45:06 buckyu root: #2 {main} May 3 16:45:06 buckyu root: thrown in /usr/local/emhttp/plugins/docker.folder/scripts/migration.php on line 42 May 3 16:45:06 buckyu root: May 3 16:45:06 buckyu root: ---------------------------------------------------- May 3 16:45:06 buckyu root: docker.folder has been installed. May 3 16:45:06 buckyu root: Version: 2020.04.30 May 3 16

 

Edited by bucky2076

Share this post


Link to post
4 hours ago, bucky2076 said:

this plugin is wreaking havoc with my webui. When I try to press a start/stop menu item with the UI, nothing happens. But when I disabled the plugin, worked fine.

The log shows an exception while loading...

I am on the beta version, as testing things out before I buy...

I am not really using the plugin at this time... but it looked interesting so installed it.

 

thought you would want to know... snip follows:

 

3 16:45:06 buckyu root: Installing package docker.folder-2020.04.30-x86_64-1.txz: May 3 16:45:06 buckyu root: PACKAGE DESCRIPTION: May 3 16:45:06 buckyu root: Package docker.folder-2020.04.30-x86_64-1.txz installed. May 3 16:45:06 buckyu root: plugin: running: anonymous May 3 16:45:06 buckyu root: folders.json already exists May 3 16:45:06 buckyu root: Fatal error: Uncaught ArgumentCountError: Too few arguments to function finish(), 2 passed in /usr/local/emhttp/plugins/docker.folder/scripts/migration.php on line 22 and exactly 4 expected in /usr/local/emhttp/plugins/docker.folder/scripts/migration.php:42 May 3 16:45:06 buckyu root: Stack trace: May 3 16:45:06 buckyu root: #0 /usr/local/emhttp/plugins/docker.folder/scripts/migration.php(22): finish('/boot/config/pl...', Array) May 3 16:45:06 buckyu root: #1 /usr/local/emhttp/plugins/docker.folder/scripts/migration.php(12): init('/boot/config/pl...', '{\n "foldersV...', '{\n "foldersV...', false) May 3 16:45:06 buckyu root: #2 {main} May 3 16:45:06 buckyu root: thrown in /usr/local/emhttp/plugins/docker.folder/scripts/migration.php on line 42 May 3 16:45:06 buckyu root: May 3 16:45:06 buckyu root: ---------------------------------------------------- May 3 16:45:06 buckyu root: docker.folder has been installed. May 3 16:45:06 buckyu root: Version: 2020.04.30 May 3 16

 

Thanks for letting me know ^_^

Just pushed an update. I was unable the get the error myself (on beta), but did fix what was causing the error (thanks for the logs :))
hope this fixes it for you

Share this post


Link to post
Posted (edited)
10 hours ago, GuildDarts said:

Thanks for letting me know ^_^

Just pushed an update. I was unable the get the error myself (on beta), but did fix what was causing the error (thanks for the logs :))
hope this fixes it for you

Don't know if this is expected behavior: I just updated Docker Folder to v2020.05.03 (not that I was having any issues with the previous version); I then switched to the Docker tab to see all my folders were deleted. I'm now back to the original list of containers.

 

Edited to add: While I was able to update containers, I cannot stop them (i.e. I clicked the container icon, clicked Stop and nothing happened). Uninstalled Docker Folder and I am able to start/stop containers again.

Edited by rragu
clarity

Share this post


Link to post
Posted (edited)
2 hours ago, rragu said:

Don't know if this is expected behavior: I just updated Docker Folder to v2020.05.03 (not that I was having any issues with the previous version); I then switched to the Docker tab to see all my folders were deleted. I'm now back to the original list of containers.

 

Edited to add: While I was able to update containers, I cannot stop them (i.e. I clicked the container icon, clicked Stop and nothing happened). Uninstalled Docker Folder and I am able to start/stop containers again.

Yeah that's not supposed to happen. 
in the previous version i changed how the migration script works, and that might have caused the issue.
will try and fix this asap

sorry about your folders getting deleted :(
incase anyone is reading this and i having same issue, before you uninstall there should be a folders.backup.json in /boot/config/plugins/docker.folder. You can import this once i fix the issue (again sorry)

 

Edit: 
i have tried but cant seem to find the issue 
if you install docker.folder again is start/stop still broken?

also if you remember were you on 2020.04.30 before you upgraded to 2020.05.03?

Edit2:

Just tried installing version 2020.04.24 then updating to latest and it broke. I cant start/stop, however my folders did not get removed like yours. Will try and fix this in the morning

Edited by GuildDarts
good news kinda (better news)

Share this post


Link to post

I didnt even update and i noticed that all of my folders were gone. So in an attempt to be proactive i uninstalled and reinstalled the plugin, i then tried importing previous folders which didnt work. I can however stop containers

Share this post


Link to post

@rraguokay so last night right after i posted that i got stop/start to not work, it started working again. Today i tried doing the exact same thing i did to break it yesterday and it is not breaking *sigh
 

10 hours ago, GooseGoose said:

I didnt even update and i noticed that all of my folders were gone. So in an attempt to be proactive i uninstalled and reinstalled the plugin, i then tried importing previous folders which didnt work. I can however stop containers

This i very confusing to me, i just reinstalled then tried to import the folders you sent previously and everything imported correctly 

would one of you two be willing to do teamviewer with me? (if we are not in same timezone i will stay up)

Share this post


Link to post
Posted (edited)
10 hours ago, troyan said:

Hi,
i have this error message when i click on docker Icon for action start, stop , remove...
this error message is : 
Uncaught (in promise) ReferenceError: folders is not defined    ???  a idea ?
see video

 

Hey sorry for the late reply

if you have not uninstalled docker.folder and its still happening i would really like to do teamviewer with you.
as you can see i have had a few reports of errors but i'm unable to reproduce it so im kinda lost :/

looks like its failing to read folders.json but i have no idea why :(

Edited by GuildDarts
why it fails

Share this post


Link to post

docker work fine,
only unraid interface icon action not work ?
what are the points that I can control to advance ?
docker.folder ???

Share this post


Link to post
2 minutes ago, troyan said:

docker work fine,
only unraid interface icon action not work ?
what are the points that I can control to advance ?
docker.folder ???

im unsure what you mean by "what are the points that I can control to advance"
about the interface icon action not working, im unable to reproduce this so i cant really do anything. Thats why i asked to do teamviewer with you so that i can see why its happening for you :)

Share this post


Link to post
Quote

im unsure what you mean by "what are the points that I can control to advance"

I can do the first checks for you.
i can check and give you information you want for solve this problem.

i have install server.io/nvidia
but I think I had the problem a little before (not sure 100%), but it didn't last very long a few days at most.
 

1 hour ago, GuildDarts said:

Thats why i asked to do teamviewer with you so that i can see why its happening for you :)

I understand and thank you, but teamviewer gives full control and I am root on unraid.
i have work and all my life on it.
I would like to share my screen but without control, i could apply the orders as and when requested...

I hope you understand ?

Share this post


Link to post
1 minute ago, troyan said:

I can do the first checks for you.
i can check and give you information you want for solve this problem.

i have install server.io/nvidia
but I think I had the problem a little before (not sure 100%), but it didn't last very long a few days at most.
 

I understand and thank you, but teamviewer gives full control and I am root on unraid.
i have work and all my life on it.
I would like to share my screen but without control, i could apply the orders as and when requested...

I hope you understand ?

i understand
the reason i wanted to do teamviewer instead of writing instructions, is that im unsure of what instructions to give or how to phrase them :$

i understand your concern about giving me controle, i would be okay with doing it without controle

whenever you want to do this just pm me :)

Share this post


Link to post

a big thank for resolv my problem... with only 3 lines of code... :)
 

Share this post


Link to post

Update
This update fixes a lot of things
One being that if prefs file did not exist docker-tab/dashboard would not work. Dont know if this is cause of the issue with folders not loading or another one.

If you're still having issues please post and i will try and figure it out^_^
thanks troyan for helping fix it :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.