[Plugin] Docker Folder


420 posts in this topic Last Reply

Recommended Posts

I added  OnlyOffice Community server to my unRaid. Afterwards, I couldn't stop / start /restart, etc.  This was the same for all applications under Docker when trying each one individually. If I clicked any function like start or stop it the mini menu would freeze and nothing would happen.

 

Squid recommended removing Docker Folder, when I went to remove it I noticed a new update pushed out today. Instead of removing I updated it to v2020.05.06. This fixed it.

This was the original submission:

 

https://forums.unraid.net/topic/91994-unraid-gui-docker-apps-canot-start-stop-remove-individually/?tab=comments#comment-852609

Link to post
  • Replies 419
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Docker Folder lets you create folders for docker containers to help with your organization, especially useful if you're using docker-compose. How to install: Can be found in Community Applic

Update Add new expansion button Add docker preview Thanks again @hernandito for the visuals, tried my best to make it look like it   If you think something looks of pl

here is a quick and dirty Photoshop of what I describe above. Perhaps the line w/ the icon can have a show/hide toggle... or the icons are semi transparent (if too cluttered), or made grey scale. When

Posted Images

I still cant actually create a folder. 

 

I tried updating and importing old folders, and i also tried creating new folders, but neither seem to work. 

 

I am free to teamviewer generally between the hours of 8:30 pm UTC to 5 am UTC. But i might be able to do something like 11 am UTC for half an hour but that would be day dependant and i probably wouldn't know until the day.

 

Cheers

Link to post

Hey there!

Just found this and absolutely love it. However I have found one minor bug (not sure if it's been reported yet). Ram usage for the folder view is being calculated wrong, it's not seeing GiB of ram, instead it's treating everything as MiB. You can see an example here in the attached photo.

Capture.PNG

Link to post
Just now, Mitch.Petersen said:

Hey there!

Just found this and absolutely love it. However I have found one minor bug (not sure if it's been reported yet). Ram usage for the folder view is being calculated wrong, it's not seeing GiB of ram, instead it's treating everything as MiB. You can see an example here in the attached photo.

Capture.PNG

This has not been reported yet, but i do know about it.
When i was writing that part i tried to calculate it but got a bit annoyed so decided to just leave it at MiB :$
Will add it to my todo list, so in the next few days should be fixed ^_^

Link to post
1 hour ago, GuildDarts said:

This has not been reported yet, but i do know about it.
When i was writing that part i tried to calculate it but got a bit annoyed so decided to just leave it at MiB :$
Will add it to my todo list, so in the next few days should be fixed ^_^

Appreciate it, no rush. It's not that big of a bother

Link to post
19 hours ago, GuildDarts said:

Update
This small update should hopefully fix the last issue, involving docker.folder not working at all.
Sorry if anyone has lost their folders during all this :(
Thanks @GooseGoose for helping find the issue

Thanks again for helping sort this out! Sorry about the other server issues i had! 

Link to post

Hey guys,

 

Not sure if this is just me or there's a bug, sometimes when i click on the docker tab, the docker list loads without the folder, click it again, and it will have them. But it appears to swap every click or two.

 

Edit::
Now that i have put all dockers into folders, it doesnt seem to show the folders at all. 10 refreshes, and a logout still not getting folders to show.

 

Edit2::

So after trying to start a docker, page refreshed and now i have folders, so i dont know whats going on. seems to swap back and forth continuously.

 

Any one having this issue?

Edited by Natcoso9955
Link to post
28 minutes ago, Natcoso9955 said:

Hey guys,

 

Not sure if this is just me or there's a bug, sometimes when i click on the docker tab, the docker list loads without the folder, click it again, and it will have them. But it appears to swap every click or two.

 

Edit::
Now that i have put all dockers into folders, it doesnt seem to show the folders at all. 10 refreshes, and a logout still not getting folders to show.

 

Edit2::

So after trying to start a docker, page refreshed and now i have folders, so i dont know whats going on. seems to swap back and forth continuously.

 

Any one having this issue?

hey
i have had one user report issues with folders not loading, but i have not been able to figure it out.
Your edit2 gave me a clue, it might be that the folders dont get loaded before the loadlist command gets run (loadlist is what loads in the entire page)
will try and make everthing into a folder like you did in edit and see if it breaks for me.

sorry for the inconvenience

edit:
Yeah looks like folders are not loading before loadlist triggers.
will fix this in the next update, should be within the next 24hours (its 3am for me so im going to bed)

Edited by GuildDarts
result
Link to post
53 minutes ago, GuildDarts said:

hey
i have had one user report issues with folders not loading, but i have not been able to figure it out.
Your edit2 gave me a clue, it might be that the folders dont get loaded before the loadlist command gets run (loadlist is what loads in the entire page)
will try and make everthing into a folder like you did in edit and see if it breaks for me.

sorry for the inconvenience

edit:
Yeah looks like folders are not loading before loadlist triggers.
will fix this in the next update, should be within the next 24hours (its 3am for me so im going to bed)

All good,

Glad i could help, If you cant replicate, let me know what info, logs etc you need.

 

This is such a great plugin.

Link to post

Update

  • Memory load should now display MiB GiB, heck this baby will go up to Yobibyte xD @Mitch.Petersen
  • Fixes an issue with not waiting for folders to load. The way i fixed this can potencaily cause folders to load in later than dockers, will look for a way to fix that but for now better than not loading at all ^_^ @Natcoso9955
  • Dashboard expanded will now also work with more than 3 rows of dockers, for those of you using CA Dynamix Unlimited Width
Link to post
9 hours ago, GuildDarts said:

Update

  • Memory load should now display MiB GiB, heck this baby will go up to Yobibyte xD @Mitch.Petersen
  • Fixes an issue with not waiting for folders to load. The way i fixed this can potencaily cause folders to load in later than dockers, will look for a way to fix that but for now better than not loading at all ^_^ @Natcoso9955
  • Dashboard expanded will now also work with more than 3 rows of dockers, for those of you using CA Dynamix Unlimited Width

Can confirm it loads every time now, depending on load speed you sometimes see the list and then everything collapses into folders. But it works :D Thanks so much for the fix so quickly.

Link to post
17 hours ago, Natcoso9955 said:

Can confirm it loads every time now, depending on load speed you sometimes see the list and then everything collapses into folders. But it works :D Thanks so much for the fix so quickly.

Great that its working ^_^
im thinking that the main reason why its taking long to load, is that i store the icons in the folders.json file and that bloating the file size.

could you export your folders (add folder -> import/export -> export all folders)
then either add the file to a post or you can check
1. how many custom icons there are, will be the lines that start with "icon": "data:image\/......
2. the size of the exported json file

Link to post
On 5/11/2020 at 4:51 AM, GuildDarts said:

Great that its working ^_^
im thinking that the main reason why its taking long to load, is that i store the icons in the folders.json file and that bloating the file size.

could you export your folders (add folder -> import/export -> export all folders)
then either add the file to a post or you can check
1. how many custom icons there are, will be the lines that start with "icon": "data:image\/......
2. the size of the exported json file

When i say its slowish to load, i mean literally the difference of like 0.5-1 second.
Sometimes i dont even see the list its immediately folders, on the rare occasion i see a bleep of the list and then its folders.

 

Nothing you need to fix, if others experience a much longer load time id look at it, but under 2 second delay, probably just network latency. 

Link to post

Hi,

 

Love this plugin. However I would like to propose a design modification. The height of the Docker Folder line is too big. Everything is crammed on the left. I propose you move the expansion chevron button to the right in order to reduce the height. You have so much blank space on the right, and it looks odd when seeing with the regular individual Docker. Please see attached image.

 

Also, what if you add on the right a list of the dockers housed in that folder. It would have to be bulleted list or some alternate design to differentiate it from the regular individual docker line. I will try to play with Photoshop to see if I can illustrate the idea.

 

Please let me know your thoughts.

 

Thanks for the awesome plugin. I can now imagine implementing all those Grafana dockers... I could not stand seeing all these independent grafana support dockers in my list.

docker-folder.jpg

Edited by hernandito
grammar
Link to post

here is a quick and dirty Photoshop of what I describe above. Perhaps the line w/ the icon can have a show/hide toggle... or the icons are semi transparent (if too cluttered), or made grey scale. When you toggle the chevron to expand, perhaps the icons disappear.

 

Docker-Folder2.jpg

Edited by hernandito
Link to post
3 hours ago, hernandito said:

here is a quick and dirty Photoshop of what I describe above. Perhaps the line w/ the icon can have a show/hide toggle... or the icons are semi transparent (if too cluttered), or made grey scale. When you toggle the chevron to expand, perhaps the icons disappear.

 

Docker-Folder2.jpg

First of lets me just say thanks for the amazing visuals and suggestions

About the expansion chevron never noticed as i just leave mine in advanced view, but yeah thats alot of wasted space xD
I also love the idea of having a preview to the side, think i will add both with and without icons and give the user the option to decide

Thanks again for the great suggestions ^_^

Link to post
20 minutes ago, GuildDarts said:

First of lets me just say thanks for the amazing visuals and suggestions

About the expansion chevron never noticed as i just leave mine in advanced view, but yeah thats alot of wasted space xD
I also love the idea of having a preview to the side, think i will add both with and without icons and give the user the option to decide

Thanks again for the great suggestions ^_^

 

That is great...! perhaps the icon can also have a choice of being the same color ones, and making them greyscale/transparent. It may become too busy visually in full color versions. But not sure how that would work if using the Dark UI Theme.

.... and thank you!!!

Docker-Folder3.jpg

Edited by hernandito
Link to post
2 minutes ago, hernandito said:

 

That is great...! perhaps the icon can also have a choice of being the same color ones, and making them greyscale/transparent. It may become too busy visually in full color versions. But not sure how that would work if using the Dark UI Theme.

.... and thank you!!!

When you say 'icon can also have a choice of being the same color ones'
do you mean that the icons in the preview should be selected based on matching colors?

about greyscale/transparent will see how busy it gets and then got from there :)

Link to post
1 minute ago, GuildDarts said:

When you say 'icon can also have a choice of being the same color ones'
do you mean that the icons in the preview should be selected based on matching colors?

about greyscale/transparent will see how busy it gets and then got from there :)

I just added an image above with the greyscale and transparent icons.

Link to post

Update

  • Add new expansion button
  • Add docker preview

d5qifn37.thumb.png.158fe762877099bcecd6aa40061cb960.png


Thanks again @hernandito for the visuals, tried my best to make it look like it ^_^ 
If you think something looks of please tell me and i will try to fix it:)
 

A few extra things
I could make the old button not take the extra space like this (looks a bit odd)
zDWZNSRb.png.0e58d05dcc43d0736f7241b32e9f802a.png

Another thing is that if you have a few folders it starts to take a while to change the same setting on all of them. Maybe i should add a way to change the same setting on multiple folders

Edited by GuildDarts
Link to post
8 hours ago, GuildDarts said:

Update

  • Add new expansion button
  • Add docker preview

d5qifn37.thumb.png.158fe762877099bcecd6aa40061cb960.png


Thanks again @hernandito for the visuals, tried my best to make it look like it ^_^ 
If you think something looks of please tell me and i will try to fix it:)
 

A few extra things
I could make the old button not take the extra space like this (looks a bit odd)
zDWZNSRb.png.0e58d05dcc43d0736f7241b32e9f802a.png

Another thing is that if you have a few folders it starts to take a while to change the same setting on all of them. Maybe i should add a way to change the same setting on multiple folders

Very exciting.....

 

I upgraded but it still shows the previous layout. I go to the setting and not sure how to enable/configure.

 

thank you

 

h

Link to post
1 minute ago, hernandito said:

Very exciting.....

 

I upgraded but it still shows the previous layout. I go to the setting and not sure how to enable/configure.

 

thank you

 

h

It should hopefully be under 'ADVANCED VIEW'
i have added extra options there just so it's a bit less cluttered (not the most intuitive :$)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.