[Plugin] Docker Folder


420 posts in this topic Last Reply

Recommended Posts

2 minutes ago, cback said:

Still no luck, even if it seems like the items stay in place for a refresh or two, a few folders will disappear and after a couple refreshes they'll show up again and the folder order will be randomized.

Very strange. You are not getting any errors in browser console right?
I'm a bit unsure as what might be the issue. If you're not getting any errors would you be willing to do teamviewer?

Link to post
  • Replies 419
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Docker Folder lets you create folders for docker containers to help with your organization, especially useful if you're using docker-compose. How to install: Can be found in Community Applic

Update Add new expansion button Add docker preview Thanks again @hernandito for the visuals, tried my best to make it look like it   If you think something looks of pl

here is a quick and dirty Photoshop of what I describe above. Perhaps the line w/ the icon can have a show/hide toggle... or the icons are semi transparent (if too cluttered), or made grey scale. When

Posted Images

8 hours ago, GuildDarts said:

Very strange. You are not getting any errors in browser console right?
I'm a bit unsure as what might be the issue. If you're not getting any errors would you be willing to do teamviewer?

Nope no action in browser console. Perhaps we could hop in a Discord screen share tomorrow?

Link to post
On 6/7/2020 at 11:08 PM, GuildDarts said:

Yeah i don't think this is an issue with docker.folder, not trying to shift blame

It does not make any sense to me why after you remove the plugin that its still in the plugins tab.
The only thing i can think of is to manual make the plugin folder and put the docker.folder.plg in the folder and see if can uninstall.

Could you maybe make a new post under general support and ask why you cant remove plugin as i have no clue. Maybe someone more knowledgeable can answer

Sorry for not being of more help just really have no idea and this is a bit out of my comfort zone.

Edit:
Something that might be worth a try is a restart. As i think that all plugins get installed on startup. So since you removed all the files from the flash it won't be able to install.
Tried deleting my docker.folder.plg and got the same plugin with missing icon thing.
227343764_Annotation2020-06-08045612.thumb.png.7fb43850f1ed34ff241bb94edfe84578.png

One week offline due to isp failure. 

I finally managed to remove and reinstall the plugin. I think my server was in a weird state. I have to reboot to often to my taste due to problem with emhttp. 

It seems i have the same problem than before : i can add folders and edit them but not all folders appear.

When i edit a folder i can see all dockers and the folder they belong to but on the docker page i can not see them all.

 

Capture d’écran 2020-06-15 à 15.52.54.png

Capture d’écran 2020-06-15 à 15.53.51.png

 

 

edit: when i export folders i can see them all.

Edited by caplam
Link to post
26 minutes ago, caplam said:

One week offline due to isp failure. 

I finally managed to remove and reinstall the plugin. I think my server was in a weird state. I have to reboot to often to my taste due to problem with emhttp. 

It seems i have the same problem than before : i can add folders and edit them but not all folders appear.

When i edit a folder i can see all dockers and the folder they belong to but on the docker page i can not see them all.

 

Capture d’écran 2020-06-15 à 15.52.54.png

Capture d’écran 2020-06-15 à 15.53.51.png

 

 

edit: when i export folders i can see them all.

One week do to ISP that a long time holy moly

 

It's very weird that "DOMOTIQUE" folder is not displaying


Do you get any errors in browser console when loading the docker page, also does it only happen on the docker page or does it also not display on the dashboard

Edited by GuildDarts
Link to post
  • 2 weeks later...

Hello,


just tried to install your addon but found out that I'm not able to correctly order my containers. When I order containers in one group it'll shuffle other group and vice-versa. Is there some way how to do it? I have quite a few containers depending on startup order so it's showstopper for me.

Link to post
50 minutes ago, bambi73 said:

Hello,


just tried to install your addon but found out that I'm not able to correctly order my containers. When I order containers in one group it'll shuffle other group and vice-versa. Is there some way how to do it? I have quite a few containers depending on startup order so it's showstopper for me.

Yeah that's not supposed to happen.
one thing you could try is "reset sorting" i know its not ideal but sometimes that fixes things
reset.thumb.png.26c76700ac9addecba79cc071e214bd8.png
 

hope that fixes if not i will think i bit hard about what might be causing it:)

Link to post
18 hours ago, GuildDarts said:

Yeah that's not supposed to happen.
one thing you could try is "reset sorting" i know its not ideal but sometimes that fixes things
reset.thumb.png.26c76700ac9addecba79cc071e214bd8.png
 

hope that fixes if not i will think i bit hard about what might be causing it:)

Tried that but it doesn't help. It simply sorts dockers alphabetically by name.

When I try arrange my groups then same happen again.

 

Order after I arrange DB folder

arrange-db.thumb.jpg.38f47d98edff6c9d8482f724ef0c7f44.jpg

DB is ok, but IOT is shuffled.

 

Order after I arrange IOT folder

arrange-iot.thumb.jpg.5c03b0dd299a3847fd4059c9af35f25a.jpg

IOT is ok, but DB is shuffled.

 

What I noticed is that it isn't random shuffle but it always ends in same, but anyway wrong, order. I tried to find what order is used but without success.

 

Link to post
5 minutes ago, bambi73 said:

Tried that but it doesn't help. It simply sorts dockers alphabetically by name.

When I try arrange my groups then same happen again.

 

Order after I arrange DB folder

arrange-db.thumb.jpg.38f47d98edff6c9d8482f724ef0c7f44.jpg

DB is ok, but IOT is shuffled.

 

Order after I arrange IOT folder

arrange-iot.thumb.jpg.5c03b0dd299a3847fd4059c9af35f25a.jpg

IOT is ok, but DB is shuffled.

 

What I noticed is that it isn't random shuffle but it always ends in same, but anyway wrong, order. I tried to find what order is used but without success.

 

So just tried sorting my folders and also got the reset of sorting.
Will be sure to fix this by next update ^_^ (should be in 1-2 days)

Link to post

@GuildDarts Checked new version and after quick test it looks like shuffle problem was solved. But another one appeared :)

 

When I create and arrange folders it looks like

folders-created.thumb.jpg.633a8eb2b64ff4dd702e997b3bf91cda.jpg

 

But when I refresh page or go somewhere else and back folders itself reorders like 

folders-refresh.thumb.jpg.1df936e09ae5b50ad335a3898021bae0.jpg

 

It looks like presentation problem because when I check Dockerman userprefs.cfg order of folders and containers is correct

userprefs.jpg.e9db01992bb6145c575768276243021b.jpg

 

Problem happen if folder is touched (modified) in this state because order is then persisted as it is (in wrong state).

 

Additional questions/notes:

  • Is font size for folder names intentional? I plan to combine folders with regular containers so bold font with double size looks really weird.
  • Is it really necessary to have folder name different than existing container? From userprefs.cfg it looks like folder is using "-folder" postfix so I'm curious. In pictures above I'd like to name iot folder home-assistant because it's basically it + some supporting plugins.
  • You should add check for dot in folder name. It completely destroy plugin and isn't recoverable without manual editing (probably) or reinstall :)
Link to post

@bambi73 should be fixed now, thanks for the excellent info ^_^
 

2 hours ago, bambi73 said:

Is font size for folder names intentional? I plan to combine folders with regular containers so bold font with double size looks really weird.

It is indeed intentional, you can change the "Docker icon style" to "docker" and it will look like any old docker :)
Alternative if you just wanna change the font you could use Theme Engine and use the "
Enable custom styling" to modify the "label-tab" class font
folder-style.png.75628fdb9127a3a9716253e9a4ff6fc4.png

2 hours ago, bambi73 said:

Is it really necessary to have folder name different than existing container? From userprefs.cfg it looks like folder is using "-folder" postfix so I'm curious. In pictures above I'd like to name iot folder home-assistant because it's basically it + some supporting plugins.

I added the popup preventing you from using a docker name, because the folder was just not loading when using the same name as a docker, and i was lazy that day so did not wanna figure out why :P
I have also been asked to allow spaces and other such characters, so if i ever do that will hopefully remember to also fix this then
Note while you cant use "home-assistant" you can use "Home-assistant" as a temp fix

2 hours ago, bambi73 said:

You should add check for dot in folder name. It completely destroy plugin and isn't recoverable without manual editing (probably) or reinstall :)

Forgot to add this just now when i updated, big ups way to late for me. Will add next update :D
the reason its breaking is that i'm using the folder name as a class in a few places

Edited by GuildDarts
Note
Link to post
9 hours ago, poniz said:

Hey @GuildDarts would it be possible to add a "Expand all" and "Hide all" button on the docker page for all the folders?

 

side note the advanced context menu is fuckin sweeeeet! thank you @hernandito and @GuildDarts 

glad that you like the advanced context menu, was a lot of fun the make ^_^
It would very much be possible to add "Expand all" and "Hide all" button, my only question is where. Do you have any place in mind on the docker page? (i cant really think of a good place)

Edited by GuildDarts
Link to post

@GuildDarts looks good now. Only one small glitch remaining 🙃

When folder name is changed folder is always placed on top of the list. Changes to other folder properties doesn't cause this behavior so it's only minor issue.

 

Thanks for answering my questions. Somehow I thought that "Docker icon style" only affects design of folder itself. I switched to "Docker" because it better suits my tastes :)

 

Potential problems:

  • From observation it looks like Advance context menu is able to gather cpu/mem data only when Advanced view is selected. If it isn't possible to gather data in Basic mode then it'll be probably better to grey out cpu/mem indicators and graphs or leave them completely. Graphs stays on last known value and so it looks weird.
  • Looks like gathering data for graphs is quite CPU hog. My current desktop is really crappy so probably for newer computers it isn't problem but it could be problems for phones/tablets.
  • From CPU workload it looks like it gathers data even in Basic mode when it gets static values, so there is potential for optimization.

Potential improvements:

  • Make folder name clickable and linked to edit mode (same behavior as regular container names)
  • Somehow show which container in the folder has update available without necessity to open whole list. Maybe use different color (same like for "update ready") for container name. I don't have any better proposal :)
  • Make container icon in Advanced context menu not clickable. At the moment it opens standard container context menu which isn't really necessary (as all links are already available) and additionally it opens below your popup.
Link to post
11 minutes ago, bambi73 said:

When folder name is changed folder is always placed on top of the list. Changes to other folder properties doesn't cause this behavior so it's only minor issue.

This should be fixable forgot to make it also rename in the userprefs.cfg :)

 

13 minutes ago, bambi73 said:

Thanks for answering my questions. Somehow I thought that "Docker icon style" only affects design of folder itself. I switched to "Docker" because it better suits my tastes :)

 

@hernandito pointed out to me that you might be taking about the docker names in the preview having bold text. If that's the case then that's a bug they are not supposed to be bold.
 

 

16 minutes ago, bambi73 said:

From observation it looks like Advance context menu is able to gather cpu/mem data only when Advanced view is selected. If it isn't possible to gather data in Basic mode then it'll be probably better to grey out cpu/mem indicators and graphs or leave them completely. Graphs stays on last known value and so it looks weird.

Yeah also spotted this bug. There is probably a way for me to make it get the data even in basic view.

 

17 minutes ago, bambi73 said:

Looks like gathering data for graphs is quite CPU hog. My current desktop is really crappy so probably for newer computers it isn't problem but it could be problems for phones/tablets.

Yeah i know it's not the most optimized thing ever, will ofcoure try and make it better but its never gonna be great. Might want to have an option to disable on mobile or if the device is not that powerfull

 

21 minutes ago, bambi73 said:

Make folder name clickable and linked to edit mode (same behavior as regular container names)

21 minutes ago, bambi73 said:

Somehow show which container in the folder has update available without necessity to open whole list. Maybe use different color (same like for "update ready") for container name. I don't have any better proposal :)

Will do both of these ^_^
 

23 minutes ago, bambi73 said:

Make container icon in Advanced context menu not clickable. At the moment it opens standard container context menu which isn't really necessary (as all links are already available) and additionally it opens below your popup.

will also fix this, thought i had done itO.o

Link to post

Decent plugin, I like the organization aspect of it. A couple issues I have though:

1. When editing a folder, if the docker repository shows a long string, such as the sha256 version, the check-marks aren't in the correct place.

 bVQjAZdCQWWQA8wOuB_BBg.png

2. Unlike usual, where everything is shown on the screen properly, when having a lot of dockers in a folder, it gets a bit inconvenient and forces you to scroll left and right as well to see more information per docker. For example, I have 8 dockers in a folder and it goes off page forcing me to scroll to the right to see the CPU/Memory Load, Autostart and Logs. It would be nice if there were a way to fit all of this on the page so it doesn't stretch out of the full width.

2P9Cn9ZYQbi_yfRmv3MqvQ.png

Edited by Jad
Link to post
9 hours ago, Jad said:

1. When editing a folder, if the docker repository shows a long string, such as the sha256 version, the check-marks aren't in the correct place.

9 hours ago, Jad said:

2. Unlike usual, where everything is shown on the screen properly, when having a lot of dockers in a folder, it gets a bit inconvenient and forces you to scroll left and right as well to see more information per docker. For example, I have 8 dockers in a folder and it goes off page forcing me to scroll to the right to see the CPU/Memory Load, Autostart and Logs. It would be nice if there were a way to fit all of this on the page so it doesn't stretch out of the full width.

will fix both of these :)
about 2. im only getting a small bit of having to scroll, it's not the same as in your picture where half the page taken
i thought it might be that long sha265 adding space, so i replaced the "by:" text with it and got similar results.

 

default.thumb.png.b611a3593a7150428f58524e477d270b.pngsha.thumb.png.3e271309bff6ed900e9e010ac4d81781.png

Link to post

Update

  • Added: preview update text
    the option is called "Make text orange on update"
  • Change: Click folder name to edit folder
  • Fixed: not getting data in basic view
    By default in unraid it stops getting the data when in basic view. I just made it get it even in basic view, however i cloud optimize it by only getting it for the dockers that are in folder with advancec context enabled
  • Fixed: label-tab making preview bold
  • Fixed: items not showing in advanced/basic view
  • Fixed: Prevent opeing default context menu in advanced
  • Fixed: Advanced context style fixes
  • Fixed: preview icon causing horizontal scroll
  • Fixed: folder page text overflow
  • Fixed: preview/advanced context status not animating
  • Fixed: renaming folder reseting sort order

@bambi73 i think this update addresses everything you pointed up in your post above (except for the performance). Thanks again for your detailed post ^_^

@Jad your issues should hopefully also be fixed :)

Edited by GuildDarts
Link to post

Folder editor is fixed, nice!

On the docker list page, the only issue now is that the version could show a long string and reproduce the issue of the page stretch. For example:

Bypdh7UdRPi5YZtAJ1hlxg.png

You may notice this is abnormal behavior, which it likely is. Some of my dockers aren't added via Unraid, so they show values like this, but the dockers still work perfectly fine.

Edited by Jad
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.