Jump to content
Ryan911199

Can not get USB controller to work in windows.

2 posts in this topic Last Reply

Recommended Posts

I have been working on soling this for the past few days now and i have managed to not fix the problem so if any of you have any ideas it would be greatly appreciated. 

 

I am attempting to run a windows VM on my unraid server with a GTX card and USB controller. I can get everything to work until i try and pass the usb controller. if i try and boot the VM with something plugged in to the controller it boots (sometimes making it to the login screen) then it pauses. i am unable to start the vm again it says "unable to execute QEMU command 'cont': Resetting the Virtual Machine is required". However if i pass the card with nothing plugged in then it boots and works like it should until i plug something in to the card and it freezes again with the same error message. I have tried moving the card around on the motherboard, updating the bios, making sure all settings allow virtualization. if you all have any ideas on how to fix it please let me know.   

Share this post


Link to post

Install vfio-pci config plugin and then Settings -> VFIO-PCI.CFG and then look for your usb controller.

If there's no reset capable icon (RESET column, on the left of VENDOR ID) then the controller can't be used for passing through to a VM unfortunately.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.