Jump to content
Cpt. Chaz

Interface Ethernet Port 0 is down. Check cable! (SOLVED)

8 posts in this topic Last Reply

Recommended Posts

Hello all! Thanks for taking the time to read here - with the lockdown happening, I figured this was a good time to do some maintenance.

 

My issue is not high priority per se, as i'm not really having any operational issues here (although i couldn't get pfsense vm working and i suspect this is the cause). On my network settings, i'm getting an error in red at the bottom of the page:

 

Interface Ethernet Port 0 is down. Check cable!

 

This all started after i switched machines last year, i went from a desktop sff pc to a Dell R720 server, so essentially went from only have 1 nic to 4. On the new r720, it came with a SAS HBA assigned to ports 0,1, while regular 1gb ethernet is assigned to ports 2,3. I had gone into the idrac settings on the dell itself and tried to disable the sas controller, hoping unraid would just assign port 0 to the ethernet port i'm actually using. This didn't work though. Currently, i have ethernet plugged into port 2 with seemingly full functionality, minus the error.

 

I had gone into the network settings a while back (somewhere around 6.7.9 and 6.8) and tried troubleshooting with different settings and never had any luck resolving it. i've attached screen shots and logs, if anyone cares to take a look, would be much appreciated getting this sorted. Thanks in advance!

 

kal-el-diagnostics-20200325-1018.zip

Interface eth0.png

Interface eth1-3.png

Interface Rules and Routes.png

Edited by Cpt. Chaz
solved

Share this post


Link to post

GUI is warning you that eth0 link is down:

Settings for eth0:
    Supported ports: [ FIBRE ]
    Supported link modes:   1000baseT/Full
                            10000baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: No
    Supported FEC modes: Not reported
    Advertised link modes:  10000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: No
    Advertised FEC modes: Not reported
    Speed: Unknown!
    Duplex: Unknown! (255)
    Port: FIBRE
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: off
    Supports Wake-on: g
    Wake-on: d
    Current message level: 0x00000000 (0)
                   
    Link detected: no

 

Lan is still working because eth2's link is up and you have a all NICs bonded.

 

BONDNICS[0]="eth0 eth1 eth2 eth3"

 

Share this post


Link to post

I know eth0 is down, that’s what I’m trying to resolve. They’re bonded now because it just happened to be one of the things I tried during troubleshooting. It didn’t resolve the eth0 problem, I just didn’t want to stop the array again to undo it since it didn’t seem to make a difference either way. But even if the nics aren’t bonded, lan still works, eth0 shows down. 
 

if you’d like to see screenshots or logs of different configurations here, or even a specific one, I’d be happy to oblige. Thanks for the time 

Share this post


Link to post

The error is generic when there is no link.

If you expect network through that port but link is down, the noob mistake is not pluggin it in, hence the error says "check cable".

 

I had that same red error on my dual NIC because obviously I only plugged 1 port in. Other than being OCD annoying because it's in red, there's nothing really to deal with.

 

Share this post


Link to post
7 hours ago, johnnie.black said:

Set eth2 as eth0, you can do that by swapping them on "interface rules", reboot is need to take effect.

couldn't see the forest for the trees here. thanks for this!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.