All USB devices have disappeared

Recommended Posts

I plugged an external USB drive into my server with plans to copy the content to a share.  A few minutes later I went to logon to the web interface and it only shows the menu headers - nothing works.  In looking into this trouble I found others with trouble because their USB flash drive had failed.


In my case - I don't see any USB devices at all using lsub from the command line.  I used to see the flash drive and any external USB storage I had plugged in.  I first tried the external hard drive on another computer and it comes up just fine there.  I then tried my USB Flash drive that has unraid on it and it also works on another computer.  Neither show up when I plug them into the unraid server.


I'd just reboot but I just finished a parity check yesterday and don't really want to have to start over again.  Is there any way to properly shutdown unraid from the command line so it is 'clean'?


Maybe a way to reset the USB buses without restarting?


Anyone run into this before?



Link to comment

Thanks for the quick response!  So using powerdown won't require the parity check to run again?  I ask only because I have a faint memory of using powerdown years ago when the web interface crashed and it required a parity check.  Could be that my memory is failing me!  Or maybe I used shutdown back then rather than the powerdown script.


Link to comment

Great - thank you! 


Have you ever had the boot USB drive (and all the others) just disappear like this?  It doesn't matter what USB device I plug in - none of them are recognized.


I'm not sure what to blame for the trouble.  Its strange because the motherboard has two USB controllers - one for 4 USB 2.0 ports and one for 4 USB 3 ports.  None of the 8 ports work when I plug a known good USB drive in.  

Link to comment

Damn...  Started right back up and all the USB devices are working again.  Parity check started.


Had a bunch of errors scroll by as it shutdown.  I suspect because it couldn't find the USB Flash drive that has unraid installed on it.


I'll just have to live with another 24 hours of parity check.  I just wish I knew what caused the trouble to begin with.

Link to comment
53 minutes ago, Dissones4U said:

I've actually been meaning to ask about this, is the information in this link still accurate?


Way out of date.  That doesn't consider any of the various other services (docker, vm's, etc) running.  Although on a rare occasion a seriously crashed container can prevent the docker.img from unmounting  So you would do

umount -f /var/lib/docker


  • Thanks 1
Link to comment

If the flash drive drops then you are guaranteed a parity check when the system boots back up, because there is no way for the shutdown process to write the flag to the flash drive that says it was a clean shutdown. It is still a good idea to try and shut down as gracefully as possible though (i.e. run the powerdown command) to minimize the chance that there will be an actual problem with the array.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.