[SOLVED] WebUI is messed up


Recommended Posts

UnRaid 6.8.3 with Nvidia GPU enabled

 

Hey Everyone... I was trying to add some new disks that were not formatting correctly so i added the "unassigned Devices" plugin and "binhex-preclear" to my box... something got horked and now my UI looks like gunk and this message is showing:

 

Warning: parse_ini_file(/boot/config/plugins/dynamix/dynamix.cfg): failed to open stream: Success in /usr/local/emhttp/plugins/dynamix/include/Wrappers.php on line 22 Warning: array_replace_recursive(): Expected parameter 2 to be an array, bool given in /usr/local/emhttp/plugins/dynamix/include/Wrappers.php on line 22 Warning: extract() expects parameter 1 to be array, null given in /usr/local/emhttp/plugins/dynamix/include/DeviceList.php on line 24

 

it got funky as soon as i added the binhex-preclear plugin so i stopped the plugin and removed it, but still no love. I uninstalled the dynamix plugin and rebooted, reinstalled the dynamix plugin, rebooted again, still getting the wierd messages.  Everything else is working fine though, all of the docker containers seem to function fine. Is there an easy way to just update UnRAID to get the system back to its "normal" state?

 

Thanks

Drabert

Capture.PNG

Link to comment

Backup flash drive, recreate a new flash with the USB tool, restore only super.dat and the key (both on the config folder), it should now boot correctly like that, than either restore the other settings a few at time until you find the problem or just reconfigure the server.

Link to comment

Sorry. I have not had a chance to fix it yet.  The system is still running fine, the GUI is just fugly :) Hoping to try to do what you all recommended this evening to see if that resolves my issue... it just took a while to get it all working, and I am afraid that something during the reinstall will nuke the VMs i have already created.  I am running the NVIDIA branch of 6.8.3... was thinking of just reverting back to the stock 6.8.3 to see if that rebuilds whatever is stuck and then redo NVIDIA.  Would that work too?

Link to comment

So i went ahead and reinstalled unRaid, added the License key and super.dat to the new image.  The UI is back to normal, but now i lost the ability to "edit" all of my docker components and a couple of them are failing to start.  I went back and also added the files in /config/plugins/dockerMan/templates-user/ and i was able to edit the components again.  I am installing the NVIDIA plugin right now... thank you for the help!

Link to comment
  • JorgeB changed the title to [SOLVED] WebUI is messed up

This empirically is due to the binhex-preclear install but only indirectly.  When you install that plugin it asks you for volume mounts to give to the underlying docker daemon for mounting inside the docker container.  Host Path 6 is /boot/config/plugins/dynamix/dynamix.cfg.  This *should* be a file, I'm assuming, but didn't exist on my unraid.  When you give docker a path that doesn't exist it will automatically create a folder given that path.  So when I installed binhex-preclear the docker daemon created the folder /boot/config/plugins/dynamix/dynamix.cfg/  If you make this folder and refresh your WebUI you will see that it generates php errors described above.

 

The *easiest* fix is:

 

1.  Uninstall the binhex-preclear plugin/app

2.  remove that path from your dynamix plugins folder (or at the very least move it to another name that *doesn't* end in .cfg)

     *  You can move the offending directory out of the way via the terminal with the command:

         * mv /boot/config/plugins/dynamix/dynamix.cfg /boot/config/plugins/dynamix/dynamix.cfg.broken

     *  Or if you want to remove it

         * rmdir /boot/config/plugins/dynamix/dynamix.cfg

3.  Now refresh the WebUI and you'll see the errors are gone.

 

 

Now if you want to reinstall the binhex-preclear plugin you should first create that file that the plugin wants to pass through to the docker container.  From the terminal run the command:

 

touch /boot/config/plugins/dynamix/dynamix.cfg

 

[EDIT] Squid pointed out that if you make changes within Settings -> Display Settings this will create the file /boot/config/plugins/dynamix/dynamix.cfg so there's no need to enter the terminal if you don't want to.

 

Then proceed with the install as you normally would and things should operate just fine.

Edited by imsplitbit
  • Thanks 3
Link to comment

That's probably true.  I'm very new to unraid but have been a linux systems engineer for 20 years so I'm happy to help folks when/where I can.  This array is only about 12 hours old but it did have issues immediately following the install of binhex-preclear.  After reading this thread I was about to do a backup and restore as detailed above but thought I'd spend a little time digging into the problem to see if all of that was necessary.

Edited by imsplitbit
  • Like 1
Link to comment

thanks for the detailed debug @imsplitbit, i was not aware that the dynamix.cfg could not exist, i assumed some default values would always be required and thus the file would be generated, my bad.

 

ok simple fix for this is to switch the volume mount point so that it no longer points at a specific file but the folder instead, example modification (unraid docker template):-

    <Volume>
      <HostDir>/boot/config/plugins/dynamix/</HostDir>
      <ContainerDir>/unraid/config/plugins/dynamix/</ContainerDir>
      <Mode>ro</Mode>
    </Volume>

the effect is the same, it just exposes all files in that folder as opposed to just one, but as the volume is read only it shouldnt mean the risk of users accidentally messing with the host files is any greater so should be fine, sound good?.

Edited by binhex
Link to comment

for anybody following this thread, my change is now in and hostdir and containerdir are now both pointing at path rather than directly at file dynamix.cfg, i have checks already in the code to check if the file exists so that will be covered in the case where the file doesnt exist (as is the case with somebody who hasnt configured anything in unraid web ui settings).

  • Like 1
Link to comment
  • 7 months later...

Just read thru last couple pages of this thread. Seems like everything is taken care of (known bugs anyway) but was looking for some confirmation before clearing a 10TB drive with this docker. Also, my parity is currently rebuilding and the new disk is unassigned and not formatted. I guess I need to wait to stop array and format or does the preclear script also do this per my disk setting (ie MBR 4K aligned)?

 

I think I found my answer In FAQ:

 

Alignment Options (-a and -A flags)

Below is the logic built into the preclear script when determining the starting sector for the partition:-

if preclear -a option chosen and drive < 2.2TB then will set to 63.

if preclear -a option chosen and drive > 2.2TB then will set to 64.

if preclear -A option chosen and drive < 2.2TB then will set to 64.

if preclear -A option chosen and drive > 2.2TB then will set to 64.

if preclear -a or -A not defined then 63 or 64 will be chosen based on unraid config, UNLESS the drive is > 2.2TB, in which case it will always be 64.

Edited by betaman
Link to comment
5 minutes ago, itimpi said:

You must add a disk to Unraid BEFORE trying to format it as formatting a disk destroys its ‘Clear’ status.

Disk is “added” but unassigned. I want to preclear the disk so it’s ready in case of a drive failure. I just don’t remember seeing the format notice on a device before but I haven’t added or precleared a drive in quite some time!
 

00C3A1F1-0305-4B4B-9802-2036EF9A8C4E.jpeg
 

So the order of operations is preclear, format, assign?

Edited by betaman
Link to comment
4 minutes ago, betaman said:

Disk is “added” but unassigned.

Added means ADDED to the array.

 

5 minutes ago, betaman said:

So the order of operations is preclear, format, assign?

So no this is not correct. If you format the precleared disk before you assign it, then it won't be clear anymore and Unraid will have to clear it.

 

10 minutes ago, itimpi said:

You must add a disk to Unraid BEFORE trying to format it as formatting a disk destroys its ‘Clear’ status.

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.