Docker container stuck waiting for IO

Recommended Posts



I have a docker container (plexinc/pms-docker) that is "stuck" and can't be stopped, I think it's waiting for IO. Is there any way to get it out of this state without a hard reboot? I want to avoid them as much as possible, since parity checks take 20+ hours and make the system unreliable.


A little context: I am running "Unraid Nvidia", and have to GPUs, a GTX 1080 passed through to a gaming VM, and a GTX 1660 set as visible to Plex to be used for transcoding. The gaming VM also has a USB controller passed through. This is the second time that I've tried to start my gaming VM and it fails and crashes the VM manager. Much like what spaceinvader one described will happen if you're using a GPU for transcoding and then trying to start a VM with the same GPU passed through. But of course this is not my case, since I have two different GPUs for this.


Both times this has happened, Plex has failed to enter a stopped state after I try to stop it, and there is a process in ps named "wait" that can't be killed. Also, as I'm writing this, I tried to run the command "nvidia-smi", and it "hangs". As in I type "nvidia-smi" and press enter and nothing happens.


Any help investigating would be appreciated!




EDIT: This is a post I made earlier, and the hard reset I am referring to was caused by this:

Edited by rockard
Link to comment

I gave in and did a hard reset, so I guess this is more or less moot. I'm quite certain it will happen again though, so if somebody could help me understand why it happens, I'd be thankful. In the meantime, I will just keep the gaming VM on at all times, so this can't happen.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.