Windows 10 VM - Is it possible to get WSL2 to work?


13 posts in this topic Last Reply

Recommended Posts

I have a Windows 10 VM and would like to get WSL2 working on it, but nothing I try seems to work. I have an AMD Ryzen 3900X. I added kvm_amd.nested=1 to my syslinux.cfg file. I run spaceinvaderone's script to turn on nested vms, and I still get an error when I try to set up WSL2 on my Windows 10 VM. Anyone have any real luck with this? Is there something that needs to be added to unraid by the devs? Any help would be much appreciated. 

 

This is what I see when I try to install Ubuntu as the WSL2 distro:
 

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x80370102
Error: 0x80370102 The virtual machine could not be started because a required feature is not installed.

Press any key to continue...

Maybe I missed a step somewhere? 

Link to post
  • 4 weeks later...

Now that Windows 2004 is out I'm going to be playing around with this as well.

 

Thus far all my attempts (on a previous version of Windows) to get HyperV working on Windows (with Unraid 6.8.3 host) have failed. 

 

WSL2 is based on HyperV, so I don't have much hope that I'll actually get this working at the moment.

Link to post
  • 2 months later...
On 8/5/2020 at 7:42 AM, Unraid Newbie said:

i think we have the same problem. i am trying to run android emulator and hyper v

 

i am running the latest 20180 build, which suppose to fix amd nested or something. 

 

https://techcommunity.microsoft.com/t5/virtualization/amd-nested-virtualization-support/ba-p/1434841

I think the @limetech people need to fix this. The new build of Windows 10 still does not allow AMD procs to use Hyper V.

 

Link to post
  • 2 months later...
  • 2 weeks later...

I have been working on trying to get this for work for a while to get Docker to work. Yesterday it just finally worked for me. I am using `6.9.0-beta30` and a slightly modified script where I pulled out the intel parts instead of having an if statement. Shut down all your VMs and run the script below. I also have `Hyper-V` enabled. I am using a 1800x so it may be 1st v 3rd gen Ryzen, but this is the first time it has worked for me.
 

#!/bin/bash

modprobe -r kvm_amd
modprobe kvm_amd nested=1
echo "Nested vms are enabled for AMD cpus"

sleep 10
exit

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.