Wacom Tablet in VM support

Recommended Posts

I'm trying to get my Wacom Cintiq Pro 16" working in my Windows VM. I have the GPU: EVGA RTX 2080 Super FTW3 Hybrid passed through fully to the VM. For 4k support, I have to use the Type-C connection on the GPU for the tablet. In Baremetal Windows, this works fine and has no issues. However, when I boot it in a VM, it only acts as a screen (no touch functions, pen detection, and the Wacom Tablet program doesn't detect the tablet hooked up). Even if the device is powered on, at boot-up of UnRaid, it doesn't show up as a IOMMU or USB device, so I don't seem to be have an option to pass it through.


So my question is, does anyone know how to get this to work through a VM, preferably using the Type-C connector so I can have 4k support?


As far as my UnRaid setup goes, this is what I have:
Ryzen 9 3900x

AsRock x570 Taichi

EVGA RTX 2080 Super FTW3 Hybrid

Wacom Cintiq Pro 16"

NVMe drive stubbed with native Windows Install (so I can boot the same OS either Baremetal or VM on the fly).


Incidentally, this device, and a couple others are not ALWAYS hooked up, is there a way to get them to automount and passthrough to an active VM (so that they function like normal plug and play devices on baremetal)? I find it really annoying to have to reboot the VM just because I plugged my headset back in or remove devices that are not hooked up just to get the VM to boot each time.

Edited by AnhedonicNeko
Link to comment

Does which controller matter? I have several of them, and I'm not sure which one the UnRaid flash drive is on. I'll try it here in a bit. The Type-C port on the GPU is already passed through (as I needed to for the purpose of passing through the GPU as a whole)


Edit: I tried each USB controller independently and also the ones grouped together to no avail. Only one of them being passed actually let me boot the VM and didn't allow for plug and play (I tried multiple USB ports to see if it was only controlling some of them). I think it was actually the internal connectors that allowed that. The other configurations just caused either the VM to seize up UnRaid or otherwise make it so I needed to reboot UnRaid, so I'm assuming they either need additional configuration or are tied to something else that isn't/can't be forwarded properly.


Incidentally, my WiFi was able to be passed through separate from the Ethernet, but I can't seem to identify which device is the Bluetooth. The device I previously thought was the Bluetooth (a device listed in USB) disappears when I forward the WiFi (listed in PCI), so I'm guessing it was the Antenna that attaches to the WiFi?.


Regardless, still no touch/pen input on my tablet though even on the USB controller that was able to be passed through.

Edited by AnhedonicNeko
Link to comment
  • 8 months later...

I have a XP-Pen Artist 15.6 Pro ( https://www.xp-pen.com/product/65.html ) Drawing tablet with display , which I use as my primary pointing device.

On my Host System (Linux, Ubuntu ), the drivers for my Wacom are working great. I have pressure sensitivity and control over all its options.

On my Guest System (Windows 10) the Wacom does move the mouse and for the most part works fine.

However, when using Photoshop within my Guest System ( Windows 10 ), I don't have pressure sensitivity.

I downloaded the Windows drivers from XP-Pen and they installed. However, when I attempt to enter the control panel and configure the tablet, it says no compatible device can be found.

It seems there is a bit of a disconnect between VMWare Player and being able to detect the XP-Pen tablet, even though it recognizes events from the tablet for the purpose of moving the mouse.

Edited by yuanhen97
Link to comment
  • 2 weeks later...

Today I also tried to passthrough my Wacom Display with Drawing support via USB:

Bus 005 Device 003:ID 056a:00c6 Wacom Co., Ltd DTZ-1200W [Cintiq 12WX]
It does not work either as a single USB device passthrough neither on my USB Port passthrough.

Same problem as described above.

Any other ideas about that?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.