Unassigned Devices - Managing Disk Drives and Remote Shares Outside of The Unraid Array


dlandon

6094 posts in this topic Last Reply

Recommended Posts

  • Replies 6.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

New release of UD.  Changes: When changing the mount point (which is also the share name), the mount point is checked for a duplicate of a user share or another UD device.  Samba cannot handle

Major new release of UD: "Where are the switches?"  The "Pass Through", "Read Only", "Automount", and "Share" switches have been moved to a new Edit Settings dialog.  This is also where the sc

While I appreciate your interest in esthetics, there is more to consider than just 'aligning' disk drive mounts: This disk is mounted without a UD script, it is probably better to put it in th

Posted Images

1 minute ago, wgstarks said:

IIRC, exFAT should also work. You might want to test it though, just to be sure. Format it in unRAID, add some sort of test file, then hook the drive to your Mac and be sure you can read/write to the file.

Damn!  Just started formatting at Ext4

Link to post
1 minute ago, wgstarks said:

That’s what I use. Paragon software sells the ext for Mac app for about $20 I believe. Was trying to give you a free alternative though.

I appreciate that.  I'll stick with EXT4 for now and see how I get on! Thanks

Link to post

Hi. I'm trying to format a drive I will use outside of the array.  I have deleted the partitions shown for the drive in unassigned devices but...

 

1. The partition reappears

2. I don't see any option to format

 

Not sure what's going on

Link to post

I'm just setting up my first unraid system.  Prior I was running ubuntu where I had a 6-disk btrfs raid1 setup.  The hardware being used is the same, but I have a few new drives.  Currently I have the unraid array set up with dual parity and a few disks.  My question: what's the best way that I can mount my existing btrfs volume so that I can move data to the unraid array.

 

In the original post I see:

Quote

DIsks formated XFS or BTRFS will be partitioned compatible with the array disks and can be installed in the array without a re-format.

but what exactly does that mean?

 

Disclaimer: I apologize if this has already been asked elsewhere...I read through the first few and last few pages of this thread along with a few searches and didn't come up with anything.

Link to post
15 minutes ago, tselliott said:

My question: what's the best way that I can mount my existing btrfs volume so that I can move data to the unraid array.

If all members of the pool are present you can mount it with UD, more info here, on the notes part.

Link to post

@dlandon I think I've discovered a bug with the plugin. I'll give details below. Let me know if I should report it on GitHub and I will.

 

I am running UD 2019.06.18 and unRAID 6.7.0.

 

Steps:

  • Mount a partition in the drive, but change the name of the mount (by clicking on the name, changing it, and pressing enter)
  • Create a script for the mounted partition or drive
  • Save the script
  • Edit the script (which now appears as a code icon)
  • Make some change and save it
  • Observe that the entire configuration appears to be wiped out, and is gone from the \flash\config\plugins\unassigned.devices\unassigned.devices.cfg file as well.

Let me know if you need more details to reproduce this.

 

EDIT: It looks like it's even simpler to reproduce than I initially thought. I am updating the steps. You do not need to make the script on the mounted partition. Editing a script that corresponds with any renamed partition is apparently enough to cause this behavior.

 

 

 

Edited by RoldGold
Link to post
1 hour ago, RoldGold said:

@dlandon I think I've discovered a bug with the plugin. I'll give details below. Let me know if I should report it on GitHub and I will.

 

I am running UD 2019.06.18 and unRAID 6.7.0.

 

Steps:

  • Mount a partition in the drive, but change the name of the mount (by clicking on the name, changing it, and pressing enter)
  • Create a script for the mounted partition or drive
  • Save the script
  • Edit the script (which now appears as a code icon)
  • Make some change and save it
  • Observe that the entire configuration appears to be wiped out, and is gone from the \flash\config\plugins\unassigned.devices\unassigned.devices.cfg file as well.

Let me know if you need more details to reproduce this.

 

EDIT: It looks like it's even simpler to reproduce than I initially thought. I am updating the steps. You do not need to make the script on the mounted partition. Editing a script that corresponds with any renamed partition is apparently enough to cause this behavior.

 

 

 

I cannot reproduce your issue and haven't heard of anyone else reporting this issue.  Post your diagnostics and I'll have a look.

Link to post

Hi, I'm on unraid 6.72, I'm not able to format the disk to ext4, it seems parted is missing, below is the log

 

Aug 8 12:17:21 Tower unassigned.devices: Device '/dev/nvme0n1' block size: 976773168
Aug 8 12:17:21 Tower unassigned.devices: Clearing partition table of disk '/dev/nvme0n1'.
Aug 8 12:17:21 Tower unassigned.devices: Clear partition result: 1+0 records in 1+0 records out 2097152 bytes (2.1 MB, 2.0 MiB) copied, 0.0028507 s, 736 MB/s
Aug 8 12:17:21 Tower unassigned.devices: Reloading disk '/dev/nvme0n1' partition table.
Aug 8 12:17:21 Tower unassigned.devices: Reload partition table result: /dev/nvme0n1: re-reading partition table
Aug 8 12:17:21 Tower unassigned.devices: Creating a primary partition on disk '/dev/nvme0n1'.
Aug 8 12:17:21 Tower unassigned.devices: Creating a 'msdos' partition table on disk '/dev/nvme0n1'.
Aug 8 12:17:21 Tower unassigned.devices: Create 'msdos' partition table result: sh: /usr/sbin/parted: No such file or directory
Aug 8 12:17:21 Tower unassigned.devices: Create primary partition result: sh: /usr/sbin/parted: No such file or directory
Aug 8 12:17:21 Tower unassigned.devices: Formatting disk '/dev/nvme0n1' with 'ext4' filesystem.
Aug 8 12:17:21 Tower unassigned.devices: Format disk '/dev/nvme0n1' with 'ext4' filesystem failed! Result: 

Link to post
5 hours ago, trott said:

Hi, I'm on unraid 6.72, I'm not able to format the disk to ext4, it seems parted is missing, below is the log

 

Aug 8 12:17:21 Tower unassigned.devices: Device '/dev/nvme0n1' block size: 976773168
Aug 8 12:17:21 Tower unassigned.devices: Clearing partition table of disk '/dev/nvme0n1'.
Aug 8 12:17:21 Tower unassigned.devices: Clear partition result: 1+0 records in 1+0 records out 2097152 bytes (2.1 MB, 2.0 MiB) copied, 0.0028507 s, 736 MB/s
Aug 8 12:17:21 Tower unassigned.devices: Reloading disk '/dev/nvme0n1' partition table.
Aug 8 12:17:21 Tower unassigned.devices: Reload partition table result: /dev/nvme0n1: re-reading partition table
Aug 8 12:17:21 Tower unassigned.devices: Creating a primary partition on disk '/dev/nvme0n1'.
Aug 8 12:17:21 Tower unassigned.devices: Creating a 'msdos' partition table on disk '/dev/nvme0n1'.
Aug 8 12:17:21 Tower unassigned.devices: Create 'msdos' partition table result: sh: /usr/sbin/parted: No such file or directory
Aug 8 12:17:21 Tower unassigned.devices: Create primary partition result: sh: /usr/sbin/parted: No such file or directory
Aug 8 12:17:21 Tower unassigned.devices: Formatting disk '/dev/nvme0n1' with 'ext4' filesystem.
Aug 8 12:17:21 Tower unassigned.devices: Format disk '/dev/nvme0n1' with 'ext4' filesystem failed! Result: 

Post diagnostics.  Also go to a command line and show the result of "whereis parted".

Link to post
3 hours ago, dlandon said:

Post diagnostics.  Also go to a command line and show the result of "whereis parted".

thanks, it seems the parted not install successfully,  I think I will try to reinstall the plugin

 

Unable to install /boot/config/plugins/unassigned.devices/packages/parted-3.2-x86_64-2.txz:  tar archive is corrupt (tar returned error code 2)

Link to post
On 8/2/2019 at 4:18 PM, tselliott said:

...

My question: what's the best way that I can mount my existing btrfs volume so that I can move data to the unraid array.

 

In the original post I see:

but what exactly does that mean?

Unassigned Device (i.e. this plugin) is the right tool. Install it and mount your volume. It should show up under /mnt/disks

Just in case: make sure you don't include your existing drive in the array / cache pool or there's a risk it will be erased.

 

What the statement means is that if you format a disk as (for example) xfs, you can include it in the array without Unraid asking you to reformat the disk (and thus keep your existing data on the disk). You will still have to rebuild parity.

Link to post
43 minutes ago, testdasi said:

Unassigned Device (i.e. this plugin) is the right tool. Install it and mount your volume. It should show up under /mnt/disks

Just in case: make sure you don't include your existing drive in the array / cache pool or there's a risk it will be erased.

 

What the statement means is that if you format a disk as (for example) xfs, you can include it in the array without Unraid asking you to reformat the disk (and thus keep your existing data on the disk). You will still have to rebuild parity.

I'm just moving from ubuntu server to unraid,  I have 3 disks in BTRFS single, UD cannot recognize them, I have to mount them in CLI

Link to post
  • 2 weeks later...

I am sorry... this is probably pretty simple, and, I have searched and can't find an answer:

 

I am trying to add a my Google Drive (set as shareable in system prefs>sharing) folder via my Mac as an SMB share to UD:

 

I click add:

 

set host: smb://xx.xx.xx.xxx (Mac ip)

enter credentials

enter folder name

 

click add

 

it populates to SMB shares but is not mountable.  

 

What am I missing?

 

Thank you!

 

Link to post

A unraid newbie here with a feature request

 

I do run a separate 10 disk raidz2-pool in addition to the main unraid pool.

This unassigned devices -plugin nicely brings control and basic visibility on individual disks to the MAIN-tab but it does not understand that zfs-plugin has taken control of the disks aready.

Would it be an insane task to add zfs-awareness to the plugin, preferably with similar share and mount buttons it now has for disks?

 

Link to post
On 8/18/2019 at 1:58 PM, hema said:

A unraid newbie here with a feature request

 

I do run a separate 10 disk raidz2-pool in addition to the main unraid pool.

This unassigned devices -plugin nicely brings control and basic visibility on individual disks to the MAIN-tab but it does not understand that zfs-plugin has taken control of the disks aready.

Would it be an insane task to add zfs-awareness to the plugin, preferably with similar share and mount buttons it now has for disks?

 

Unraid does not have support for ZFS built in and it is not appropriate to add support for ZFS based on a plugin.

Link to post

Hi All,
 

I am encountering an issue where each morning, I log into Unraid to find Unassigned devices unresponsive.
 

Everything in the GUI and array is responsive, except the one disk mounted via unassigned devices and the GUI for unassigned devices. (just the loading animation). The disk is being used by a VM to write to over night as a bit of a scratch disk.

I Also am unable to shutdown or reboot the server in this state, I am required to do a hard power off in order to restart everything.
I am worried doing this is going to cause problems pretty quickly.

 

Has anyone had this issue before?

Capture.PNG

Capture2.PNG

Edited by mustava
Link to post
9 hours ago, mustava said:

Hi All,
 

I am encountering an issue where each morning, I log into Unraid to find Unassigned devices unresponsive.
 

Everything in the GUI and array is responsive, except the one disk mounted via unassigned devices and the GUI for unassigned devices. (just the loading animation). The disk is being used by a VM to write to over night as a bit of a scratch disk.

I Also am unable to shutdown or reboot the server in this state, I am required to do a hard power off in order to restart everything.
I am worried doing this is going to cause problems pretty quickly.

 

Has anyone had this issue before?

Capture.PNG

Capture2.PNG

A snipet of a log is not very helpful.  Post the diagnostics.  Tools->Diagnostics.

Link to post
13 hours ago, chris_netsmart said:

What happens if you turn off your VM.  Do you still have the same issue ?

Yes still same issue, even if i stop everything using the Disk / Array I still cant shutdown the server cleanly. Is there a way to restart the Unassigned Plugin?

Link to post
  • trurl pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.