Jump to content
dlandon

Unassigned Devices - Managing Disk Drives and Remote Shares Outside of The Unraid Array

4511 posts in this topic Last Reply

Recommended Posts

@dlandon, Just a comment regarding UD+  

 

If you have UD up to date, and then decide that you need UD+ and install it, everything works good.  But then you're cleaning up stuff and notice that UD is still sitting in the plugins tab and uninstall it.  Now you've trashed the install of UD+, and a reboot or an uninstall / reinstall is required.

 

Since the two plugins are effectively mutually exclusive, why not just have them with the same filename on the .plg  Would solve a ton of problems (such as the unlikely event where UD gets an update, but UD+ does not which would then trash UD+, or if they both have an update and the user updates UD+ and then UD)

 

While I'm not a fan of duplicating .plg filenames, in this case it really makes sense and is the only workable solution

 

EDIT: Nevermind  They aren't mutually exclusive  My Bad

Share this post


Link to post
4 hours ago, johnnie.black said:

 

First thing to do would be to update the LSI firmware:


LSISAS2008: FWVersion(20.00.02.00)

All p20 releases except latest (p20.00.07.00) have known issues.

Thank you both for the replies.  Johnnie, I bought my LSI card with IT mode flashed.  I think what you'e saying is the 20.00.02.00 IT mode firmware may have issues and I should download and flash 20.00.07.00 version, correct?  Sorry for the basic question but I want to make sure I understand what's going on.  The only link on broadcom's site for my card in 20.00.07.00 is for a MSDOS windows.  I'm going to go do some reading on these cards to educate myself, so apologies if this is basic stuff I should know.

Share this post


Link to post
6 minutes ago, Squid said:

@dlandon, Just a comment regarding UD+  

 

If you have UD up to date, and then decide that you need UD+ and install it, everything works good.  But then you're cleaning up stuff and notice that UD is still sitting in the plugins tab and uninstall it.  Now you've trashed the install of UD+, and a reboot or an uninstall / reinstall is required.

 

Since the two plugins are effectively mutually exclusive, why not just have them with the same filename on the .plg  Would solve a ton of problems (such as the unlikely event where UD gets an update, but UD+ does not which would then trash UD+, or if they both have an update and the user updates UD+ and then UD)

 

While I'm not a fan of duplicating .plg filenames, in this case it really makes sense and is the only workable solution

 

EDIT: Nevermind  They aren't mutually exclusive  My Bad

That is in preparation for moving all the packages not normally needed to UD+ for those who use UD skinny.  i.e. No hfsplus or exFat format mounting, no nmap for NFS server lookups, and no formatting or deleting partitions.  It is still a work in process.

 

UD will not install any of those packages in the upcoming release.  UD+ will have to be installed for the additional features.

 

I am not a fan of all of the packages being installed that few people use.

Share this post


Link to post
7 minutes ago, dlandon said:

exFat format mounting,

Completely up to you of course, but I would think that exFat would be part of the base package since it's the default format for flash drives > 32G

Share this post


Link to post
7 minutes ago, Squid said:

Completely up to you of course, but I would think that exFat would be part of the base package since it's the default format for flash drives > 32G

Like I said a work in progress.  Just uploaded the plugin template for testing.

Share this post


Link to post

So - anyone can help me with an USB device fail?
Dec 28 19:10:02 Hubbi unassigned.devices: Adding disk '/dev/sda1'...
Dec 28 19:10:02 Hubbi unassigned.devices: Mount drive command: /sbin/mount -t ntfs -o auto,async,noatime,nodiratime,nodev,nosuid,umask=000 '/dev/sda1' '/mnt/disks/My_Book_Duo'
Dec 28 19:10:02 Hubbi unassigned.devices: Mount of '/dev/sda1' failed. Error message:
Dec 28 19:10:02 Hubbi unassigned.devices: Partition 'My_Book_Duo' could not be mounted.

16B Western Digital USB3 drive i have alot of data on i need to transfer to my Unraid server :)

Share this post


Link to post
51 minutes ago, MWDK said:

So - anyone can help me with an USB device fail?
Dec 28 19:10:02 Hubbi unassigned.devices: Adding disk '/dev/sda1'...
Dec 28 19:10:02 Hubbi unassigned.devices: Mount drive command: /sbin/mount -t ntfs -o auto,async,noatime,nodiratime,nodev,nosuid,umask=000 '/dev/sda1' '/mnt/disks/My_Book_Duo'
Dec 28 19:10:02 Hubbi unassigned.devices: Mount of '/dev/sda1' failed. Error message:
Dec 28 19:10:02 Hubbi unassigned.devices: Partition 'My_Book_Duo' could not be mounted.

16B Western Digital USB3 drive i have alot of data on i need to transfer to my Unraid server :)

Post diagnostics.

Share this post


Link to post
57 minutes ago, MWDK said:

So - anyone can help me with an USB device fail?
Dec 28 19:10:02 Hubbi unassigned.devices: Adding disk '/dev/sda1'...
Dec 28 19:10:02 Hubbi unassigned.devices: Mount drive command: /sbin/mount -t ntfs -o auto,async,noatime,nodiratime,nodev,nosuid,umask=000 '/dev/sda1' '/mnt/disks/My_Book_Duo'
Dec 28 19:10:02 Hubbi unassigned.devices: Mount of '/dev/sda1' failed. Error message:
Dec 28 19:10:02 Hubbi unassigned.devices: Partition 'My_Book_Duo' could not be mounted.

16B Western Digital USB3 drive i have alot of data on i need to transfer to my Unraid server :)

Are you connecting to a USB 3 port? Have you tried it on a USB 2 port instead? I have one device that only works on USB 2, so I wonder if that might also be your problem. 

Share this post


Link to post

For some reason it worked after i uninstalled and installed again :) So it's mounted!
Not i just need to find the best file explorer so i can copy the content to my Unraid drives :D

Share this post


Link to post
6 minutes ago, MWDK said:

For some reason it worked after i uninstalled and installed again :) So it's mounted!
Not i just need to find the best file explorer so i can copy the content to my Unraid drives :D

Try the Krusader docker container.... it's quite full-featured as a file/directory utility. Just make sure to add the paths to the mountpoints for your UD device(s) so you can copy to the array.

 

Share this post


Link to post
2 minutes ago, AgentXXL said:

Try the Krusader docker container.... it's quite full-featured as a file/directory utility. Just make sure to add the paths to the mountpoints for your UD device(s) so you can copy to the array.

 

Thank you sir! will try it out :)

I see you have the Norcotek case i want! Happy with it?

Share this post


Link to post
3 hours ago, Squid said:

Completely up to you of course, but I would think that exFat would be part of the base package since it's the default format for flash drives > 32G

The idea is to support all formats natively supported by Unraid, and add the plus packages for other file format support and disk formatting.  Fairly painless.

Share this post


Link to post
1 minute ago, MWDK said:

Thank you sir! will try it out :)

I see you have the Norcotek case i want! Happy with it?

I was happy when I bought it over 6 years ago and used it for FreeNAS for many years with only 8 of the 20 bays populated with drives. When I moved to unRAID about 9 months ago, I had major issues with the hot-swap SATA backplanes that Norcotek has installed in the case. I eventually had to remove all the backplanes and now the drives are direct cabled - no more easy hot-swap but I never really needed that anyways. And as far as I know, Norcotek is now out of business. They haven't responded to multiple emails asking about replacement backplanes and their phone number has been disconnected.

 

This means you'll have to look for something else - I'm considering a Supermicro 24  disk enclosure myself, but also picked up a Rosewill 4500 so I can do a 2nd unRAID setup with up to 15 x 3.5" drives (again, all direct cabled).

Share this post


Link to post

@johnnie.black @dlandon - So, I just spent a couple hours cleaning my server for dust etc and checking connections.  That said, most of that time was spent trying to flash my SAS card to p20.00.07.00.  I can't seem to figure that out, and I've tried a few guides.  Either way, when I put everything back together and booted back up to unraid the partition is now gone as it should be.  So, maybe it was a loose connection or something....

 

I will read up more on how to flash this SAS card and try to do that as well for good measure.

 

Thank you both again for your input.  If anyone can recommend a good guide on flashing these things I would appreciate it.  I get the following when attempting to use the exe in dos:

Failed to Initialise PAL

I know this isn't really a UD issue at this point, so I'll keep reading but if anyone could point me in the right direction I would appreciate it.

 

EDIT/UPDATE - I managed to figure out how to flash the sas card (needed to do it through EFI shell).  Everything is up to date now.  I assume things are fine but will update if need be.

Edited by statecowboy

Share this post


Link to post
12 hours ago, statecowboy said:

EDIT/UPDATE - I managed to figure out how to flash the sas card (needed to do it through EFI shell).  Everything is up to date now.  I assume things are fine but will update if need be.

(sorry for the thread hijack, but I need to do this myself.... can you ping me any links etc - ta)

Share this post


Link to post

In the next release of UD, I am separating out all the packages loaded currently by UD into a separate plugin called 'Unassigned Devices Plus'.  The packages removed from the base UD affect mounting of HFS+ and extFAT disks.  If you need to mount these formats, install the UD plus Plugin.

 

The other package not installed any more in the base UD s 'parted'.  Parted is used for formatting and partition delete on disks.  If you need to do any formatting or deleting of partitions, install the UD Plus plugin.

 

All disk formats supported by Unraid are supported in the base UD plugin.  The idea behind all this is the installation of packages into Unraid that are not used by the majority of users.  I am not a fan of installing a lot of packages into Unraid, especially packages that are not being used.  This also cuts down on the UD plugin installation time by not downloading and installing all those packages.

 

The UD Settings page will indicate which features can not be enabled without the UD Plus plugin being installed.  Check the 'Help' on that page for further information.

Share this post


Link to post
On 12/27/2019 at 10:28 PM, dlandon said:

You need to adjust the shutdown timers as suggested here:

This was an informative read. It helped me achieve a better understanding of the subtleties of the shutdown process(es) – thanks for that.

 

So, I updated the various timings as suggested and factored these into my current (pun intended) power outage/UPS shutdown timings. I am happy to report that it appears to have worked since we have had yet another outage (this is 2020 right?) and I had a graceful shutdown. Now it is time to dive into gracefully shutting down the network appliances and UPS devices. Thanks again for all the assistance.

 

Happy New Year everyone!

Share this post


Link to post
1 minute ago, wgstarks said:

So if we need UD+ should we delete UD first and then install UD+?

No.  UD Plus is just an add on plugin that installs the packages needed for the additional features.  It is not an alternative to the base UD.

Share this post


Link to post
3 minutes ago, TechMed said:

This was an informative read. It helped me achieve a better understanding of the subtleties of the shutdown process(es) – thanks for that.

 

So, I updated the various timings as suggested and factored these into my current (pun intended) power outage/UPS shutdown timings. I am happy to report that it appears to have worked since we have had yet another outage (this is 2020 right?) and I had a graceful shutdown. Now it is time to dive into gracefully shutting down the network appliances and UPS devices. Thanks again for all the assistance.

 

Happy New Year everyone!

That's good news.  The subtleties of the timings in shutting down Unraid can be confusing, especially when things take a bit of time to shutdown - like remote mounts.

 

My goal in shutting down UD mounts is to be sure that all unmounts are as safe as possible so data will not be lost or corrupted.  Sometimes this can be difficult because CIFS (remote mounts) is a pretty contrary beast.  I also don't want things to hang or take too long.

Share this post


Link to post

On the update of UD, the packages installed originally by UD will remain.  When you reboot, they will not be re-installed.  If you need the additional features offered by the UD+ plugin, then I recommend you install UD+ also and you will then see a seamless update after a reboot.

Share this post


Link to post
1 minute ago, dlandon said:

The subtleties of the timings in shutting down Unraid can be confusing

 

1 minute ago, dlandon said:

My goal in shutting down UD mounts is to be sure that all unmounts are as safe as possible so data will not be lost or corrupted.

Understood and appreciated (literally and figuratively).

As systems start to get larger and more complex, the need for 'graceful' dismounts and shutdowns become greater.

I for one am moving towards relying heavily on two of my boxes. I am big into automation, particularly as it relates to healthcare, so stability and reliability become exponentially more more important.

 

Even though many use unRAID as a media storage/delivery platform, losing that data is a big deal as well; just look at some of the near panicked posts people have made because they think it has all gone to Byte Heaven! I have a few ( wink wink nudge nudge) TB myself and would be darn near inconsolable if it went away. Ergo, redundancy, backups, and application of Best Practices, as outlined in the earlier referenced post.

 

Hopefully this info will help someone else in the future. Thanks again to everyone who contributed!

Share this post


Link to post
2 hours ago, dlandon said:

In the next release of UD, I am separating out all the packages loaded currently by UD into a separate plugin called 'Unassigned Devices Plus'.  The packages removed from the base UD affect mounting of HFS+ and extFAT disks.  If you need to mount these formats, install the UD plus Plugin.

 

The other package not installed any more in the base UD s 'parted'.  Parted is used for formatting and partition delete on disks.  If you need to do any formatting or deleting of partitions, install the UD Plus plugin.

 

All disk formats supported by Unraid are supported in the base UD plugin.  The idea behind all this is the installation of packages into Unraid that are not used by the majority of users.  I am not a fan of installing a lot of packages into Unraid, especially packages that are not being used.  This also cuts down on the UD plugin installation time by not downloading and installing all those packages.

 

The UD Settings page will indicate which features can not be enabled without the UD Plus plugin being installed.  Check the 'Help' on that page for further information.

Would you like me to notify everyone with UD and FCP installed about this?  Should *hopefully* lessen the massive influx of support posts that will happen

Share this post


Link to post
2 hours ago, dlandon said:

No.  UD Plus is just an add on plugin that installs the packages needed for the additional features.  It is not an alternative to the base UD.

Thanks to clear things up. UD+ is only an addon for the addon so to say. Maybe add that info in the first post. I had to read the last couple pages after reading the adjusted first post to find the info. I get the point, why you strip things out to slim down the plugin to the base it always meant to be. Maybe I'am allowed to asked is this the first step to prepare UD to become implemented by default into Unraid by Limetech? I remember there were a couple discussions to implement the functionality of UD into Unraid.

Share this post


Link to post
5 minutes ago, pluginCop said:

Would you like me to notify everyone with UD and FCP installed about this?  Should *hopefully* lessen the massive influx of support posts that will happen

Yes.  I can see people getting confused when they reboot after updating UD and don't have UD+ installed and wonder why certain things are now broken.

 

I also sense a lot of confusion about UD Settings and that UD even has settings.  I'll look into possibly adding a link on the UD page to the settings.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.