Unassigned Devices - Managing Disk Drives and Remote Shares Outside of The Unraid Array


dlandon

5995 posts in this topic Last Reply

Recommended Posts

  • Replies 6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

New release of UD.  Changes: When changing the mount point (which is also the share name), the mount point is checked for a duplicate of a user share or another UD device.  Samba cannot handle

While I appreciate your interest in esthetics, there is more to consider than just 'aligning' disk drive mounts: This disk is mounted without a UD script, it is probably better to put it in th

Major new release of UD: "Where are the switches?"  The "Pass Through", "Read Only", "Automount", and "Share" switches have been moved to a new Edit Settings dialog.  This is also where the sc

Posted Images

1 hour ago, Jase said:

Regarding the latest update for Unassigned Devices Plus; Is there a reason why the plugin is being rolled back?

 

"2021.01.24 Fi: Remove libfsapfs package"

I was told it didn’t work.

Link to post
4 hours ago, Beermedlar said:

If failure to unmount the remote share when reboot or shutdown. The unraid will be forzen. Never reboot or shutdown

The remote shares are unmounted with the force switch set and will always unmount.

Link to post
1 hour ago, itimpi said:

Maybe some could let you have an image file of a Apfs+ disk to allow you to test this format in the future?

Or send me an old/cheap disk formatted apfs.

Link to post
7 hours ago, dlandon said:

Or send me an old/cheap disk formatted apfs.

 

I've got an old laptop drive that I can format as APFS and send to you. If you want to contact me by PM with the details on where to send it to, I'll add it to my trip to the post office this week.

Link to post
3 hours ago, Beermedlar said:

Where is "the force switch"? I didn't find it in UnassignedDevicesSettings

UD handles it when the array is stopped.

 

If you are having trouble with unclean shutdowns, take a look at this:

 

 

Link to post

I think I saw it in this thread, but i'll be damned if I can find it;  I have the appearing/disappearing preclear finished status below an empty drive.  What was the fix for that?

 

nevermind.  Just noticed I was on v.2020.12.31 for UD.  updated to v2021.01.16b.  seems to have stopped doing the thing.

Link to post
3 minutes ago, giganode said:

Hey @dlandon!

 

What do you think about a toggle switch for read/write in MB/s? :)

Personally I think this would be fantastic!

 

And also, could the columns be alligned according to the ones above in cache and array? 😁

Do you mean simply honour the switch at the top right of the Main page that already acts as a toggle of this sort for array drives.

Link to post
5 hours ago, giganode said:

And also, could the columns be alligned according to the ones above in cache and array?

I've done about the best I can for now.  The information in UD is very dynamic and the table columns change width.  I don't have the time right now to spend on purely cosmetic issues.

Link to post
8 hours ago, dlandon said:

It's on my list of things to look at, but not a high priority.

 

Okay, what about the ability to rename the devices? Right now, I have dev 1 and dev 3.. would be nice be able to rename for example dev 1 to VMs or Images  or something like that.

Link to post
3 hours ago, giganode said:

 

Okay, what about the ability to rename the devices? Right now, I have dev 1 and dev 3.. would be nice be able to rename for example dev 1 to VMs or Images  or something like that.

Have you tried clicking on the partition name and changing the name and then pressing Enter?   Works for me

Link to post
9 hours ago, giganode said:

 

Rename Dev 2 into something different.

What I was trying to ask is why you feel that is important.  It is a designation used by Unraid for unassigned disks.  It is not something that can be changed.

 

Maybe you need to move the device to the pool where you can name it like you are wanting.

Link to post
14 hours ago, dlandon said:

What I was trying to ask is why you feel that is important.  It is a designation used by Unraid for unassigned disks.  It is not something that can be changed.

 

Maybe you need to move the device to the pool where you can name it like you are wanting.

 

Okay... I saw a possibility there, because in previous versions the names did not exist in that way... they were simply called sdb or nvme1n1 in that column

Link to post

image.thumb.png.402fd28700f2e90bdc3fd3547a00f6bc.png

 

Any thoughts on why the preclear icon at the bottom will show the temperature for an UD, but not in the listing above?
Also Read/Write never populate (not sure if related, but thought I should mention.)

Diagnostics attached.

If you need anything else, just ask, and please provide instructions as if I'm a complete moron, or haven't had any coffee in days. :D

Thanks!

cube-diagnostics-20210130-1323.zip

Edited by sota
Link to post
9 minutes ago, sota said:

image.thumb.png.402fd28700f2e90bdc3fd3547a00f6bc.png

 

Any thoughts on why the preclear icon at the bottom will show the temperature for an UD, but not in the listing above?

Diagnostics attached.

If you need anything else, just ask, and please provide instructions as if I'm a complete moron, or haven't had any coffee in days. :D

Thanks!

cube-diagnostics-20210130-1323.zip 238.78 kB · 0 downloads

You have some strange stuff going on.  None of your temperatures are showing.  Preclear is struggling:

Jan 30 07:48:02 Cube nginx: 2021/01/30 07:48:02 [error] 12695#12695: *32314906 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 192.168.1.29, server: , request: "POST /plugins/unassigned.devices/UnassignedDevices.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "cube", referrer: "http://cube/Main"
Jan 30 07:48:02 Cube php-fpm[12669]: [WARNING] [pool www] child 19751 exited on signal 7 (SIGBUS) after 126.218227 seconds from start
Jan 30 08:07:02 Cube rc.diskinfo[58387]: SIGHUP received, forcing refresh of disks info.
Jan 30 08:15:01 Cube kernel: sde: sde1
Jan 30 08:15:01 Cube rc.diskinfo[58387]: SIGHUP received, forcing refresh of disks info.
Jan 30 08:15:01 Cube kernel: sdb: sdb1
Jan 30 08:19:01 Cube kernel: sdc: sdc1
Jan 30 08:19:01 Cube kernel: sdd: sdd1
Jan 30 08:19:01 Cube kernel: sdf: sdf1
Jan 30 08:19:01 Cube rc.diskinfo[58387]: SIGHUP received, forcing refresh of disks info.
Jan 30 08:19:01 Cube kernel: sdg: sdg1
Jan 30 08:19:01 Cube nginx: 2021/01/30 08:19:01 [error] 12695#12695: *32332208 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 192.168.1.112, server: , request: "POST /plugins/unassigned.devices/UnassignedDevices.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "cube", referrer: "http://cube/Main"
Jan 30 08:19:01 Cube php-fpm[12669]: [WARNING] [pool www] child 63666 exited on signal 7 (SIGBUS) after 86.344191 seconds from start
Jan 30 08:19:01 Cube nginx: 2021/01/30 08:19:01 [error] 12695#12695: *32332513 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 192.168.1.112, server: , request: "POST /plugins/unassigned.devices/UnassignedDevices.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "cube", referrer: "http://cube/Main"
Jan 30 08:19:01 Cube php-fpm[12669]: [WARNING] [pool www] child 9694 exited on signal 7 (SIGBUS) after 43.772320 seconds from start
Jan 30 08:23:49 Cube kernel: sdg: sdg1
Jan 30 08:23:50 Cube rc.diskinfo[58387]: SIGHUP received, forcing refresh of disks info.
### [PREVIOUS LINE REPEATED 1 TIMES] ###
Jan 30 08:23:50 Cube kernel: sdf: sdf1
Jan 30 08:23:50 Cube kernel: sdc: sdc1
Jan 30 08:23:50 Cube kernel: sde: sde1
Jan 30 08:23:51 Cube kernel: sdb: sdb1
Jan 30 08:23:51 Cube kernel: sdd: sdd1

Start by removing the preclear plugin for the moment and then reboot.

Link to post

I can try that.  It'll be at least 16+ hours before I can do a reboot though, so i'm not ignoring you. :)

eta:

also I maybe should have mentioned (the whole lack of coffee thing), I'm in the process of doing a full array backup to cold storage, so there's a lot of disk swapping going on, and a specific VM is stopped/started each time.

Edited by sota
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.