Unassigned Devices - Managing Disk Drives and Remote Shares Outside of The Unraid Array


dlandon

Recommended Posts

18 hours ago, trurl said:

Can you see these files in something other than the dockers? If so, then you have a problem with the docker and not with UD. You can go directly to the correct support thread for any of your dockers by clicking on its icon and selecting Support.

 

Are you specifying slave mode in the mapping?

 

 

Thank you for your reply. I will check out the Docker FAQ.

 

UD is doing some very weird things, That i think are related to Docker Containers. So i have my NAS mapped within UD. No Docker containers running and everything works fine. as you can see from the link below 

 

https://imgur.com/MsUAdxR

 

Once i start the Radarr or the Sonarr Docker container. This will crash UD and the NAS drive will be unavailable from within Unraid and from within Radarr or Sonarr. 

 

Any one else had this issue with Docker and UD not playing nicely?

 

 

 

 

Link to comment
2 hours ago, psychofaktory said:

Why is the plugin doing this and how can I prevent it?

This is used to find SMB and NFS servers when you click on the 'Search for Servers' button when adding a SMB or NFS remote share.  That is the only time it is used.

Link to comment
1 hour ago, Dialatech2303 said:

UD is doing some very weird things,

What weird things are you seeing?

 

1 hour ago, Dialatech2303 said:

Once i start the Radarr or the Sonarr Docker container. This will crash UD and the NAS drive will be unavailable from within Unraid and from within Radarr or Sonarr. 

What is 'crashing' in UD?

 

UD manages mounting/unmounting remote shares and displays some status on the UD web page.  It has no active role in the remote share operation once it is mounted.

 

Is there any chance you are mounting the device with UD and the docker container?

Link to comment
2 hours ago, dlandon said:

What weird things are you seeing?

 

What is 'crashing' in UD?

 

UD manages mounting/unmounting remote shares and displays some status on the UD web page.  It has no active role in the remote share operation once it is mounted.

 

Is there any chance you are mounting the device with UD and the docker container?

 

I'm sorry if im not explaining this clear. I'm new to Unraid and to Docker.

 

So i have my NAS mounted using UD, Source being //Data01/Movies and the mount point is DATA01_Movies. I have created a link in my docker-compose file to use the mount point ( mnt/remotes/DATA01_Movies) and create a link to a folder called /movies. Which is then linked to Radarr docker app. All works fine but then all sudden it radarr will say the /movies is unavailable. I go into unraid go to Main tab and UD it will say the mounts are online but if i click on it , this will error out also at that point if i go to mnt/remotes/DATA01_Movies. That will be just spin and spin aswell and timeout.

Link to comment
24 minutes ago, Dialatech2303 said:

I go into unraid go to Main tab and UD it will say the mounts are online but if i click on it , this will error out also at that point

What are you clicking on and what is the error?  Screen shot please.

 

Please post your complete diagnostics.

Link to comment

I rebooted the server and one of my Unassigned NVME drives that I used to house a VM is not mounting. Under Historical Devices, the same drive is listed however the Mount Point seems to be different. I don't recall how it was previously but currently the Historical Devices mount point was "VM" and the current one is "nvme0n1".

 

Right now there's only an option to Format or Preclear the drive. I'm not quite sure how to change the mount point or to have it read that drive again.

Mount Point.png

Link to comment
4 hours ago, insomniak said:

I rebooted the server and one of my Unassigned NVME drives that I used to house a VM is not mounting. Under Historical Devices, the same drive is listed however the Mount Point seems to be different. I don't recall how it was previously but currently the Historical Devices mount point was "VM" and the current one is "nvme0n1".

 

Right now there's only an option to Format or Preclear the drive. I'm not quite sure how to change the mount point or to have it read that drive again.

Mount Point.png

Click on the double arrow icon in the upper right of UD and see if the drive is recognized again.  If that doesn't work, check your drive seating in he socket.

Link to comment

Hi guys, I've searched but I haven't found the solution. I have some disks connected internally (not's USB) to unassigned devices.
I need to run a script to mount, backup, unmount. I use CA Scrips Users. I'm trying to do this:


LABEL="4TB"
SERIAL="01056498A"

 

if [ ! -d "/mnt/disks/${LABEL}" ]; then
     DISK_MOUNT="ls -l /dev/disk/by-id/ | grep '${SERIAL}' | head -1 | tail -c4"
     DEVICE="${DISK_MOUNT}1"
     mkdir "/mnt/disks/${LABEL}"
     /usr/local/emhttp/plugins/unassigned.devices/scripts/rc.unassigned mount "/dev/${DEVICE}"
fi

 

On the command line, it identifies the sdX drive (ls -l /dev/disk/by-id/ | grep '${SERIAL}' | head -1 | tail -c4), but in the script it doesn't save to the variable. The variable's output is the command itself, that is, it doesn't execute, it just saves the variable as text.

 

I just need to identify the sdX according to the device serial.
I can't use a fixed sdX because when I restart Unraid it might change the sdX.

 

Can you help me? Tks
Forgive my english.

Link to comment
48 minutes ago, Braulio said:

run a script to mount, backup, unmount.

There is already an example backup script on the first page of this thread. And UD can automatically mount a disk, and automatically run a script when a disk is mounted.

Link to comment
15 minutes ago, trurl said:

There is already an example backup script on the first page of this thread. And UD can automatically mount a disk, and automatically run a script when a disk is mounted.

Yes, I saw this script. But my device will not be plugged into USB to mount when connecting. It is already connected inside the case via SATA cable.

I need creat a script in CA User Scripts and Scheduled, but i need mount the device with this command that i said.

Link to comment
2 minutes ago, Braulio said:

Yes, I saw this script. But my device will not be plugged into USB to mount when connecting. It is already connected inside the case via SATA cable.

I need creat a script in CA User Scripts and Scheduled, but i need mount the device with this command that i said.

Click on the Help icon when on the UD page and read about how to mount a UD disk using the devX designation in Unraid 6.9.

Link to comment

I removed a cache drive from my system and installed a new one. I am trying to use UD to access the data on this drive. It is formatted BTRFS. UD sees the drive, but my only option is to format it. Is there another way to get at this data?

Edited by mikedpitt420
Link to comment
3 hours ago, Braulio said:

I haven't found this option in CA User Scripts.

CA.jpg

You create a script in User Scripts and put the disk mount command in the script at the beginning.

/usr/local/sbin/rc.unassigned mount /dev/devX

The devX is the device name in the UD page. If the device name is 'Dev 1', then use dev1 as the device to mount.

Link to comment

Any good way of diagnosing speed issues with SMB mounted shares? I have a remote SMB share on my cloud server that I transfer large files from to my unraid. If I browse the share directly from my windows machine and copy a file from it to that machine, I saturate my incoming bandwidth (300mbps, the server's upload is much greater). I can also verify this amount of bandwidth between the 2 machines using iperf3.

 

However, if I copy from the remote share in unraid (either directly in unraid, using "rsync -ahP" to watch the speed, or by sharing the mount and copying in Windows), I only get about 5MB/s average, or 40mbps. What should I look at next?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.