Unassigned Devices - Managing Disk Drives and Remote Shares Outside of The Unraid Array


dlandon

Recommended Posts

4 hours ago, Devinius said:

Hi all,

 

i've the following problem.

I would like to use a NVMe m2 SSD with UD.

During the array is offline, all is fine. I was able to format the SSD and my array settings looks good.
If i start my array unraid says "flash device error" and unraid couldn't find my license file.

image.png.2c9c16e7097b2957d1f5a0052e626d26.png

UD show this:

image.png.982b072cde5470edad1c4986b443115c.png

 

The second one is my USB Stick with UNRAID.

Bringing the array offline takes very long, UNRAID says "Retry unmounting disk share(s)...".

 

Whats wrong here?

 

Thank you!

 

 

Your flash drive is disconnecting and then reconnecting.  When it reconnects, Linux assigns a new device designation thinking it is a new hot plugged drive.  The server then loses access to sda.

 

Do this:

  • Shut down your system.
  • Remove the flash drive and take it to a computer and try to repair the file system.
  • Put the flash back into the server in a different USB slot.  Try to use a USB2 slot.
Link to comment
14 hours ago, chuckthetekkie said:

Good luck finding it. As a hobbyist software developer and tester I know it can be a real pain in the butt to find a bug that's hard to replicate. 

 

I've fixed the clear disk not showing after a preclear:

193105679_UDPage.png.b1ebb41df09f94b34e761d5677c58b8a.png

 

I added the clear disk icon because parted has issues at times removing partitions.  In your case, parted said the partition did not exist.  Obviously there is a partition.  The clear disk does a 'wipefs' that removes any and all partitions from a disk.  Users have had to go to the command line to clear a disk, and there is too much chance of making a mistake. 

  • Thanks 1
Link to comment
47 minutes ago, Mike S said:

I have some full drives from an old ubuntu system that were XFS and I want to attach them using unassigned devices but it seems to not be recognizing that I can mount these. Is there something I need to do to get these mountable?

only-format.PNG

tower-diagnostics-20211222-1304.zip 148.64 kB · 0 downloads

The limited screen shot you posted indicates that the disk format is not recognized by Linux.

Link to comment
11 minutes ago, dlandon said:

The limited screen shot you posted indicates that the disk format is not recognized by Linux.

 

Is there more information I can share? I just pulled these from an ubuntu 20.04 system and they were working there

 

root@Tower:~# fdisk -l -u /dev/sdm
Disk /dev/sdm: 3.64 TiB, 4000787030016 bytes, 7814037168 sectors
Disk model: Dual SATA Bridge
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

 

Edited by Mike S
Link to comment
1 minute ago, Mike S said:

 

Is there more information I can share? I just pulled these from an ubuntu 20.04 system and they were working there

If they were formatted purely as xfs, then Linux (hence UD) would be able to recognize the file system.  Were they in a raid or other configuration that might be a unique partition layout?

 

Post the /var/state/unassigned.devices/unassigned.devices.ini file and I can see the disk details.  This is the udev info for each disk.  Let me know which /dev/sdX disk designations are the issue.

  • Thanks 1
Link to comment
10 minutes ago, dlandon said:

If they were formatted purely as xfs, then Linux (hence UD) would be able to recognize the file system.  Were they in a raid or other configuration that might be a unique partition layout?

 

Post the /var/state/unassigned.devices/unassigned.devices.ini file and I can see the disk details.  This is the udev info for each disk.  Let me know which /dev/sdX disk designations are the issue.

 

I stand corrected they are ext4 and the disks are `/dev/sdm`, `/dev/sdf`, `/dev/sdc`. 

 

They were not in a raid or anything of the sort.

Thanks for this!

 

[/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2H678P-part1]
DEVLINKS = "/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2H678P-part1 /dev/disk/by-id/wwn-0x5000c500db5e4d6a-part1 /dev/disk/by-partuuid/8b279c57-e91c-409e-a9bb-50909986d8ab /dev/disk/by-path/pci-0000:04:00.0-sas-phy2-lun-0-part1 /dev/disk/by-uuid/4ae0920c-2a0f-43d3-b2e4-81facea3bd2c"
DEVNAME = "/dev/sde1"
DEVPATH = "/devices/pci0000:00/0000:00:03.0/0000:04:00.0/host7/port-7:3/end_device-7:3/target7:0:3/7:0:3:0/block/sde/sde1"
DEVTYPE = "partition"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 66804
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 66804
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 7200
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_FS_TYPE = "xfs"
ID_FS_USAGE = "filesystem"
ID_FS_UUID = "4ae0920c-2a0f-43d3-b2e4-81facea3bd2c"
ID_FS_UUID_ENC = "4ae0920c-2a0f-43d3-b2e4-81facea3bd2c"
ID_MODEL = "ST14000NM001G-2KJ103"
ID_MODEL_ENC = "ST14000NM001G-2KJ103\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PART_ENTRY_DISK = "8:64"
ID_PART_ENTRY_NUMBER = 1
ID_PART_ENTRY_OFFSET = 64
ID_PART_ENTRY_SCHEME = "gpt"
ID_PART_ENTRY_SIZE = 27344764831
ID_PART_ENTRY_TYPE = "0fc63daf-8483-4772-8e79-3d69d8477de4"
ID_PART_ENTRY_UUID = "8b279c57-e91c-409e-a9bb-50909986d8ab"
ID_PART_TABLE_TYPE = "gpt"
ID_PART_TABLE_UUID = "04ba71dd-b8d4-451d-8803-5a19c6574bea"
ID_PATH = "pci-0000:04:00.0-sas-phy2-lun-0"
ID_PATH_TAG = "pci-0000_04_00_0-sas-phy2-lun-0"
ID_REVISION = "SN03"
ID_SERIAL = "ST14000NM001G-2KJ103_ZL2H678P"
ID_SERIAL_SHORT = "ZL2H678P"
ID_TYPE = "disk"
ID_WWN = "0x5000c500db5e4d6a"
ID_WWN_WITH_EXTENSION = "0x5000c500db5e4d6a"
MAJOR = 8
MINOR = 65
PARTN = 1
SUBSYSTEM = "block"
USEC_INITIALIZED = 19156206

[/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2HE85K-part1]
DEVLINKS = "/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2HE85K-part1 /dev/disk/by-id/wwn-0x5000c500db6c6aa6-part1 /dev/disk/by-partlabel/primary /dev/disk/by-partuuid/9664b79b-e805-49f2-8213-2a8361f31a0d /dev/disk/by-path/pci-0000:04:00.0-sas-phy1-lun-0-part1 /dev/disk/by-uuid/a590a3f1-beca-402b-8043-1eb43522b4d4"
DEVNAME = "/dev/sdd1"
DEVPATH = "/devices/pci0000:00/0000:00:03.0/0000:04:00.0/host7/port-7:2/end_device-7:2/target7:0:2/7:0:2:0/block/sdd/sdd1"
DEVTYPE = "partition"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 66766
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 66766
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 7200
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_FS_TYPE = "xfs"
ID_FS_USAGE = "filesystem"
ID_FS_UUID = "a590a3f1-beca-402b-8043-1eb43522b4d4"
ID_FS_UUID_ENC = "a590a3f1-beca-402b-8043-1eb43522b4d4"
ID_MODEL = "ST14000NM001G-2KJ103"
ID_MODEL_ENC = "ST14000NM001G-2KJ103\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PART_ENTRY_DISK = "8:48"
ID_PART_ENTRY_NAME = "primary"
ID_PART_ENTRY_NUMBER = 1
ID_PART_ENTRY_OFFSET = 2048
ID_PART_ENTRY_SCHEME = "gpt"
ID_PART_ENTRY_SIZE = 27344760832
ID_PART_ENTRY_TYPE = "0fc63daf-8483-4772-8e79-3d69d8477de4"
ID_PART_ENTRY_UUID = "9664b79b-e805-49f2-8213-2a8361f31a0d"
ID_PART_TABLE_TYPE = "gpt"
ID_PART_TABLE_UUID = "9ecf4f69-305c-47eb-a6a8-4719d4f7279f"
ID_PATH = "pci-0000:04:00.0-sas-phy1-lun-0"
ID_PATH_TAG = "pci-0000_04_00_0-sas-phy1-lun-0"
ID_REVISION = "SN03"
ID_SERIAL = "ST14000NM001G-2KJ103_ZL2HE85K"
ID_SERIAL_SHORT = "ZL2HE85K"
ID_TYPE = "disk"
ID_WWN = "0x5000c500db6c6aa6"
ID_WWN_WITH_EXTENSION = "0x5000c500db6c6aa6"
MAJOR = 8
MINOR = 49
PARTN = 1
PARTNAME = "primary"
SUBSYSTEM = "block"
USEC_INITIALIZED = 19215505

[/dev/disk/by-id/ata-WDC_WD10EADS-00L5B1_WD-WCAU4D967611-part1]
DEVLINKS = "/dev/disk/by-id/ata-WDC_WD10EADS-00L5B1_WD-WCAU4D967611-part1 /dev/disk/by-id/wwn-0x50014ee258e839e0-part1 /dev/disk/by-label/1TB-2 /dev/disk/by-partlabel/primary /dev/disk/by-partuuid/684b65e1-4711-4f53-a1d1-fa75db33bc3e /dev/disk/by-path/pci-0000:0d:00.0-usb-0:1:1.0-scsi-0:0:0:1-part1 /dev/disk/by-uuid/b41436e4-675a-4169-8577-55de7c8d666f"
DEVNAME = "/dev/sdn1"
DEVPATH = "/devices/pci0000:00/0000:00:1c.7/0000:0d:00.0/usb6/6-1/6-1:1.0/host10/target10:0:0/10:0:0:1/block/sdn/sdn1"
DEVTYPE = "partition"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_AAM = 1
ID_ATA_FEATURE_SET_AAM_CURRENT_VALUE = 254
ID_ATA_FEATURE_SET_AAM_ENABLED = 1
ID_ATA_FEATURE_SET_AAM_VENDOR_RECOMMENDED_VALUE = 128
ID_ATA_FEATURE_SET_HPA = 1
ID_ATA_FEATURE_SET_HPA_ENABLED = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 238
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 238
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_FS_LABEL = "1TB-2"
ID_FS_LABEL_ENC = "1TB-2"
ID_FS_TYPE = "xfs"
ID_FS_USAGE = "filesystem"
ID_FS_UUID = "b41436e4-675a-4169-8577-55de7c8d666f"
ID_FS_UUID_ENC = "b41436e4-675a-4169-8577-55de7c8d666f"
ID_MODEL = "WDC_WD10EADS-00L5B1"
ID_MODEL_ENC = "WDC\x20WD10EADS-00L5B1\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PART_ENTRY_DISK = "8:208"
ID_PART_ENTRY_NAME = "primary"
ID_PART_ENTRY_NUMBER = 1
ID_PART_ENTRY_OFFSET = 2048
ID_PART_ENTRY_SCHEME = "gpt"
ID_PART_ENTRY_SIZE = 1953521664
ID_PART_ENTRY_TYPE = "0fc63daf-8483-4772-8e79-3d69d8477de4"
ID_PART_ENTRY_UUID = "684b65e1-4711-4f53-a1d1-fa75db33bc3e"
ID_PART_TABLE_TYPE = "gpt"
ID_PART_TABLE_UUID = "24697ce4-8138-485d-babb-51e5e1b91310"
ID_PATH = "pci-0000:0d:00.0-usb-0:1:1.0-scsi-0:0:0:1"
ID_PATH_TAG = "pci-0000_0d_00_0-usb-0_1_1_0-scsi-0_0_0_1"
ID_REVISION = "01.01A01"
ID_SERIAL = "WDC_WD10EADS-00L5B1_WD-WCAU4D967611"
ID_SERIAL_SHORT = "WD-WCAU4D967611"
ID_TYPE = "disk"
ID_WWN = "0x50014ee258e839e0"
ID_WWN_WITH_EXTENSION = "0x50014ee258e839e0"
MAJOR = 8
MINOR = 209
PARTN = 1
PARTNAME = "primary"
SUBSYSTEM = "block"
USEC_INITIALIZED = 111312916

[/dev/disk/by-id/ata-ST4000VN008-2DR166_ZGY8Z2WZ]
DEVLINKS = "/dev/disk/by-id/ata-ST4000VN008-2DR166_ZGY8Z2WZ /dev/disk/by-id/wwn-0x5000c500c8e5646a /dev/disk/by-label/4TB-1 /dev/disk/by-path/pci-0000:0d:00.0-usb-0:1:1.0-scsi-0:0:0:0 /dev/disk/by-uuid/97666c1c-3780-4670-a26c-1700a109e684"
DEVNAME = "/dev/sdm"
DEVPATH = "/devices/pci0000:00/0000:00:1c.7/0000:0d:00.0/usb6/6-1/6-1:1.0/host10/target10:0:0/10:0:0:0/block/sdm"
DEVTYPE = "disk"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_APM = 1
ID_ATA_FEATURE_SET_APM_CURRENT_VALUE = 128
ID_ATA_FEATURE_SET_APM_ENABLED = 1
ID_ATA_FEATURE_SET_HPA = 1
ID_ATA_FEATURE_SET_HPA_ENABLED = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 434
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 434
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 5980
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_FS_LABEL = "4TB-1"
ID_FS_LABEL_ENC = "4TB-1"
ID_FS_TYPE = "ext4"
ID_FS_USAGE = "filesystem"
ID_FS_UUID = "97666c1c-3780-4670-a26c-1700a109e684"
ID_FS_UUID_ENC = "97666c1c-3780-4670-a26c-1700a109e684"
ID_FS_VERSION = 1.0
ID_MODEL = "ST4000VN008-2DR166"
ID_MODEL_ENC = "ST4000VN008-2DR166\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PATH = "pci-0000:0d:00.0-usb-0:1:1.0-scsi-0:0:0:0"
ID_PATH_TAG = "pci-0000_0d_00_0-usb-0_1_1_0-scsi-0_0_0_0"
ID_REVISION = "SC60"
ID_SERIAL = "ST4000VN008-2DR166_ZGY8Z2WZ"
ID_SERIAL_SHORT = "ZGY8Z2WZ"
ID_TYPE = "disk"
ID_WWN = "0x5000c500c8e5646a"
ID_WWN_WITH_EXTENSION = "0x5000c500c8e5646a"
MAJOR = 8
MINOR = 192
SUBSYSTEM = "block"
USEC_INITIALIZED = 111178224

[/dev/disk/by-id/ata-ST4000VN008-2DR166_ZGY9126P]
DEVLINKS = "/dev/disk/by-id/ata-ST4000VN008-2DR166_ZGY9126P /dev/disk/by-id/wwn-0x5000c500c8fd8e3c /dev/disk/by-label/4TB-2 /dev/disk/by-path/pci-0000:04:00.0-sas-phy3-lun-0 /dev/disk/by-uuid/85fa0c9e-f93b-41f0-9f65-eb4a36fdf5a5"
DEVNAME = "/dev/sdf"
DEVPATH = "/devices/pci0000:00/0000:00:03.0/0000:04:00.0/host7/port-7:4/end_device-7:4/target7:0:4/7:0:4:0/block/sdf"
DEVTYPE = "disk"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_APM = 1
ID_ATA_FEATURE_SET_APM_CURRENT_VALUE = 128
ID_ATA_FEATURE_SET_APM_ENABLED = 1
ID_ATA_FEATURE_SET_HPA = 1
ID_ATA_FEATURE_SET_HPA_ENABLED = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 444
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 444
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 5980
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_FS_LABEL = "4TB-2"
ID_FS_LABEL_ENC = "4TB-2"
ID_FS_TYPE = "ext4"
ID_FS_USAGE = "filesystem"
ID_FS_UUID = "85fa0c9e-f93b-41f0-9f65-eb4a36fdf5a5"
ID_FS_UUID_ENC = "85fa0c9e-f93b-41f0-9f65-eb4a36fdf5a5"
ID_FS_VERSION = 1.0
ID_MODEL = "ST4000VN008-2DR166"
ID_MODEL_ENC = "ST4000VN008-2DR166\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PATH = "pci-0000:04:00.0-sas-phy3-lun-0"
ID_PATH_TAG = "pci-0000_04_00_0-sas-phy3-lun-0"
ID_REVISION = "SC60"
ID_SERIAL = "ST4000VN008-2DR166_ZGY9126P"
ID_SERIAL_SHORT = "ZGY9126P"
ID_TYPE = "disk"
ID_WWN = "0x5000c500c8fd8e3c"
ID_WWN_WITH_EXTENSION = "0x5000c500c8fd8e3c"
MAJOR = 8
MINOR = 80
SUBSYSTEM = "block"
USEC_INITIALIZED = 19312073

[/dev/disk/by-id/ata-ST6000VN001-2BB186_ZR10SAK0]
DEVLINKS = "/dev/disk/by-id/ata-ST6000VN001-2BB186_ZR10SAK0 /dev/disk/by-id/wwn-0x5000c500db1047b1 /dev/disk/by-label/6TB\x20-\x20\x281\x29 /dev/disk/by-path/pci-0000:04:00.0-sas-phy0-lun-0 /dev/disk/by-uuid/966fa765-99a6-467b-a311-5297723f113e"
DEVNAME = "/dev/sdc"
DEVPATH = "/devices/pci0000:00/0000:00:03.0/0000:04:00.0/host7/port-7:1/end_device-7:1/target7:0:1/7:0:1:0/block/sdc"
DEVTYPE = "disk"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_HPA = 1
ID_ATA_FEATURE_SET_HPA_ENABLED = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 66262
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 66262
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 5425
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_FS_LABEL = "6TB_-__1_"
ID_FS_LABEL_ENC = "6TB\x20-\x20\x281\x29"
ID_FS_TYPE = "ext4"
ID_FS_USAGE = "filesystem"
ID_FS_UUID = "966fa765-99a6-467b-a311-5297723f113e"
ID_FS_UUID_ENC = "966fa765-99a6-467b-a311-5297723f113e"
ID_FS_VERSION = 1.0
ID_MODEL = "ST6000VN001-2BB186"
ID_MODEL_ENC = "ST6000VN001-2BB186\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PATH = "pci-0000:04:00.0-sas-phy0-lun-0"
ID_PATH_TAG = "pci-0000_04_00_0-sas-phy0-lun-0"
ID_REVISION = "SC60"
ID_SERIAL = "ST6000VN001-2BB186_ZR10SAK0"
ID_SERIAL_SHORT = "ZR10SAK0"
ID_TYPE = "disk"
ID_WWN = "0x5000c500db1047b1"
ID_WWN_WITH_EXTENSION = "0x5000c500db1047b1"
MAJOR = 8
MINOR = 32
SUBSYSTEM = "block"
USEC_INITIALIZED = 19315146

[/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2H678P]
DEVLINKS = "/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2H678P /dev/disk/by-id/wwn-0x5000c500db5e4d6a /dev/disk/by-path/pci-0000:04:00.0-sas-phy2-lun-0"
DEVNAME = "/dev/sde"
DEVPATH = "/devices/pci0000:00/0000:00:03.0/0000:04:00.0/host7/port-7:3/end_device-7:3/target7:0:3/7:0:3:0/block/sde"
DEVTYPE = "disk"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 66804
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 66804
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 7200
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_MODEL = "ST14000NM001G-2KJ103"
ID_MODEL_ENC = "ST14000NM001G-2KJ103\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PART_TABLE_TYPE = "gpt"
ID_PART_TABLE_UUID = "04ba71dd-b8d4-451d-8803-5a19c6574bea"
ID_PATH = "pci-0000:04:00.0-sas-phy2-lun-0"
ID_PATH_TAG = "pci-0000_04_00_0-sas-phy2-lun-0"
ID_REVISION = "SN03"
ID_SERIAL = "ST14000NM001G-2KJ103_ZL2H678P"
ID_SERIAL_SHORT = "ZL2H678P"
ID_TYPE = "disk"
ID_WWN = "0x5000c500db5e4d6a"
ID_WWN_WITH_EXTENSION = "0x5000c500db5e4d6a"
MAJOR = 8
MINOR = 64
SUBSYSTEM = "block"
USEC_INITIALIZED = 19125897

[/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2HE85K]
DEVLINKS = "/dev/disk/by-id/ata-ST14000NM001G-2KJ103_ZL2HE85K /dev/disk/by-id/wwn-0x5000c500db6c6aa6 /dev/disk/by-path/pci-0000:04:00.0-sas-phy1-lun-0"
DEVNAME = "/dev/sdd"
DEVPATH = "/devices/pci0000:00/0000:00:03.0/0000:04:00.0/host7/port-7:2/end_device-7:2/target7:0:2/7:0:2:0/block/sdd"
DEVTYPE = "disk"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 66766
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 66766
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_ROTATION_RATE_RPM = 7200
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_MODEL = "ST14000NM001G-2KJ103"
ID_MODEL_ENC = "ST14000NM001G-2KJ103\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PART_TABLE_TYPE = "gpt"
ID_PART_TABLE_UUID = "9ecf4f69-305c-47eb-a6a8-4719d4f7279f"
ID_PATH = "pci-0000:04:00.0-sas-phy1-lun-0"
ID_PATH_TAG = "pci-0000_04_00_0-sas-phy1-lun-0"
ID_REVISION = "SN03"
ID_SERIAL = "ST14000NM001G-2KJ103_ZL2HE85K"
ID_SERIAL_SHORT = "ZL2HE85K"
ID_TYPE = "disk"
ID_WWN = "0x5000c500db6c6aa6"
ID_WWN_WITH_EXTENSION = "0x5000c500db6c6aa6"
MAJOR = 8
MINOR = 48
SUBSYSTEM = "block"
USEC_INITIALIZED = 19125633

[/dev/disk/by-id/ata-WDC_WD10EADS-00L5B1_WD-WCAU4D967611]
DEVLINKS = "/dev/disk/by-id/ata-WDC_WD10EADS-00L5B1_WD-WCAU4D967611 /dev/disk/by-id/wwn-0x50014ee258e839e0 /dev/disk/by-path/pci-0000:0d:00.0-usb-0:1:1.0-scsi-0:0:0:1"
DEVNAME = "/dev/sdn"
DEVPATH = "/devices/pci0000:00/0000:00:1c.7/0000:0d:00.0/usb6/6-1/6-1:1.0/host10/target10:0:0/10:0:0:1/block/sdn"
DEVTYPE = "disk"
ID_ATA = 1
ID_ATA_DOWNLOAD_MICROCODE = 1
ID_ATA_FEATURE_SET_AAM = 1
ID_ATA_FEATURE_SET_AAM_CURRENT_VALUE = 254
ID_ATA_FEATURE_SET_AAM_ENABLED = 1
ID_ATA_FEATURE_SET_AAM_VENDOR_RECOMMENDED_VALUE = 128
ID_ATA_FEATURE_SET_HPA = 1
ID_ATA_FEATURE_SET_HPA_ENABLED = 1
ID_ATA_FEATURE_SET_PM = 1
ID_ATA_FEATURE_SET_PM_ENABLED = 1
ID_ATA_FEATURE_SET_PUIS = 1
ID_ATA_FEATURE_SET_PUIS_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY = 1
ID_ATA_FEATURE_SET_SECURITY_ENABLED = 0
ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN = 238
ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN = 238
ID_ATA_FEATURE_SET_SMART = 1
ID_ATA_FEATURE_SET_SMART_ENABLED = 1
ID_ATA_SATA = 1
ID_ATA_SATA_SIGNAL_RATE_GEN1 = 1
ID_ATA_SATA_SIGNAL_RATE_GEN2 = 1
ID_ATA_WRITE_CACHE = 1
ID_ATA_WRITE_CACHE_ENABLED = 1
ID_BUS = "ata"
ID_MODEL = "WDC_WD10EADS-00L5B1"
ID_MODEL_ENC = "WDC\x20WD10EADS-00L5B1\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20"
ID_PART_TABLE_TYPE = "gpt"
ID_PART_TABLE_UUID = "24697ce4-8138-485d-babb-51e5e1b91310"
ID_PATH = "pci-0000:0d:00.0-usb-0:1:1.0-scsi-0:0:0:1"
ID_PATH_TAG = "pci-0000_0d_00_0-usb-0_1_1_0-scsi-0_0_0_1"
ID_REVISION = "01.01A01"
ID_SERIAL = "WDC_WD10EADS-00L5B1_WD-WCAU4D967611"
ID_SERIAL_SHORT = "WD-WCAU4D967611"
ID_TYPE = "disk"
ID_WWN = "0x50014ee258e839e0"
ID_WWN_WITH_EXTENSION = "0x50014ee258e839e0"
MAJOR = 8
MINOR = 208
SUBSYSTEM = "block"
USEC_INITIALIZED = 111209601



 

Edited by Mike S
Link to comment

They are formatted ext4, but at the disk level.  Udev does not show any partition info for the disks, so UD doesn't think they are formatted.

 

If you look at the UD webpage, you'll see that UD doesn't see a partition, because udev does not present info on a partition.

 

I'm not that familiar with ext4 file systems, but I'll do some research.  For now assume UD can't handle this.

 

If you can, re-install them in the old Ubuntu system and mount them as remote shares and transfer your data that way.

  • Thanks 1
Link to comment
3 hours ago, dlandon said:

They are formatted ext4, but at the disk level.  Udev does not show any partition info for the disks, so UD doesn't think they are formatted.

 

If you look at the UD webpage, you'll see that UD doesn't see a partition, because udev does not present info on a partition.

 

I'm not that familiar with ext4 file systems, but I'll do some research.  For now assume UD can't handle this.

 

If you can, re-install them in the old Ubuntu system and mount them as remote shares and transfer your data that way.

 

Okay thanks. Ya unfortunately was trying to get to the data without needing to do that because I dont want to put the data into the array and don't have 14TB of non array free storage atm. I will see what I can do thanks again. Maybe I will need to go buy another 14 lol

Link to comment

Hi all, Finally getting the hang of Unraid (spaceinvader one videos are gold).  Installed this a few days ago and have started messing around with it.

 

I came across this issue where there is a "Virtual Disk_" in unassigned devices (image attached). I have been unable to unmount it.  The system tells me it's not mounted.

 

I first noticed that the server was taking a significant amount of time responding when using the GUI (simple operations such as going from Dashboard to Main to Shares).  That prompted me to look at the syslog.  I tracked it down to the /dev/sda device. Looks like there's a virtual disk. Goal is to remove it.

 

I did go into the BIOS and disabled all IPMI virtual disk, virtual CD-ROMS, virtual anything as well.

 

Has anyone come across this by any chance? Or perhaps can point me to other areas for me to research?

 

This is a custom box from server parts: Supermicro X8SIL-F, Xeon x3430, 4GB of ECC RAM. 

 

 

483652626_VirtualDisk_.thumb.png.6e59ec0343015bd0f42307d9ff98ca33.png

syslog (4) (1)

Link to comment
8 hours ago, fel0ncod3 said:

Hi all, Finally getting the hang of Unraid (spaceinvader one videos are gold).  Installed this a few days ago and have started messing around with it.

 

I came across this issue where there is a "Virtual Disk_" in unassigned devices (image attached). I have been unable to unmount it.  The system tells me it's not mounted.

 

I first noticed that the server was taking a significant amount of time responding when using the GUI (simple operations such as going from Dashboard to Main to Shares).  That prompted me to look at the syslog.  I tracked it down to the /dev/sda device. Looks like there's a virtual disk. Goal is to remove it.

 

I did go into the BIOS and disabled all IPMI virtual disk, virtual CD-ROMS, virtual anything as well.

 

Has anyone come across this by any chance? Or perhaps can point me to other areas for me to research?

 

This is a custom box from server parts: Supermicro X8SIL-F, Xeon x3430, 4GB of ECC RAM. 

 

 

483652626_VirtualDisk_.thumb.png.6e59ec0343015bd0f42307d9ff98ca33.png

syslog (4) (1) 386.61 kB · 0 downloads

Normally sda is the Unraid flash drive.  In your case the flash is sdb.  Is there something on your flash drive causing this?  Take your flash to a PC and see if there is something that might be the problem.

Link to comment
10 hours ago, nathan909 said:

I'm having issues removing a SMB share, any time I try it says success, but its still there. It looks to have a mount point of "_". If I change the mount point, it adds a new share that I can remove. If i change mount point to "_", I get a fail

 

Hium9Ag.png

How did you create that smb share?  The source is very strange - '//192.168.1.11/></a>'.  It contains html code.

Link to comment
2 hours ago, dlandon said:

How did you create that smb share?  The source is very strange - '//192.168.1.11/></a>'.  It contains html code.

 

With the GUI. I had problems connecting so I updated plug-in, after update I couldn't edit share so I added a new one.

FYI I've tried removing/installing plug-in, but shares are still there.

Link to comment
3 minutes ago, nathan909 said:

 

With the GUI. I had problems connecting so I updated plug-in, after update I couldn't edit share so I added a new one.

FYI I've tried removing/installing plug-in, but shares are still there.

That won't make them go away.  UD is designed to leave the configured shares when it is uninstalled.

 

So you can't delete the share at all?  It sounds like the configuration file might be corrupted.  You can start over by doing this:

  • Unmount all remote shares.
  • Delete the /flash/config/plugins/unassigned.devices/samba_mount.cfg file.
  • Click on the double arrows in the upper right corner of the UD page.
  • Re-enter your remote shares.
  • Like 1
Link to comment
2 hours ago, dlandon said:

That won't make them go away.  UD is designed to leave the configured shares when it is uninstalled.

 

So you can't delete the share at all?  It sounds like the configuration file might be corrupted.  You can start over by doing this:

  • Unmount all remote shares.
  • Delete the /flash/config/plugins/unassigned.devices/samba_mount.cfg file.
  • Click on the double arrows in the upper right corner of the UD page.
  • Re-enter your remote shares.

 

No it wouldn't delete.
 

I just uninstalled plugin, then edited/removed the bad entry in: /boot/config/plugins/unassigned.devices/samba_mount.cfg

Then reinstalled


This solved my problem, Thanks for your help!!!

 

Edited by nathan909
Link to comment
On 12/23/2021 at 2:11 PM, dlandon said:

Normally sda is the Unraid flash drive.  In your case the flash is sdb.  Is there something on your flash drive causing this?  Take your flash to a PC and see if there is something that might be the problem.

 

For me the Unraid flash is sdc. The two external USB hard drives connected via UD are sda and sdb. Is there a reason to worry or do something?

Link to comment
1 hour ago, Ruato said:

 

For me the Unraid flash is sdc. The two external USB hard drives connected via UD are sda and sdb. Is there a reason to worry or do something?

No.  The sdX designations are assigned dynamically by the Linux kernel and the only assumption Unraid makes it that they stay constant after boot for array and pool devices.

Link to comment
On 12/22/2021 at 6:58 AM, dlandon said:

 

I've fixed the clear disk not showing after a preclear:

193105679_UDPage.png.b1ebb41df09f94b34e761d5677c58b8a.png

 

I added the clear disk icon because parted has issues at times removing partitions.  In your case, parted said the partition did not exist.  Obviously there is a partition.  The clear disk does a 'wipefs' that removes any and all partitions from a disk.  Users have had to go to the command line to clear a disk, and there is too much chance of making a mistake. 

Did you ever push the fix to the Unraid Community Apps?

 

The red X shows on some UD devices but not others like before. Still can't delete those partitions that Parted says don't exist.

Edited by chuckthetekkie
Link to comment
11 hours ago, chuckthetekkie said:

Did you ever push the fix to the Unraid Community Apps?

 

The red X shows on some UD devices but not others like before. Still can't delete those partitions that Parted says don't exist.

I plan on a release after the Holidays.  I'm working on some issues I want resolved by the next release.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.