Jump to content
Sign in to follow this  
ridley

Array drive failure

18 posts in this topic Last Reply

Recommended Posts

I have an array with disk 20 an 8tb drive showing the red X so I need to sort it out.

 

 Drive 21 is another 8Tb drive that appears to have nothing on it.

 

Is there a way to use the empty 8tb that is in the array, to replace the faulty drive and then rebuild the array?

 

 

Share this post


Link to post
13 minutes ago, ridley said:

Is there a way to use the empty 8tb that is in the array, to replace the faulty drive and then rebuild the array?

No, but there may be nothing wrong with disk20 and you might be able to rebuild to the same disk.

 

Go to Tools - Diagnostics and attach the complete Diagnostics ZIP file to your NEXT post.

Share this post


Link to post

SMART for disk20 looks OK. Maybe a bad connection so you might check that. Syslog resets when you reboot so nothing in the diagnostics that might tell us what happened.

 

You have a lot of small disks, many still ReiserFS. Have you considered upsizing disks to get same capacity with fewer disks? Larger disks perform better and fewer disks are fewer opportunities for problems.

 

You have so many disks that I didn't look at SMART for any of the others. Do you have SMART warnings on the Dashboard for any disks?

 

Do you have a spare to rebuild to? Or you can rebuild to the same disk if you are confident in the rest of your array. Do you know how to rebuild?

Share this post


Link to post

Apparently I do now have two smart warning on other disks now. One drivev is showing errors but is excluded from shares  as I was about to delete that drive from the array as a move to fewer larger drives.

 

the other was not showing errors before the reboot.

 

Most of the drives are in s netapp drive array Inc the one with the red X.

Share this post


Link to post
19 minutes ago, ridley said:

Apparently I do now have two smart warning on other disks now.

Which disks are these?

Share this post


Link to post
Posted (edited)

Disks 5 & 7

 

Though 7 is a drive I was in then process of decommissioning and has no data on it.

Edited by ridley

Share this post


Link to post

Those few CRC on disk7 are not a concern. It is part of the array currently and will have to stay for the rebuild. 1 pending on disk5 not ideal but we'll just have to live with for now.

 

Do you want to rebuild to the same disk?

 

Share this post


Link to post

I don't have any spare 8tb drives lying around, so I don't suppose I have a choice at the moment.

 

I could buy another but would prefer not to at the moment.

 

If I rebuilt to that drive and it failed I would be just back to my present position, right?

Share this post


Link to post

More to the point, if I wanted to rebuild to that disk, how do I?

Share this post


Link to post

Stop array

Unassign disabled disk

Start array with disabled disk unassigned

Stop array

Reassign disabled disk

Start array to begin rebuild

Share this post


Link to post

Thanks. Rebuild has been going for some time.

 

It does seem to have slowed though. It seemed to be going along at 100m/s roughly until it got beging the max utilisation of any other drive @about 4Tb. Now it is at about 12mb/s. 

 

I will leave it going but it seems odd, I would have thought it would speed up if anything or am I misunderstanding?

Share this post


Link to post

Shouldn't have slowed that much. Post new diagnostics.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this