Repeated hard drive failures on a LSI SAS 9207-8i

Recommended Posts

Hey everyone.  New guy here.  I built a new AMD PC for myself and figured I'd use my old intel box with full tower as an unraid build and move my plex/sabnzbd/sonarr/radarr setup on over.  I had several buffalo diskstations lying around and figured I'd just start throwing these disks in.  Most are 4TB but one had four 6TBs inside.  MB is maxed out at 6 SATA ports so picked up a LSI SAS 9207-8i.  Initially everything seemed great. I ran the extended smart tests on all the drives and 1 of them failed so started my array with the other three and five 4TBs.  I transferred over several TB of data and everything was going fine until I started hitting one of the 6TB Western Digital Reds.  Started getting massive read errors and eventually unraid just pulled it out of the array.  I spun it down, removed it threw another 4TB in.  Then I discovered the array wanted me to replace the 6TB with another one that is larger or the same size and since this is all a new build, I decided to rebuild the array and remove it.  Now during the parity drive rebuild, another 6TB WD drive is throwing up a ton of read errors.  It's certainly possible that all these drives are just really old, but it seems unlikely to me that 3 out of 4 (and possibly all 4) are bad.  Could it be the storage card?  Could it be the SAS to SATA cable?  I'm sure it could be either of those things, but there are other drives plugged into the same card/port/cable and they seem to be fine.  


Guess I'm just looking for some wisdom from folks out there.  And any suggestions on the best way to figure it out.  And it would be great to know what I should be doing to test these drives before I start adding them to my array.  I've seen some talk about a pre-clear plugin/app or maybe running badblocks but it seems there isn't a consensus on the 'best' way to do it.


As for technical ability, I've built computers for years but I'm a MS weenie.  Linux is all new to me but I'm open to learning.  


Thanks in advance for any and all help.  Greatly appreciate it.

Link to comment
11 minutes ago, ZenBuddha said:

I assume by highlighting NEXT you mean I shouldn't post it in a reply here?  

what you have just done is what is wanted.    Some people add it to the original post, and then that gets missed as doing so does not cause the thread to be marked as having new cobtent.   

Link to comment

Thank you for the guidance.

So quick google search puts this broadcom page at the top.  And from what I've read on this site, people seem to be using this one:


Which claims to be version

And then I found these instructions that I assume I alter for my make/model.

Which to summarize:

  1. create bootable USB (Rufus helps)
  2. copy over the sas2flsh.exe, .bin and .rom files from the zip I downloaded from broadcom
  3. boot to the USB
  4. erase the flash with this command: SAS2FLSH.EXE -o -e 6
  5. flash it with: sas2flsh -o -f xxxxxx.bin -b xxxxxxx.rom
  6. check that it's correct: sas2flsh -listall
  7. reboot


Did I miss anything?

Thanks again.

Link to comment

Well, that was harder than expected.  When I ran the sas2flash commands I got a Failed to intialize PAL. Exiting program.  Some more googling told me that I needed to boot to UEFI and after lots of digging and retrying, I eventually figured out that my ASRock z75 pro3 motherboard was capable of UEFI but that it was still using legacy.  I'm still not clear how I set it to UEFI as I was trying different settings in the bios around the USB ports and drives.  Eventually I found a command that asked to reset all the UEFI settings to default and I said go for it.  Then I saw an option in my BIOS to "Launch EFI Shell from filesystem device. Attempts to Launch EFI Shell application (Shellx64.efi) from one of the available filesystem devices."  Finding a full shell that worked was a whole other search but eventually found this one. Renamed it Shellx64.efi and put it on a non-bootable USB drive.  And the USB had to be in a particular USB port on my motherboard for the bios to recognize it.  Found that answer here.  Anyways, wanted to record that for anyone else struggling.  So the instructions I posted above would be altered to not create a bootable USB drive but just a regular MBR, FAT drive.  Copy over those same files but you need to get the sas2flash.efi and that Shell_full.efi I linked in this post and make sure it's named whatever your bios needs it to be.


I was able to run the commands, flash the controller card. I'm back online.  Now what? Should I run SMART tests on the 6TB drives I thought were bad?  Should I run some other read/write commands to really test them?  Should I just create a share that only uses one of those drives and start read/write to it?  How do I go about testing these drives before I put them in and start losing data?


Thanks again!  Really appreciate all the help.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.