Jump to content
RubyRose96

Unassigned device not correctly reporting drive fill

5 posts in this topic Last Reply

Recommended Posts

So I logged into one of my vm's this morning to find it had paused overnight. Checking on the unraid gui the unassigned drive pased through to the vm was reporting as full, but when I rebooted the vm the drive was only showing as about half full. 

Is there any reason unraid isn't seing the usage correctly?

 

EDIT: the only workaround i've found so far is to move everything off of the drive image, remove the image and recreate it.

 

da81c1953b52d571e2d8c5bd442a91b1.png

95ca628be41851186a0ae0a4b2a8e699.png

Edited by RubyRose96

Share this post


Link to post
9 hours ago, RubyRose96 said:

So I logged into one of my vm's this morning to find it had paused overnight. Checking on the unraid gui the unassigned drive pased through to the vm was reporting as full, but when I rebooted the vm the drive was only showing as about half full. 

Is there any reason unraid isn't seing the usage correctly?

 

EDIT: the only workaround i've found so far is to move everything off of the drive image, remove the image and recreate it.

 

da81c1953b52d571e2d8c5bd442a91b1.png

95ca628be41851186a0ae0a4b2a8e699.png

You can't mount a passed through disk with UD.  You are mounting the disk with UD and then checking the 'Pass Thru'.  That's not how it works.  You mark the disk as 'Pass Thru' and don't mount it with UD.  UD won't let you mount it if it is marked 'Pass Thru'.

 

When UD mounts the disk and your VM is using it as a passed through disk, it will get corrupted.

Share this post


Link to post
2 hours ago, RubyRose said:

If I try to stay the VM without mounting the disk first I get this error. So where am I going wrong here? 

Screenshot_20200523-110727.jpg

If using a vdisk then the Pass thru option should NOT be checked.    You only use that option when the VM has complete control of the whole physical drive.

Share this post


Link to post
8 hours ago, itimpi said:

If using a vdisk then the Pass thru option should NOT be checked.    You only use that option when the VM has complete control of the whole physical drive.

Aaahhhhh, I get what you mean now. Thanks for clearing that up!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.