[Support] ich777 - AMD Vendor Reset, CoralTPU, hpsahba,...


Recommended Posts

19 minutes ago, cron144 said:

Do you know the background of this behaviour?

Not really but from what I see you are using a Gigabyte motherboard... I only can speak for myself but I really don't like Gigabyte any more... :D

 

19 minutes ago, cron144 said:

What would be the best workaround to keep the monitor off and to have the possiblity to use the console.

I would recommend that you plug in a HDMI dummy plug so that the iGPU thinks a monitor is connected.

Some monitors are not visible to the iGPU if they are turned off or switched to another input and I think this is the main cause of this issue.

I know this is not the best thing to do but if it helps keeping this errors out I would connect a HDMI dummy plug and plug in a monitor if needed.

 

21 minutes ago, cron144 said:

I will do a bios update today.

Please report back if it changes anything, also make sure to set the primary GPU to your iGPU.

 

On my motherboard I have to connect a HDMI dummy plug to the iGPU when a dGPU is in the Server otherwise the iGPU doesn't even get's activated, even when I set the iGPU to the primary graphics card.

Link to comment
11 hours ago, ich777 said:

Not really but from what I see you are using a Gigabyte motherboard... I only can speak for myself but I really don't like Gigabyte any more... :D

Yeah, it seems that this was not the best choice...

11 hours ago, ich777 said:

I know this is not the best thing to do but if it helps keeping this errors out I would connect a HDMI dummy plug and plug in a monitor if needed.

Ok, I will give it a try to avoid errors.

 

In regard to the bios update, it doesnt change anything, but ok. The only GPU in the system is the iGPU and this is set to enabled in bios.

I struggle a bit with the overall power consumption of the system. When all drives spins down and docker is running (no vms, no additional pci-cards) I have 18W consumption, but ok.

 

Thanks a lot for your help.

  • Like 1
Link to comment
14 hours ago, cron144 said:

I struggle a bit with the overall power consumption of the system. When all drives spins down and docker is running (no vms, no additional pci-cards) I have 18W consumption, but ok.

If I got that my only concern was that it is too low so there must be something wrong :) 

  • Haha 1
Link to comment
  • 4 weeks later...

I've been trying to get my iGPU working so I can use HW transcoding in Plex for days now and nothing I seem to do works. 

 

https://forums.unraid.net/topic/92865-support-ich777-amd-vendor-reset-coraltpu-hpsahba/?do=findComment&comment=1076014

 

That is the latest thing I've tried to follow. I even unplugged a monitor from my GPU and plugged one in via HDMI to my MOBO and I still get 

Quote

No device filter specified and no discrete/integrated i915 devices found

when I run the "intel_top_gpu" command. And this doesn't even get me to pointing my Plex docker container at the iGPU for HW transcoding... I've attached my diagnostics so any help someone can provide me would be much appreciated.

tower-diagnostics-20220206-0905.zip

Link to comment
17 minutes ago, MustbeCanadian said:

I've been trying to get my iGPU working so I can use HW transcoding in Plex for days now and nothing I seem to do works. 

I don't see your Intel iGPU in your System devices.

Please make sure that you've set the iGPU to the promary graphics device in your BIOS and try to plug the Monitor in you Motherboard before you boot and see if you get a display output.

 

On my motherboard a Monitor must be plugged in the motherboard to activate it even if I set it to the primary display output when a dedicated GPU is installed, otherwise the iGPU won't be activated (bought a HDMI Dummy Plug for that purpouse).

Link to comment

I found an old DVI-D monitor laying around and plugged it in. That seemed to do the trick for activating it.image.png.a4d289d8e0cd5b13366eb71f6efc2a83.png

 

Now I just have to purchase the dummy plug as a longer term solution and figure out why Plex won't utilize it for HW transcoding. Thanks for your help!

 

For anyone stumbling across this in the future, I'm running an i5-6600 with an Asus H170-E D3 motherboard.

  • Like 1
Link to comment

Hello @ich777,

 

I found that there was a plugin for the NCT6687 driver, would you consider doing a plug in with this patch for the NCT6775 driver : https://git.kernel.org/pub/scm/linux/kernel/git/groeck/linux-staging.git/commit/?id=cd0b8e410937

 

It would allow some of us to have access to the sensors on our Asus mobos, specifically those models :

- PRIME B460-PLUS
- ROG CROSSHAIR VIII IMPACT
- ROG STRIX B550-E GAMING
- ROG STRIX B550-F GAMING,
- ROG STRIX B550-F GAMING (WI-FI)
- ROG STRIX Z490-I GAMING
- TUF GAMING B550M-PLUS
- TUF GAMING B550M-PLUS (WI-FI)
- TUF GAMING B550-PLUS
- TUF GAMING X570-PLUS
- TUF GAMING X570-PRO (WI-FI)

Link to comment
2 hours ago, hot22shot said:

would you consider doing a plug in with this patch for the NCT6775 driver : https://git.kernel.org/pub/scm/linux/kernel/git/groeck/linux-staging.git/commit/?id=cd0b8e410937

I think somebody already asked this in another thread, but I'm not 100% sure if it was the same chip.

 

Correct me if I'm wrong but from my research that I did back then it will be merged to the Linux Kernel, as said above doesn't know exactly if it was that exact chip.

Link to comment
18 hours ago, ich777 said:

I think somebody already asked this in another thread, but I'm not 100% sure if it was the same chip.

 

Correct me if I'm wrong but from my research that I did back then it will be merged to the Linux Kernel, as said above doesn't know exactly if it was that exact chip.

 

Indeed it seems to be included in version 5.16 (https://www.phoronix.com/scan.php?page=news_item&px=ASUS-WMI-NCT6775).

 

But as I understood that unraid kernel version follow the Slackware release, and that the new Slackware 15 is based on 5.15 LTS.

It doesn't look like we'll have 5.16 in the foreseeable future, hence my request 😃

Link to comment
24 minutes ago, hot22shot said:

But as I understood that unraid kernel version follow the Slackware release, and that the new Slackware 15 is based on 5.15 LTS.

Not really, unRAID is at least in my opinion it's own Distribution with it's own (not all) packages and various fixes and customization,...

The current test build from unRAID is based on Kernel version 5.15.16 and not like Slackware current that is based on Kernel version 5.15.19 (or even Slackware 15 is based on 5.15.19 from what I know).

 

25 minutes ago, hot22shot said:

It doesn't look like we'll have 5.16 in the foreseeable future, hence my request 😃

I think Kernel 5.16 is coming maybe sooner than you think because it introduces various fixes for Alder Lake mostly fixing crashes when the iGPU is used for transcoding in Emby/Jellyfin/Plex Docker containers.

 

But keep in mind even if it comes to unRAID and you use for example the ZFS plugin from @steini84 you are out of luck because ZFS currently doesn't work on Kernel version 5.16+

  • Thanks 1
Link to comment

When i want to restart my win 10 vm is crtashing in booting, and afterr few sec crash docker and web gui crash and the host not respons. i need to push the resset button.

some time i got this before crash 

Quote

 

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: version 1.1

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: performing pre-reset

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: performing reset

Feb 16 15:24:36 Lelopo-Maxi kernel: ATOM BIOS: xxx-xxx-xxx

Feb 16 15:24:36 Lelopo-Maxi kernel: vendor-reset-drm: atomfirmware: bios_scratch_reg_offset initialized to 4c

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: bus reset disabled? yes

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: SMU response reg: 0, sol reg: 0, mp1 intr enabled? no, bl ready? yes

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: performing post-reset

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: reset result = 0

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: vfio_ecap_init: hiding ecap 0x19@0x270

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: vfio_ecap_init: hiding ecap 0x1b@0x2d0

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: vfio_ecap_init: hiding ecap 0x25@0x400

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: vfio_ecap_init: hiding ecap 0x26@0x410

Feb 16 15:24:36 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: vfio_ecap_init: hiding ecap 0x27@0x440

Feb 16 15:24:40 Lelopo-Maxi kernel: vfio-pci 0000:00:1b.0: enabling device (0000 -> 0002)

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: version 1.1

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: performing pre-reset

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: performing reset

Feb 16 15:24:43 Lelopo-Maxi kernel: ATOM BIOS: xxx-xxx-xxx

Feb 16 15:24:43 Lelopo-Maxi kernel: vendor-reset-drm: atomfirmware: bios_scratch_reg_offset initialized to 4c

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: bus reset disabled? yes

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: SMU response reg: 0, sol reg: 0, mp1 intr enabled? no, bl ready? yes

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: performing post-reset

Feb 16 15:24:43 Lelopo-Maxi kernel: vfio-pci 0000:04:00.0: AMD_NAVI14: reset result = 0

 

 

Link to comment
7 minutes ago, momsz said:

When i want to restart my win 10 vm is crtashing in booting, and afterr few sec crash docker and web gui crash and the host not respons. i need to push the resset button.

Does this happen on every reboot from the VM or not?

 

Keep in mind the patch is not perfect and may not work all of the time.

 

Have you already tried the primary PCIe slot?

Link to comment
3 minutes ago, ich777 said:

Does this happen on every reboot from the VM or not?

 

Keep in mind the patch is not perfect and may not work all of the time.

 

Have you already tried the primary PCIe slot?

1. Yes it happen every reboot 

2. i dont tried in the primmary jut in the secundery becouse in bios i cant change primery card 

Link to comment
49 minutes ago, ich777 said:

Does this happen on every reboot from the VM or not?

 

Keep in mind the patch is not perfect and may not work all of the time.

 

Have you already tried the primary PCIe slot?

ErrorWarningSystemArrayLogin


Feb 16 19:24:00 Lelopo-Maxi kernel: FS: 0000151957d98640(0000) GS:ffff88887fc80000(0000) knlGS:0000000000000000
Feb 16 19:24:00 Lelopo-Maxi kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 16 19:24:00 Lelopo-Maxi kernel: CR2: ffffc90030c89000 CR3: 00000001981c4002 CR4: 00000000001726e0
Feb 16 19:24:00 Lelopo-Maxi kernel: Call Trace:
Feb 16 19:24:00 Lelopo-Maxi kernel: amdgpu_device_fini_sw+0xee/0x25b [amdgpu]
Feb 16 19:24:00 Lelopo-Maxi kernel: amdgpu_driver_release_kms+0x12/0x23 [amdgpu]
Feb 16 19:24:00 Lelopo-Maxi kernel: drm_dev_put+0x31/0x5a [drm]
Feb 16 19:24:00 Lelopo-Maxi kernel: release_nodes+0x3d/0x58
Feb 16 19:24:00 Lelopo-Maxi kernel: devres_release_all+0x95/0xbb
Feb 16 19:24:00 Lelopo-Maxi kernel: device_release_driver_internal+0x102/0x199
Feb 16 19:24:00 Lelopo-Maxi kernel: unbind_store+0x56/0x74
Feb 16 19:24:00 Lelopo-Maxi kernel: kernfs_fop_write_iter+0x123/0x152
Feb 16 19:24:00 Lelopo-Maxi kernel: new_sync_write+0x7c/0xb7
Feb 16 19:24:00 Lelopo-Maxi kernel: vfs_write+0xd9/0x124
Feb 16 19:24:00 Lelopo-Maxi kernel: ksys_write+0x76/0xbe
Feb 16 19:24:00 Lelopo-Maxi kernel: do_syscall_64+0x80/0xa5
Feb 16 19:24:00 Lelopo-Maxi kernel: entry_SYSCALL_64_after_hwframe+0x44/0xae
Feb 16 19:24:00 Lelopo-Maxi kernel: RIP: 0033:0x1519593294af
Feb 16 19:24:00 Lelopo-Maxi kernel: Code: 89 54 24 18 48 89 74 24 10 89 7c 24 08 e8 89 b8 f8 ff 48 8b 54 24 18 48 8b 74 24 10 41 89 c0 8b 7c 24 08 b8 01 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 31 44 89 c7 48 89 44 24 08 e8 dc b8 f8 ff 48
Feb 16 19:24:00 Lelopo-Maxi kernel: RSP: 002b:0000151957d97400 EFLAGS: 00000293 ORIG_RAX: 0000000000000001
Feb 16 19:24:00 Lelopo-Maxi kernel: RAX: ffffffffffffffda RBX: 000000000000000c RCX: 00001519593294af
Feb 16 19:24:00 Lelopo-Maxi kernel: RDX: 000000000000000c RSI: 000015195004a4f0 RDI: 0000000000000024
Feb 16 19:24:00 Lelopo-Maxi kernel: RBP: 000015195004a4f0 R08: 0000000000000000 R09: 0000151950049230
Feb 16 19:24:00 Lelopo-Maxi kernel: R10: 0000000000000000 R11: 0000000000000293 R12: 0000000000000024
Feb 16 19:24:00 Lelopo-Maxi kernel: R13: 0000000000000024 R14: 0000000000000000 R15: 000015195007c230
Feb 16 19:24:00 Lelopo-Maxi kernel: Modules linked in: veth nvidia_modeset(PO) nvidia_uvm(PO) xt_CHECKSUM ipt_REJECT nf_reject_ipv4 ip6table_mangle ip6table_nat iptable_mangle vhost_net tun vhost vhost_iotlb tap xt_nat xt_tcpudp macvlan xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xt_addrtype iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 br_netfilter md_mod nvidia(PO) nct6775 hwmon_vid vendor_reset(O) efivarfs ip6table_filter ip6_tables iptable_filter ip_tables x_tables bonding mxm_wmi intel_wmi_thunderbolt amdgpu x86_pkg_temp_thermal intel_powerclamp coretemp gpu_sched kvm_intel i2c_algo_bit drm_ttm_helper ttm kvm crct10dif_pclmul crc32_pclmul drm_kms_helper crc32c_intel ghash_clmulni_intel aesni_intel btusb crypto_simd cryptd btrtl btbcm btintel rapl drm bluetooth intel_cstate nvme backlight i2c_i801 intel_uncore agpgart i2c_smbus syscopyarea sysfillrect ecdh_generic sysimgblt ecc e1000e fb_sys_fops i2c_core nvme_core ahci libahci wmi button
Feb 16 19:24:00 Lelopo-Maxi kernel: CR2: ffffc90030c89000
Feb 16 19:24:00 Lelopo-Maxi kernel: ---[ end trace 488568fef88066ab ]---
Feb 16 19:24:00 Lelopo-Maxi kernel: RIP: 0010:vcn_v2_0_sw_fini+0x10/0x32 [amdgpu]
Feb 16 19:24:00 Lelopo-Maxi kernel: Code: 60 48 85 c0 74 0d 41 b8 10 00 00 00 31 c9 ff e0 0f 1f 00 31 c9 e9 86 b0 f2 ff 0f 1f 44 00 00 55 48 8b 87 00 17 01 00 48 89 fd <c7> 00 00 00 00 00 e8 1b 97 f5 ff 48 89 ef e8 a8 6d ff ff 85 c0 75
Feb 16 19:24:00 Lelopo-Maxi kernel: RSP: 0018:ffffc90000df3cd0 EFLAGS: 00010206
Feb 16 19:24:00 Lelopo-Maxi kernel: RAX: ffffc90030c89000 RBX: ffff888106300000 RCX: 0000000000000000
Feb 16 19:24:00 Lelopo-Maxi kernel: RDX: 000000000000000f RSI: 0000000000210d00 RDI: ffff888106300000
Feb 16 19:24:00 Lelopo-Maxi kernel: RBP: ffff888106300000 R08: 0000000000000001 R09: ffffffffa063ee69
Feb 16 19:24:00 Lelopo-Maxi kernel: R10: ffff888105886800 R11: 0000000000000000 R12: 0000000000000008
Feb 16 19:24:00 Lelopo-Maxi kernel: R13: ffff8881063163b8 R14: ffff888102397368 R15: ffff888102397364
Feb 16 19:24:00 Lelopo-Maxi kernel: FS: 0000151957d98640(0000) GS:ffff88887fc80000(0000) knlGS:0000000000000000
Feb 16 19:24:00 Lelopo-Maxi kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 16 19:24:00 Lelopo-Maxi kernel: CR2: ffffc90030c89000 CR3: 00000001981c4002 CR4: 00000000001726e0
Feb 16 19:25:03 Lelopo-Maxi nginx: 2022/02/16 19:25:03 [error] 8542#8542: *826 open() "/usr/local/emhttp/announce" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "GET /announce?info_hash=eZ%a9R%18%3a%91%1f%18%caI%d6%f6Y4%b2%ef%c0%f7X&peer_id=-TR3000-rc6qtmp1wdf8&port=51413&uploaded=0&downloaded=0&left=0&numwant=80&key=451cbce3&compact=1&supportcrypto=1&event=started HTTP/1.1", host: "pow7.com"
Feb 16 19:25:23 Lelopo-Maxi nginx: 2022/02/16 19:25:23 [error] 8542#8542: *938 open() "/usr/local/emhttp/announce" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "GET /announce?info_hash=eZ%a9R%18%3a%91%1f%18%caI%d6%f6Y4%b2%ef%c0%f7X&peer_id=-TR3000-rc6qtmp1wdf8&port=51413&uploaded=0&downloaded=0&left=0&numwant=80&key=451cbce3&compact=1&supportcrypto=1&event=started HTTP/1.1", host: "pow7.com"

I put the primery and i got this

Link to comment
21 minutes ago, momsz said:
ErrorWarningSystemArrayLogin


Feb 16 19:24:00 Lelopo-Maxi kernel: FS: 0000151957d98640(0000) GS:ffff88887fc80000(0000) knlGS:0000000000000000
Feb 16 19:24:00 Lelopo-Maxi kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 16 19:24:00 Lelopo-Maxi kernel: CR2: ffffc90030c89000 CR3: 00000001981c4002 CR4: 00000000001726e0
Feb 16 19:24:00 Lelopo-Maxi kernel: Call Trace:
Feb 16 19:24:00 Lelopo-Maxi kernel: amdgpu_device_fini_sw+0xee/0x25b [amdgpu]
Feb 16 19:24:00 Lelopo-Maxi kernel: amdgpu_driver_release_kms+0x12/0x23 [amdgpu]
Feb 16 19:24:00 Lelopo-Maxi kernel: drm_dev_put+0x31/0x5a [drm]
Feb 16 19:24:00 Lelopo-Maxi kernel: release_nodes+0x3d/0x58
Feb 16 19:24:00 Lelopo-Maxi kernel: devres_release_all+0x95/0xbb
Feb 16 19:24:00 Lelopo-Maxi kernel: device_release_driver_internal+0x102/0x199
Feb 16 19:24:00 Lelopo-Maxi kernel: unbind_store+0x56/0x74
Feb 16 19:24:00 Lelopo-Maxi kernel: kernfs_fop_write_iter+0x123/0x152
Feb 16 19:24:00 Lelopo-Maxi kernel: new_sync_write+0x7c/0xb7
Feb 16 19:24:00 Lelopo-Maxi kernel: vfs_write+0xd9/0x124
Feb 16 19:24:00 Lelopo-Maxi kernel: ksys_write+0x76/0xbe
Feb 16 19:24:00 Lelopo-Maxi kernel: do_syscall_64+0x80/0xa5
Feb 16 19:24:00 Lelopo-Maxi kernel: entry_SYSCALL_64_after_hwframe+0x44/0xae
Feb 16 19:24:00 Lelopo-Maxi kernel: RIP: 0033:0x1519593294af
Feb 16 19:24:00 Lelopo-Maxi kernel: Code: 89 54 24 18 48 89 74 24 10 89 7c 24 08 e8 89 b8 f8 ff 48 8b 54 24 18 48 8b 74 24 10 41 89 c0 8b 7c 24 08 b8 01 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 31 44 89 c7 48 89 44 24 08 e8 dc b8 f8 ff 48
Feb 16 19:24:00 Lelopo-Maxi kernel: RSP: 002b:0000151957d97400 EFLAGS: 00000293 ORIG_RAX: 0000000000000001
Feb 16 19:24:00 Lelopo-Maxi kernel: RAX: ffffffffffffffda RBX: 000000000000000c RCX: 00001519593294af
Feb 16 19:24:00 Lelopo-Maxi kernel: RDX: 000000000000000c RSI: 000015195004a4f0 RDI: 0000000000000024
Feb 16 19:24:00 Lelopo-Maxi kernel: RBP: 000015195004a4f0 R08: 0000000000000000 R09: 0000151950049230
Feb 16 19:24:00 Lelopo-Maxi kernel: R10: 0000000000000000 R11: 0000000000000293 R12: 0000000000000024
Feb 16 19:24:00 Lelopo-Maxi kernel: R13: 0000000000000024 R14: 0000000000000000 R15: 000015195007c230
Feb 16 19:24:00 Lelopo-Maxi kernel: Modules linked in: veth nvidia_modeset(PO) nvidia_uvm(PO) xt_CHECKSUM ipt_REJECT nf_reject_ipv4 ip6table_mangle ip6table_nat iptable_mangle vhost_net tun vhost vhost_iotlb tap xt_nat xt_tcpudp macvlan xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xt_addrtype iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 br_netfilter md_mod nvidia(PO) nct6775 hwmon_vid vendor_reset(O) efivarfs ip6table_filter ip6_tables iptable_filter ip_tables x_tables bonding mxm_wmi intel_wmi_thunderbolt amdgpu x86_pkg_temp_thermal intel_powerclamp coretemp gpu_sched kvm_intel i2c_algo_bit drm_ttm_helper ttm kvm crct10dif_pclmul crc32_pclmul drm_kms_helper crc32c_intel ghash_clmulni_intel aesni_intel btusb crypto_simd cryptd btrtl btbcm btintel rapl drm bluetooth intel_cstate nvme backlight i2c_i801 intel_uncore agpgart i2c_smbus syscopyarea sysfillrect ecdh_generic sysimgblt ecc e1000e fb_sys_fops i2c_core nvme_core ahci libahci wmi button
Feb 16 19:24:00 Lelopo-Maxi kernel: CR2: ffffc90030c89000
Feb 16 19:24:00 Lelopo-Maxi kernel: ---[ end trace 488568fef88066ab ]---
Feb 16 19:24:00 Lelopo-Maxi kernel: RIP: 0010:vcn_v2_0_sw_fini+0x10/0x32 [amdgpu]
Feb 16 19:24:00 Lelopo-Maxi kernel: Code: 60 48 85 c0 74 0d 41 b8 10 00 00 00 31 c9 ff e0 0f 1f 00 31 c9 e9 86 b0 f2 ff 0f 1f 44 00 00 55 48 8b 87 00 17 01 00 48 89 fd <c7> 00 00 00 00 00 e8 1b 97 f5 ff 48 89 ef e8 a8 6d ff ff 85 c0 75
Feb 16 19:24:00 Lelopo-Maxi kernel: RSP: 0018:ffffc90000df3cd0 EFLAGS: 00010206
Feb 16 19:24:00 Lelopo-Maxi kernel: RAX: ffffc90030c89000 RBX: ffff888106300000 RCX: 0000000000000000
Feb 16 19:24:00 Lelopo-Maxi kernel: RDX: 000000000000000f RSI: 0000000000210d00 RDI: ffff888106300000
Feb 16 19:24:00 Lelopo-Maxi kernel: RBP: ffff888106300000 R08: 0000000000000001 R09: ffffffffa063ee69
Feb 16 19:24:00 Lelopo-Maxi kernel: R10: ffff888105886800 R11: 0000000000000000 R12: 0000000000000008
Feb 16 19:24:00 Lelopo-Maxi kernel: R13: ffff8881063163b8 R14: ffff888102397368 R15: ffff888102397364
Feb 16 19:24:00 Lelopo-Maxi kernel: FS: 0000151957d98640(0000) GS:ffff88887fc80000(0000) knlGS:0000000000000000
Feb 16 19:24:00 Lelopo-Maxi kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 16 19:24:00 Lelopo-Maxi kernel: CR2: ffffc90030c89000 CR3: 00000001981c4002 CR4: 00000000001726e0
Feb 16 19:25:03 Lelopo-Maxi nginx: 2022/02/16 19:25:03 [error] 8542#8542: *826 open() "/usr/local/emhttp/announce" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "GET /announce?info_hash=eZ%a9R%18%3a%91%1f%18%caI%d6%f6Y4%b2%ef%c0%f7X&peer_id=-TR3000-rc6qtmp1wdf8&port=51413&uploaded=0&downloaded=0&left=0&numwant=80&key=451cbce3&compact=1&supportcrypto=1&event=started HTTP/1.1", host: "pow7.com"
Feb 16 19:25:23 Lelopo-Maxi nginx: 2022/02/16 19:25:23 [error] 8542#8542: *938 open() "/usr/local/emhttp/announce" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "GET /announce?info_hash=eZ%a9R%18%3a%91%1f%18%caI%d6%f6Y4%b2%ef%c0%f7X&peer_id=-TR3000-rc6qtmp1wdf8&port=51413&uploaded=0&downloaded=0&left=0&numwant=80&key=451cbce3&compact=1&supportcrypto=1&event=started HTTP/1.1", host: "pow7.com"

I put the primery and i got this

https://pastebin.com/w2wZz1te i got this

Link to comment
On 2/17/2022 at 8:03 AM, ich777 said:

Are you booting unRAID with UEFI or with Legacy?

What machine type are you using for the VM?

 

Please make sure that you've enabled Above 4G Decoding and Resizable BAR Support if you have that option in your BIOS.

Booting in UEFI

q35

I enambled 4G Decoding and it not solved the problem so i order rtx 3050 and i sold the rx 5500 :)

Link to comment
1 hour ago, momsz said:

Booting in UEFI

q35

You should get the best results when booting in Legacy mode and using Q35 as machine type.

 

1 hour ago, momsz said:

so i order rtx 3050 and i sold the rx 5500 :)

Thats also how you can solve this... :D

  • Like 1
Link to comment

appreciating ur job first 
but i still got some trouble
after i installed the plugin, my igpu still not working
typing 'intel_gpu_top' in the terminal , there is ‘No device filter specified and no discrete/integrated i915 devices found’
BTW my cpu is intel pentium g7400

Link to comment
7 minutes ago, peterfxiang said:

BTW my cpu is intel pentium g7400

Can you please post your Diagnostics?

 

If I'm not mistaken this is a Alder Lake CPU.

Are you on the lates RC from unRAID?

Please keep in mind that this CPU or at least the iGPU or better speaking Alder Lake is not fully supported in unRAID/Linux and also can cause crashes from the Server itself.

Link to comment
9 hours ago, ich777 said:

Can you please post your Diagnostics?

 

If I'm not mistaken this is a Alder Lake CPU.

Are you on the lates RC from unRAID?

Please keep in mind that this CPU or at least the iGPU or better speaking Alder Lake is not fully supported in unRAID/Linux and also can cause crashes from the Server itself.

thx for answering me
this is Alder Lake CPU. no wonder the code 'modprobe i915' didn't work. 
so all i can do is waiting till the Alder Lake fully supported, right?

微信截图_20220220104005.png

Link to comment

@ich777 Is the unraid-kernel-helper container usable to try and create a custom kernel based on 5.17 (for better Alder Lake support)? I would also like to add the latest drivers for the Aquantia 5Gbe and 10Gbe NICs (vers. 2.4.15 released 2022-02-22, i.e. yesterday or today depending on your time zone). I've tried the latest drivers (3.1.6.0) on Win10 x64 and they did improve my connection with far fewer packet retransmits so I'm hoping the Linux driver does the same.

Edited by AgentXXL
spellling
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.