[Support] ich777 - AMD Vendor Reset, CoralTPU, hpsahba,...


Recommended Posts

I deleted my original post while ich777 was replying. Sorry for the confusion. I found the vendor-reset discord channel and moved my question there. It seemed more appropriate.

ich777 - Thank you for your quick reply, and thank you for all of your contributions to the community.

I have connected LAN and VGA to the BMC. I have tried different cables. I typically use IPMI over the dedicated LAN port. I don't have a serial cable but ordered a new one this weekend. The motherboard has an LED that flashes to indicate that the BMC/IPMI is working. That light dies with the BMC.

I did open a ticket with Supermicro. We tried some troubleshooting but did not resolve the issue. I have returned all three failed motherboards to Newegg. A person on reddit suggest that I RMA directly with Supermicro so that they can determine if there's a firmware issue or something like that.

  • Like 1
Link to comment
1 minute ago, ajnichol2001 said:

where do i find the kernal helper, i have a dl 360g8 that wont pass a network card thu and i cam across this 

I deprecated the Kernel Helper because it makes no sense to me to support it any longer because you can basically build everything into Unraid itself and if you run a custom version from Unraid the USB Flash Drive backup function will not properly work from what I know.

Link to comment
1 minute ago, ajnichol2001 said:

do you know how i can apply the patch now im not sure how do go about it?

You don't have to apply the patch anymore because it's integrated into Unraid itself, simply upgrade to 6.10.0-rc5 and modify the syslinux.conf with this:

append initrd=/bzroot intel_iommu=relax_rmrr

like described in your post from above.

Link to comment
Posted (edited)
On 11/2/2021 at 9:00 AM, ich777 said:

Should I create a plugin for this where the package is compiled every time a new unRAID version is released, like it is for my Nvidia Driver, DVB Driver, NCT Driver Plugin,...

I also compile packages for other community developers like ZFS for @steini84 and USBIP & iSCSI for @SimonF.

 

The process is automated and executed every time a new unRAID version is released.

Just hook me up with a short PM.

hey @HarryMuscle just tried to load this driver into my unRAID QNAP TS-873A by doing the following:

  • Place qnap-ec-1.0.0-x86_64-1.txz into /boot/extra/
installpkg qnap-ec-1.0.0-x86_64-1.txz
depmod --quick
modprobe qnap-ec

 

Getting the following after manually moving qnap-ec.ko.xz from the hard-coded directory

/lib/modules/5.10.28-Unraid/extra/

to the only other directory under /lib/modules:

/lib/modules/5.15.37-Unraid/extra/

Output from 'modprobe qnap-ec' command:

modprobe: ERROR: could not insert 'qnap_ec': Exec format error

 

Casual searches about this kind of error say that the binary must be compiled against the current kernel in order to get past that error. I'm sorry to bother you @ich777, is there any chance to compile this for latest RC7 version of unRAID?

 

Additional information shown during pkgremove which is where I got the idea to move that binary.

  --> Deleting /lib/modules/5.10.28-Unraid/extra/qnap-ec.ko.xz
  --> Deleting /usr/lib/libuLinux_hal.so
  --> Deleting /usr/sbin/qnap-ec
  --> Deleting empty directory /lib/modules/5.10.28-Unraid/extra/
  --> Deleting empty directory /lib/modules/5.10.28-Unraid/

 

Edited by Trunkton
Link to comment
3 hours ago, Trunkton said:

hey @HarryMuscle just tried to load this driver into my unRAID QNAP TS-873A by doing the following:

  • Place qnap-ec-1.0.0-x86_64-1.txz into /boot/extra/

From what I remember this is only for Unraid 6.9.2.

 

3 hours ago, Trunkton said:

I'm sorry to bother you @ich777, is there any chance to compile this for latest RC7 version of unRAID?

It would be no issue to compile but I actually heard never back from @HarryMuscle if a plugin should be created or not, I think something is wrong with the fan and this driver IIRC.


 

3 hours ago, Trunkton said:

Additional information shown during pkgremove which is where I got the idea to move that binary.

Don‘t do this, this won‘t work.

 

 

EDIT: I have sent you a message with instructions and how to install the package.

Link to comment

I'm struggling to get this to work... I was running a windows 10 vm using the original kernel-helper on 6.9.2 for about 8 months with zero issues. All of a sudden, the amd reset bug started happening again. I upgraded unraid to 6.10-rc7 and installed the newer amd vendor reset plugin but i don't know where to go from there. Whenever I boot my vm, windows is blurry and goes into a repair menu (which doesn't help) and won't start, and in the vm log i get "vfio: cannot reset device 0000:3.00.1, no available reset mechanism" (that device is my amd sound card). Any pointers here?

Link to comment
18 minutes ago, Lountz said:

All of a sudden, the amd reset bug started happening again. I upgraded unraid to 6.10-rc7 and installed the newer amd vendor reset plugin

What do you mean with the "newer" Vendor Reset plugin?

The plugin should work fine with rc7 too.

 

18 minutes ago, Lountz said:

Any pointers here?

Can you post your Diagnostics please?

 

 

Just a little side information, it is most likely that Vendor Reset is not actively developed anymore and will be not work on Kernel versions higher than 5.16

Link to comment
On 5/9/2022 at 5:13 PM, ich777 said:

What do you mean with the "newer" Vendor Reset plugin?

The plugin should work fine with rc7 too.

 

Can you post your Diagnostics please?

 

 

Just a little side information, it is most likely that Vendor Reset is not actively developed anymore and will be not work on Kernel versions higher than 5.16

i have the amd reset bug back too on rc8 i post my diagnostic 

nas-diagnostics-20220516-1209.zip

Link to comment
2 minutes ago, ptichalouf said:

i have the amd reset bug back too on rc8 i post my diagnostic 

From what I see in the log it performs the reset just fine.

 

Can you try to uninstall the plugin, reboot and see if this makes any difference?

Link to comment

Hello, 

I've tried searching on this form and watching videos trying to get the iGPU to work on my server. No matter what I do I can't get it to find the /dev/dri directory. 

 

I've tried uninstalling the plugin and reinstalling. 

Rebooted the machine several times.

Updated Unraid to the latest version. 

 

The CPU I'm using is an intel i5 12600k which should support quick sync for plex.

 

Also noteworthy, I'm a unraid n00b go easy on me lol

Link to comment
2 hours ago, Bibs said:

The CPU I'm using is an intel i5 12600k which should support quick sync for plex.

Please note that AlderLake isn't fully supported in this Kernel and can cause crashes and various other unexpected behavior. If you are on anything greater than 6.9.2 than you have to blacklist your iGPU first to get it to work with my plugin.

 

See this thread for more information:

 

You can't safely use your iGPU until Unraid is released with Kernel version 5.16-RC2 or greater.

Link to comment

Hello, i'm trying to make my iGPU work in order to able to transcode and i've followed the instructions to install 

Intel-GPU-TOP in order to be able to mount the /dev/dri into a container but it doesn't seem to be working
cpu: i5-12500
m/b: Asrock H670M Pro RS
I installed intel-gpu-top and it seems to be installing correctly but the ls -al /dev/dri returns No such file or directory, I read that plex don't support 12th gen cpus yet and it leads to crashes but with the plugin i should be able find it in unraid right!?

skynet-diagnostics-20220518-1952.zip

Link to comment
2 minutes ago, Lynxorz said:

Hello, i'm trying to make my iGPU work in order to able to transcode and i've followed the instructions to install 

Please see my comment above yours, it's basically the same.

If you are on anything greater than 6.9.2 than you have to blacklist your iGPU first but this comes with downsides -> post above yours.

Link to comment

aha..I see, yes I'm on 6.10  so for plex transcoding i'll wait to be stable with my iGPU to do trancode, but does that also mean that i shouldn't use it for VM aswell?
I'm planning to add a VM for homeassistant and pihole would it cause problems to blacklist the iGPU?
I'm assuming the VM need the same /dev/dri as plex containers does or is that not the case?

and lastly if i keep the plugin installed (intel-top-gpu) will it work once it's supported and updated or should i remove it?!

Thanx for answering and sorry for being ignorant..just starting getting into unraid :)

Link to comment
2 hours ago, ich777 said:

Please note that AlderLake isn't fully supported in this Kernel and can cause crashes and various other unexpected behavior. If you are on anything greater than 6.9.2 than you have to blacklist your iGPU first to get it to work with my plugin.

 

See this thread for more information:

 

You can't safely use your iGPU until Unraid is released with Kernel version 5.16-RC2 or greater.

Thanks for the quick reply! I guess I'll just have to wait a bit. Any idea when they might be releasing the new Kernel version?

Link to comment
2 hours ago, Lynxorz said:

but does that also mean that i shouldn't use it for VM aswell?

No.

 

2 hours ago, Lynxorz said:

I'm planning to add a VM for homeassistant and pihole would it cause problems to blacklist the iGPU?

No, I don't think so.

 

2 hours ago, Lynxorz said:

and lastly if i keep the plugin installed (intel-top-gpu) will it work once it's supported and updated or should i remove it?!

If you want to pass through the iGPU to a VM you have to uninstall it.

 

2 hours ago, Lynxorz said:

I'm assuming the VM need the same /dev/dri as plex containers does or is that not the case?

No, I'm not too familiar with passing through an iGPU to a container but I would recommend to ask this question on the VM Support sub forums.

Link to comment
1 hour ago, Bibs said:

Thanks for the quick reply! I guess I'll just have to wait a bit. Any idea when they might be releasing the new Kernel version?

The new Kernel version is not even out yet (still in the RC pahase) and Unraid only has most of the times the latest stable version built in...

You can check here which one is actually Stable, LTS or Testing: Click

Link to comment

Hi My install of coral driver previously was working, but now is no longer.  it seems /dev/apex_0 doesn't create. I create and see output but after reboot it is no more.  I install and uninstall with reboots many times. 

Link to comment
2 hours ago, Botch3963 said:

Hi My install of coral driver previously was working, but now is no longer.  it seems /dev/apex_0 doesn't create. I create and see output but after reboot it is no more.  I install and uninstall with reboots many times. 

Please post your Diagnostics with the plugin installed.

Link to comment
6 hours ago, Botch3963 said:

Thank you for help

Have you changed anything to your hardware configuration too (added hardware or made a BIOS update or something like that)?

May 23 14:02:50 Tower kernel: apex 0000:04:00.0: Cannot get BAR2 base address
May 23 14:02:50 Tower kernel: apex 0000:04:00.0: error adding gasket device
May 23 14:02:50 Tower kernel: apex: probe of 0000:04:00.0 failed with error -12

 

Link to comment
6 hours ago, ich777 said:

Have you changed anything to your hardware configuration too (added hardware or made a BIOS update or something like that)?

May 23 14:02:50 Tower kernel: apex 0000:04:00.0: Cannot get BAR2 base address
May 23 14:02:50 Tower kernel: apex 0000:04:00.0: error adding gasket device
May 23 14:02:50 Tower kernel: apex: probe of 0000:04:00.0 failed with error -12

 

Come to think. It did start around time computer overheated and crashed. Think video card got pulled while computer was still on. Any ideas to fix? Video card has been put back

Link to comment
8 hours ago, Botch3963 said:

Come to think. It did start around time computer overheated and crashed. Think video card got pulled while computer was still on. Any ideas to fix? Video card has been put back

Not really, try to reseat the card in the slot has the card enough cooling?

 

Try to enable Above 4G Decoding.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.