[Support] ich777 - Nvidia/DVB/ZFS/iSCSI/MFT Kernel Helper/Builder Docker


906 posts in this topic Last Reply

Recommended Posts

  • Replies 905
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Unraid Kernel Helper/Builder With this container you can build your own customized Unraid Kernel.   Prebuilt images for direct download are on the bottom of this post.   By

CHANGELOG: 08.04.2021: Changed template to be compatible with unRAID v6.9.2 19.03.2021: Added possibility to load AMD Drivers/Kernel Module amdgpu on startup and install 'r

Im still confused by him. He does not want to update to 8.6.3 from 8.6.2 due to personal reasons. Yet he keeps saying the only thing it fixed was a venerability. So I guess that he needs this venerabi

Posted Images

55 minutes ago, rango3221 said:

i am currently running beta30. if you can that would be awesome. Thank you.

I think I'm home in about 30 minutes, please send me a short PM and I will send you a link when it's ready to download.

Link to post

So im running Ryzen 5900x on Asus Strix X570 board. Motherboard USB and AUDIO passthrough only work on Unraid 6.9.0 Beta30 otherwise unraid completly crashes. I also have TV tuners so im currently using the precompiled kernal 6.9.0 Beta30 with DVB drivers (thanks for this!). Everything works fine other then system temperatures. I believe this is due to missing drivers? Driver shows up as "k10temp nct6775" but i get no options for temperature sensors. A little bit out of my depth but is there a kernal that has the correct drivers precompiled or can anyone shed some light on this? Thanks!

Link to post
18 minutes ago, Calpulz said:

Driver shows up as "k10temp nct6775" but i get no options for temperature sensors. A little bit out of my depth but is there a kernal that has the correct drivers precompiled or can anyone shed some light on this? Thanks!

This is what I've found from a quick search:

 

 

It's a little old but eventually this is a start.

Can't help with temperature sensors since I don't own any ryzen based system (at least for Unraid).

Link to post
34 minutes ago, ich777 said:

This is what I've found from a quick search:

 

 

It's a little old but eventually this is a start.

Can't help with temperature sensors since I don't own any ryzen based system (at least for Unraid).

Thanks for reply, yeah ive done alot of digging and x570 apparently didn't work on kernal 4.x but 5.x added the support for these drivers. But im already running 6.9.0 beta 30 with kernal 5.8.13 so i think its something to do with asus boards as i have seen asrock working fine. They get detected in sensors-detect but sensors says no sensors found. Thanks though ill have to keep digging

Link to post
7 minutes ago, rachid596 said:

Hello, i have an asus rog crosshair viii hero wifi x570 with 3900x and i have the température of cpu and motherboard

 

Envoyé de mon HD1913 en utilisant Tapatalk

 

 

 

1837023e935806aa0e9c45a1ad0e0abf.jpg

I have no idea whats wrong then.. doing modprobe on k10temp and nct6775 shows no results. 

Link to post
4 minutes ago, rachid596 said:

Yes very strange, maybe wait for the next update of the kernel.

I can sent you my kernel compile for beta30+ nvidia driver for test?

Think im already running that. Using a custom kernal from ich777 6.9.0 Beta30 with Nvidia and DVB drivers (for my TV tuners) Thanks tho. Yeah guess ill wait for ryzen 5000 to become more of a thing in the unraid space

Link to post
8 minutes ago, Calpulz said:

I have no idea whats wrong then.. doing modprobe on k10temp and nct6775 shows no results. 

Can you try to delete the plugin entirely, restart unraid and the install the plugin again and click only once on detect and apply.

I got a similar problem with my ASUS Z9PA-D8.

 

If I click again on antoher sensor or on detect the temperature plugin simply doesn't work anymore...

Link to post
9 minutes ago, ich777 said:

Can you try to delete the plugin entirely, restart unraid and the install the plugin again and click only once on detect and apply.

I got a similar problem with my ASUS Z9PA-D8.

 

If I click again on antoher sensor or on detect the temperature plugin simply doesn't work anymore...

Just gave it ago to no avail :( Still no sensors. Thanks though. I dont think its the plugin as such since modprobe from the consol shows no sensors either. 

Link to post

Hi ich777, first and foremost, thank you for the work you've done, as you've solidified my move from FreeNAS over to Unraid with iSCSI support.

 

Second, I'm working on setting up a FileIO iSCSI share, and have a quick question... Since this is setup as an IMG file for the share "drive", I'm assuming that it can't be split across drives?  If that's the case, should I select a single disk to setup the FileIO share on instead of selecting a share that spans disks, or is the share okay (as that's how it's shown in your text file [the /mnt/user/ directory leads to shares])?  Ideally it could span multiple drives and the file would somehow be split, so that I can make a share larger than a single drive, but I understand that an image file is exactly that and likely won't work that way.

 

Thanks!

Link to post
23 minutes ago, JaredC01 said:

I'm assuming that it can't be split across drives?

Exactly.

 

23 minutes ago, JaredC01 said:

If that's the case, should I select a single disk to setup the FileIO share on instead of selecting a share that spans disks, or is the share okay

The share would be also okay but I would recommend to select a single disk.

23 minutes ago, JaredC01 said:

Ideally it could span multiple drives and the file would somehow be split

No, that's not possible since Unraid is not a real RAID. What you can do is if you are on the latest beta create a second cache pool and then add more disks if you need more space, since you can expand btrfs when you add more disks but keep in mind that this all is done in software...

I would make a single share and assign it to one disk and then store the .img there.

But that's completely up to you and your needs.

 

EDIT: New version of the iSCSI Plugin is on the way @Joedy and @SimonF working real hard on this (I'm not really the webcoding guy...)

Link to post
Just now, ich777 said:

Exactly.

 

The share would be also okay but I would recommend to select a single disk.

No, that's not possible since Unraid is not a real RAID. What you can do is if you are on the latest beta create a second cache pool and then add more disks if you need more space, since you can expand btrfs when you add more disks but keep in mind that this all is done in software...

I would make a single share and assign it to one disk and then store the .img there.

But that's completely up to you and your needs.

As I was expecting, thank you very much for the quick reply!

Link to post
5 minutes ago, JaredC01 said:

As I was expecting, thank you very much for the quick reply!

No problem. ;)

 

Hope you like Unraid so far, for me it's the best NAS/Server OS in many years...

(Also note the EDIT on the previous post)

Link to post
3 minutes ago, ich777 said:

No problem. ;)

 

Hope you are liking Unraid so far, for me it's the best NAS/Server OS in many years...

(Also note the EDIT on the previous post)

Love it so far!  Best Docker integration I've seen to date as well, and it's helping me move many of my host VMs over from ESXi to Docker (cleaning up the whole home network).  Only downside so far is the loss of overall read/write speeds, as I'm on a 10Gbps network, though once I add cache drives in, I suspect that limitation will be null as well!

 

Noted on the previous edit, looking forward to their updates. :)

Link to post
7 minutes ago, JaredC01 said:

Only downside so far is the loss of overall read/write speeds, as I'm on a 10Gbps network, though once I add cache drives in, I suspect that limitation will be null as well!

Exactly, I'm also on 10Gbps but have old SATA SSD's for my cache but speeds are as expected 400 to 450MB/s (as advertised for my disks).

EDIT: But my DVB Cards are also working hard to reach allmost fully utilization from the NIC :D

 

7 minutes ago, JaredC01 said:

VMs

I only got one VM left (to build my docker containers) from my 5 VM's from pre Unraid times.

 

Really happy with it, I also learned to love the hot/cold storage idea of Unraid and since the new versions (or better speaking the beta versions) support multiple Cache pools you are a bit more flexible for write intense Files. ;)

Link to post
10 hours ago, Dazog said:

@ich777 are you planning a Mellanox Third Party Module for newer Unraid builds?

 

Since it appears that's the new way going forward, with the module loading?

Yes already wrote plugins, just woke up and I will upload them in a few minutes to the CA App but I have to test it in the first place if everything works correctly with the new build.

  • Like 1
  • Thanks 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.