[Support] ich777 - Nvidia/DVB/ZFS/iSCSI/MFT Kernel Helper/Builder Docker


916 posts in this topic Last Reply

Recommended Posts

11 minutes ago, almulder said:

I upgraded to beta35 and then setup the new video card. I will be binding the videocard to my vm here shortly. I will let you know if there are other issues.

 

Please note to bind a device to VFIO go to Tools -> System devices -> tick the boxes that you want to bind -> click Bind to VFIO on boot

 

EDIT: There is a plugin available for Nvidia,... now if you haven't seen that already, but you have to be at least on Unraid 6.9.0 beta35 to see it in the CA App.

Link to post
  • Replies 915
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Unraid Kernel Helper/Builder With this container you can build your own customized Unraid Kernel.   Prebuilt images for direct download are on the bottom of this post.   By

CHANGELOG: 08.04.2021: Changed template to be compatible with unRAID v6.9.2 19.03.2021: Added possibility to load AMD Drivers/Kernel Module amdgpu on startup and install 'r

Im still confused by him. He does not want to update to 8.6.3 from 8.6.2 due to personal reasons. Yet he keeps saying the only thing it fixed was a venerability. So I guess that he needs this venerabi

Posted Images

On 12/8/2020 at 2:35 PM, alturismo said:

@curtp and may to keep it cleaner and ppl can follow, you installed the plugin, now, did you also install a driver ? like libreelec, tbs, ... ?

 

the plugin is just the base, then u install the driver, then if you see the the tuner its a matter if plex supports it or not, if plex supports it u can add it nativ there

 

add a device like /dev/dvb to the plex docker u use

 

if its not supported by plex but can be used in tvheadend, (also /dev/dvb ...) then u need a "bridge" like xteve which will be useable in plex as hdhr device ...

tvheadend native in plex is not supported (yet).

 

step 1, install a driver (i think TBS supports your xbox tuner)

step 2, check plex if tuner is detected (after adding device to docker), as you can read at plex it should be supported ...

 

rest you will figure yourself how to scan channels and use plex epg

 

ps. double posting in forums is not a nice attitude

Update

So actually I was using the Linux version of plex and it was not working, I moved over to the official Plex one and it works. Thanks for the help 

Edited by curtp
Link to post
6 hours ago, Getn67 said:

I'm struggling with understanding how to use a modified build script with this. I'm trying to use @juchong FusionIo driver build script located here: https://github.com/juchong/unraid-fusionio-build. I'm more than likely missing something simple, but a walkthrough would be super helpful for me and others with these cards.

Nice didn't know that 3rd party scripts for my contianer exist. ;)

Just drop it in the Unraid-Kernel-Helper directory, make it executable and run it, also add the variables that are in the github repo.

 

What does not work or where are you stuck?

For which version of Unraid do do you want to build a custom image?

Link to post

I'm currently running 6.9 rc1 with your nvidia plugin as well.

2 minutes ago, ich777 said:

What does not work or where are you stuck?

The part where I drop the file into the directory, make it executable, and run it. :P 

 

When you say run it, do you mean to start the docker, or do you mean some other way?

 

I'm pretty certain that a novice like myself can follow these directions, but if I somehow trip over my own feet, I will reach back out. 

Link to post
5 minutes ago, Getn67 said:

The part where I drop the file into the directory, make it executable, and run it. :P 

Have you set all variables and the beta build variable right?

If not this would fail. Please read the first post again there is a almost full tutorial on how to do that with the builtin script.

 

7 minutes ago, Getn67 said:

When you say run it, do you mean to start the docker, or do you mean some other way?

Open up a unraid terminal, connect to the console of the container with: 'docker exec -ti Unraid-Kernel-Helper /bin/bash' and the type in: 'cd $DATA_DIR' then 'chmod +x NAMEOFTHESCRIPT' and then: './NAMEOFTHESCRIPT'

 

9 minutes ago, Getn67 said:

I'm pretty certain that a novice like myself can follow these directions, but if I somehow trip over my own feet, I will reach back out. 

You should have at least basic bash knowledge for this to do, eventually @juchong can help also. ;)

Link to post
30 minutes ago, tjb_altf4 said:

@ich777 I've just moved to 6.9.0-rc1 and it looks like iSCSI support has been added to the unraid kernel.

Is your iSCSI Target plugin still compatible with rc1, or should I wait for the new iSCSI GUI plugin to be complete?

Hi 

 

You still need to load the plugin to install Target CLI etc and enable the kernel modules.

 

 

  • Like 1
  • Thanks 1
Link to post
46 minutes ago, tjb_altf4 said:

@ich777 I've just moved to 6.9.0-rc1 and it looks like iSCSI support has been added to the unraid kernel.

Is your iSCSI Target plugin still compatible with rc1, or should I wait for the new iSCSI GUI plugin to be complete?

Yes, that's only the Kernel modules, the plugin is needed to install the application itself so that you can use iSCSI itself.

I will update the plugins next week if everything went smoothly. :)

 

But could take also a little bit longer since my dev server is defect and I wait for parts to replace them...

Link to post

So I can get channels found on Plex but I am not able to load up the HD ones, I can't see why not as the signal is okay and also I did change the default plex setting for the channel to HD.  I also tried tvheadend but that can't find any channels at all. 

Link to post
1 hour ago, curtp said:

So I can get channels found on Plex but I am not able to load up the HD ones, I can't see why not as the signal is okay and also I did change the default plex setting for the channel to HD.  I also tried tvheadend but that can't find any channels at all. 

I'm not too familar with Plex but I've heard when you got no EPG data for the channels you are not able to see the channels in Plex even if they are there, eventually you have to assign them EPG data?

Keep in mind if you tried also Tvheadend and you got it running in Plex too and Plex is using the tuner Tvheadend is not able to utilize the tuner anyways...

 

1 hour ago, daze said:

I was able to compile fine for 6.9.0-beta35 by pointing to the . But now I can't get it to compile for rc1. Any clues would be great!

What packages/modules do you need? If you are on RC1 all packages that you can build with the Unraid-Kernel-Helper that are builtin should be now availble in the CA App.

I have to look into this, can you give me a little bit more information what is failing and evenutally enable the log bevore building and post it here?

Link to post
1 hour ago, ich777 said:

What packages/modules do you need? If you are on RC1 all packages that you can build with the Unraid-Kernel-Helper that are builtin should be now availble in the CA App.

I have to look into this, can you give me a little bit more information what is failing and evenutally enable the log bevore building and post it here?

Just need the nVidia modules, and maybe ZFS for playing around.

 

I think the problem is simpler. The kernel did build, but it was -beta35 not -rc1. I'll try again. I assume I have to set beta as true again (regardless of rc1, which technically is not a beta, but a release candidate, but can qualify as a beta for our purposes). Maybe some wording change to say, "If beta or rc, set beta to true).

 

Thanks for the awesome and mainly solid work. Impressive stuff!

Link to post
6 minutes ago, daze said:

Just need the nVidia modules, and maybe ZFS for playing around.

You don't have to use this tool anymore.

 

Simoly download the stock RC1 - reboot - go to the CA App and search for Nvidia Driver install it and also for ZFS and install it, reboot youre done.

No more compiling needed and if a new version of Unraid is released the plugins will update the drivers automatically.

Link to post
On 12/13/2020 at 6:18 AM, ich777 said:

I'm not too familar with Plex but I've heard when you got no EPG data for the channels you are not able to see the channels in Plex even if they are there, eventually you have to assign them EPG data?

Keep in mind if you tried also Tvheadend and you got it running in Plex too and Plex is using the tuner Tvheadend is not able to utilize the tuner anyways...

 

What packages/modules do you need? If you are on RC1 all packages that you can build with the Unraid-Kernel-Helper that are builtin should be now availble in the CA App.

I have to look into this, can you give me a little bit more information what is failing and evenutally enable the log bevore building and post it here?

Thanks and it is weird as I also used Tvheadend to see the channels and also they did not come back in HD, I did try and manually change the channel on plex to the HD ones but also no luck. I will ask plex forums. Thanks for the help. 

Edited by curtp
Link to post
On 12/13/2020 at 12:05 AM, ich777 said:

You don't have to use this tool anymore.

 

Simoly download the stock RC1 - reboot - go to the CA App and search for Nvidia Driver install it and also for ZFS and install it, reboot youre done.

No more compiling needed and if a new version of Unraid is released the plugins will update the drivers automatically.

I do need it. ZFS is not installed by any other tool, and the nVidia plugin has issues (at least for me) with looooong load splash times, or completely getting stuck.

Nevermind, just found the new plugin, I'll try it and see how it goes. Not sure if I need ZFS that much, but would be nice to have. One can wish.

Edited by daze
Link to post
53 minutes ago, daze said:

looooong load splash times

What do you mean with this? Load splash times?

The driver is downloaded and installed on boot if you upgrade to a newer unraid version.

 

54 minutes ago, daze said:

ZFS is not installed by any other tool

There is a ZFS plugin available in the CA App that installs ZFS.

Link to post
1 hour ago, ich777 said:

What do you mean with this? Load splash times?

The driver is downloaded and installed on boot if you upgrade to a newer unraid version.

 

There is a ZFS plugin available in the CA App that installs ZFS.

Thanks for the info. I nVidia plugin (new one) works great. Though I need a 1660 to use it for my needs. But it does work, I had to restart Docker before it would accept --runtime=nvidia.

Link to post
47 minutes ago, daze said:

I had to restart Docker before it would accept --runtime=nvidia.

Yes that's also what the message says that appears after the first installation of the plugin.

 

You can also restart the server instead of restarting the docker service.

Link to post

hey so i have a quick question I have unraid 6.8.2 and im using the unraid plugin on this post to get HWA with nvence in jellyfin with the Unriad OS on 6.8.2, but i want to keep my OS Unriad on Version 6.8.2, but everytime i try to use this plugin which automatically builds the repo it will build 6.8.2, and want build 6.8.2 would anyone know how to possibly fix this so can get unraid to work on 6.8.2 build with nvidia GPU for HWA. 

Edited by DemonWarrior
spelling correction
Link to post
6 hours ago, DemonWarrior said:

6.8.2

Why did you want to stay om that version?

 

Prebuilt images with Nvidia in the first post you don't have to build it on your own...

 

Keep in mind that I designed this tool for use with 6.8.3+, never tested it with a version below.

 

Also you say you want to build for 6.8.2 and it builds 6.8.2 whats wrong with that oris it just a typo?

Link to post
10 hours ago, ich777 said:

Why did you want to stay om that version?

 

Prebuilt images with Nvidia in the first post you don't have to build it on your own...

 

Keep in mind that I designed this tool for use with 6.8.3+, never tested it with a version below.

 

Also you say you want to build for 6.8.2 and it builds 6.8.2 whats wrong with that oris it just a typo?

There are certain personal reasons why. But i would like to keep the build on 6.8.2 Unraid version. Everytime i build it with the docker it would automatically build 6.8.3. I wanted to stay on the version of unraid im on currently which is 6.8.2. Could you specify how to build this or how to get Unriad working on 6.8.2 with gpu transcoding for a nvidia geforc 960 GTX. 

Link to post
18 minutes ago, DemonWarrior said:

i would like to keep the build on 6.8.2 Unraid version

That's not a supported version, 6.8.3 is the oldest version actively supported. If there is something in 6.8.3 that doesn't work with your setup, try the latest 6.9 release candidate. It's not a good idea to stay with that old of a release anyway, there are vulnerabilities that are fixed in the newest versions, and you will need to eventually go to the 6.9 series anyway, so if there is some incompatibility with the current 6.9 release candidate with your setup it would be good to get that addressed with limetech before the 6.9 release.

 

24 minutes ago, DemonWarrior said:

Could you specify how to build this or how to get Unriad working on 6.8.2 with gpu transcoding for a nvidia geforc 960 GTX. 

That's not going to happen, for the reasons I just stated.

Link to post
48 minutes ago, DemonWarrior said:

There are certain personal reasons why. But i would like to keep the build on 6.8.2 Unraid version. Everytime i build it with the docker it would automatically build 6.8.3.

As I said, that's normal because it's designed to work only with 6.8.3 and up.

 

52 minutes ago, DemonWarrior said:

Could you specify how to build this or how to get Unriad working on 6.8.2 with gpu transcoding for a nvidia geforc 960 GTX. 

No because this container is also at EoL at least for version 6.8.3 I update it now for version 6.9.0 if someone is in need of a "complete" version with everything builtin.

Link to post
3 hours ago, ich777 said:

As I said, that's normal because it's designed to work only with 6.8.3 and up.

 

No because this container is also at EoL at least for version 6.8.3 I update it now for version 6.9.0 if someone is in need of a "complete" version with everything builtin.

is there an alternate way of getting my Nvidia Geforce 960 GTX working on unraid 6.8.2? 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.