[Support] ich777 - Nvidia/DVB/ZFS/iSCSI/MFT Kernel Helper/Builder Docker


Recommended Posts

After completely restarting from scratch I figured out what I was doing wrong.  Instead of selecting latest for the nvidia driver I had to put the version of the beta driver 450.51

 

Successfully built and my GPU is finally entering power state p8 instead of being stuck in p0 all the time :)

 

 

Link to comment
6 hours ago, rachid596 said:

Hello

Is it possible to build with kernel 5.8 rc2?

Thank you very much.

Yes, this is possible but you have to do it by hand or you also can automate this.

I would recommend you to switch on the CUSTOM_BUILD then the build script is copied over to the main directory of the container.

Link to comment
8 hours ago, ich777 said:

Yes, this is possible but you have to do it by hand or you also can automate this.

I would recommend you to switch on the CUSTOM_BUILD then the build script is copied over to the main directory of the container.

i rename the 5.8rc2 to linux-5.5.8.tar.gz and the script compile it  but when i enable nvidia support i have a bzmodule with size of 4kb.

If i compile without nvidia it's work great but i don't have bzmodules in output folder only bzroot and bzfirmware.

Thanks

Link to comment
41 minutes ago, rachid596 said:

i rename the 5.8rc2 to linux-5.5.8.tar.gz and the script compile it  but when i enable nvidia support i have a bzmodule with size of 4kb.

If i compile without nvidia it's work great but i don't have bzmodules in output folder only bzroot and bzfirmware.

Thanks

That simply can't work, you have to do it by hand and then you can automate it.

Have you also tried to run Unraid with your compiled Kernel without the nVidia drivers? If not try it, I bet that it won't boot or something similar - if it boots than you are very lucky...

Also why did you renamed it to 5.5.8? For which Unraid version are you compiling the kernel?

 

Also is something using your graphics card at building the Kernel?

 

You also need to include a log of the build process.

Link to comment

But 6.8.3 doesn't use the kernel 5.5.8...

It uses the kernel 4.19.108

 

I think it has found also the kernel 4.19.108 archive and extracted that.

 

Can you post the output of 'uname -r' with your compiled kernel witgout the nVidia drivers?

 

As i said without a log i can't help much.

Link to comment
1 hour ago, ich777 said:

But 6.8.3 doesn't use the kernel 5.5.8...

It uses the kernel 4.19.108

 

I think it has found also the kernel 4.19.108 archive and extracted that.

 

Can you post the output of 'uname -r' with your compiled kernel witgout the nVidia drivers?

 

As i said without a log i can't help much.

i have this wiyh uname -a

"Linux Tower 5.5.8-Unraid #1 SMP Sat Mar 7 14:24:42 CST 2020 x86_64 AMD Ryzen 9 3900X 12-Core Processor AuthenticAMD GNU/Linux"

I attach my log file

in outpout folder i have bzroot and bzimage

Thanks

unraid2.JPG

log.txt

Link to comment
9 minutes ago, rachid596 said:

The two logs say fail ? I see at the end '' all done''

Yes, but this means that the script is finished, I haven't built in that the script stops of something fails because that's not that easy especially if you do something like you have in mind.

In the first thread also is mentioned that you have to keep an eye on the logs...

Also it's not that easy like you did it, you simply can't rename a file and hope that everything went well especially if you are building a Kernel.

 

You have to dig into this and study the build script if you enable custom mode.

I recommend you to build the Kernel manually step by step and dig into it if an error occours.

Link to comment
10 minutes ago, rachid596 said:

OK Thank you very much. I will try to learn emoji16.png.
Have a good day

Envoyé de mon HD1913 en utilisant Tapatalk
 

I will take a look at it after the weekend but this is not an easy task and i don't know if it's worth the effort because it's a release candidate version and not an official version.

Much can change to the official release.

Link to comment
7 hours ago, cybrnook said:

Absolutely great Plugin and Docker, truly thank you.

 

Just wanted to report one small, superficial visual anomaly. I run a widescreen, high res monitor and I notice the separation bar on the plugin helper screen breaks in the middle. I use Chromium Edge:

 

image.thumb.png.8793f9e61eec5478fc751f31f9e83681.png

This is simply because you strated the plugin on a stock image of unraid and it haven't found any compatible Kernel Module.

If it finds compatible modules the layout should be correct.

  • Like 1
Link to comment
11 hours ago, ich777 said:

This is simply because you strated the plugin on a stock image of unraid and it haven't found any compatible Kernel Module.

If it finds compatible modules the layout should be correct.

As suspected 🙂

image.thumb.png.7824dc28e64cb2e1911bbdf2034fa973.png

 

Only thing that would throw me off a little, I am preloading the modified kernel before I am installing my Hauppauge card as well as my Nvidia GPU, that will come this afternoon. But the wording on the page makes me think that the driver isn't loading properly. I can only assume this message is appearing because I don't yet have the GPU installed. Perhaps it should say something like "Make sure that the latest NVIDIA driver is installed and running and your GPU is properly installed and detected"?

Edited by cybrnook
  • Thanks 1
Link to comment
35 minutes ago, cybrnook said:

As suspected 🙂

image.thumb.png.7824dc28e64cb2e1911bbdf2034fa973.png

 

Only thing that would throw me off a little, I am preloading the modified kernel before I am installing my Hauppauge card as well as my Nvidia GPU, that will come this afternoon. But the wording on the page makes me think that the driver isn't loading properly. I can only assume this message is appearing because I don't yet have the GPU installed. Perhaps it should say something like "Make sure that the latest NVIDIA driver is installed and running and your GPU is properly installed and detected"?

Nice.

 

I can't change the message because I read the message or better speaking the driver version and everything from the command 'nvidia-smi'.

The message actually is not 100% false but you are right that it is also not the best but I can't change it since I'm reading it from the above command. 

Hope that makes sense and everything works when all is installed.

 

Feel free to contact me if something isn't working as expected...

  • Thanks 1
Link to comment
On 6/27/2020 at 7:58 AM, ich777 said:

This is simply because you strated the plugin on a stock image of unraid and it haven't found any compatible Kernel Module.

If it finds compatible modules the layout should be correct.

Hello,

I'm now able to create a custom firmware with amd USB3 and audio patch for Unraid 6.8.3 and the beta.

Thank you very much for your great plugin.

Do you have a Paypal for donate?

  • Like 1
Link to comment
Just now, rachid596 said:

Hello,

I'm now able to create a custom firmware with amd USB3 and audio patch for Unraid 6.8.3 and the beta.

Thank you very much for your great plugin.

Do you have a Paypal for donate?

Great, can you share what you did only to give me a little bit of insight (since I'm not having any new AMD hardware)?

Yes, you find a button in my Plugin and also on in the CA APP at my Docker containers.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.