New drive is throwing a lot of errors, want it to be emulated until I can take it to the shop to be replaced.


Recommended Posts

Pretty much the title. Smart is showing huge amounts of read and write errors for a new drive that I used to replace a failed drive.

 

I tried pulling the drive assuming that it would be automatically emulated but it wasn't

 

Instead all the files on the drive became unavailable. I've had to put the drive back in for a sync / rebuild.

 

Once that's finished how can I tell unraid to emulate the drive while I get it replaced.

Link to comment

The files are back available since I put the drive back in and on the dashboard the drive is listed as emulated.

 

However, when the drive was pulled the drive was listed as not available, the amount of storage available dropped and the files on the missing drive were unavailable.

 

This is why I'm asking the question.... because the files on the drive became unavailable when the drive was out of the array.

array status.png

Link to comment

Even better..... I thought I'd wait out the rebuild but it decided to hard lock my machine.

 

Now I can't even get into the webgui when I hard reboot.

 

Anyone reading this.... And it'll be a few days from anyone from limetech bothers according to their Web form. Stay away. Your data isn't safe.

Link to comment
20 hours ago, dodgypast said:

Instead all the files on the drive became unavailable.

If the data on the emulated drive isn't available possibly there's a filesystem problem, and rebuilding won't help, if you still need help please post the diagnostics: Tools -> Diagnostics

Link to comment

 Hi there,

 

Saw your message into support and was obviously concerned. When a drive fails, Unraid can emulate the contents.  Questions:

 

When the first drive failed, did Unraid automatically mark it as such with a red X?  Then did you stop the array, remove the drive that failed, then replace it with this new disk? And after replacing it, did the rebuild operation ever complete our did it start throwing out errors immediately?

 

It also would be helpful to see diagnostics from your system so we can analyze it to see what went wrong. 

 

You should be able to start the array with no disk assigned to the slot that is having problems and be able to emulate the contents there. 

 

Is slot 6 the drive slot that we are talking about?  What happens if you stop the array and unassigned the disk and start the array again?

 

You may need to start the array in maintenance mode with no disk assigned to that slot and then run a file system repair on that disk. You can do this by clicking the disk slot on the main tab. 

Link to comment

 

Saw your message into support and was obviously concerned. When a drive fails, Unraid can emulate the contents.  Questions:

It failed to do this.

 

When the first drive failed, did Unraid automatically mark it as such with a red X?  Then did you stop the array, remove the drive that failed, then replace it with this new disk? And after replacing it, did the rebuild operation ever complete our did it start throwing out errors immediately?

It was failing according to smart data so I pulled it out and restarted believing that it would be emulated. It wasn't emulated and the parity corrupted losing all data on the drive.

 

It also would be helpful to see diagnostics from your system so we can analyze it to see what went wrong. 

It's been rebooted multiple times ( the server randomly grabbed a different IP after crashing during a failed attempt to stop the array )

 

You should be able to start the array with no disk assigned to the slot that is having problems and be able to emulate the contents there. 

NO, it started without emulating the missing drive and started chagning the parity to reflect having 5 drives immediately killing my data.

 

Is slot 6 the drive slot that we are talking about?  What happens if you stop the array and unassigned the disk and start the array again?

Yes.... That's exactly what I did, it decided I only had 5 drives and changed the parity drive accordingly loosing all my data.

 

You may need to start the array in maintenance mode with no disk assigned to that slot and then run a file system repair on that disk. You can do this by clicking the disk slot on the main tab. 

yeah tried that, I'm completely fucked.

 

 

I WANT MY MONEY BACK, YOUR PRODUCT IS A SCAM

Link to comment
1 hour ago, dodgypast said:

your shitty os has turned my life into a nightmare.

 

i think i'm going to kill myself

Wow!  If this is the worst thing that's ever happened to you, then the rest of your life must be fantastic.  I'm jealous of you.  

 

It seems to me, that you need to calm down and read for comprehension the things that have already been posted in reply to your topic.  You also might want to peruse the unraid online documentation, parts dealing with storage management.  https://wiki.unraid.net/UnRAID_6/Storage_Management

Link to comment

I was extremely stressed as I needed to be able to get my vm running for work.

 

Just to list the issues:

UnRAID didn't emulate a drive when it was removed.

When I tried to rebuild the array it started rebuilding the drive as empty.... Then hard locked in the middle of the rebuild process.

The hard lock somehow resulted in the ip address unraid was using to change. It also resulted in my acs settings being reset on the USB.

 

End result 4 hours of sleep before work and 7tb of data lost.

 

Yes I was overly dramatic but it's been extremely stressful and I'm upset that a product I paid for failed to do what I bought it to do.

 

It's also unsettling knowing that none of my data is actually protected and that I've been championing a product that can't be relied on.

Edited by dodgypast
Link to comment

Nobody else has had the problem of Unraid not emulating a failed/removed drive if all the other drives are OK and parity is valid.     This suggests a problem that is local to your system or you left out some steps in what actually happened.    
 

Getting a hard lock at any point suggests you have some underlying hardware error.  
 

I am also not sure what you mean by the acs settings on the USB drive got reset?   This sounds as if it might be hardware related?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.