[Support] FoxxMD - pgadmin4

Recommended Posts

Application Name: pgadmin4

Application Site: https://www.pgadmin.org/

Github Repo: https://github.com/postgres/pgadmin4

Docker Hub: https://hub.docker.com/r/dpage/pgadmin4/

Template Repo: https://github.com/FoxxMD/unraid-docker-templates




pgAdmin is the most popular and feature rich Open Source administration and development platform for PostgreSQL, the most advanced Open Source database in the world. Some features:


  • Designed for PostgreSQL 9.5 and above
  • Access and manage multiple databases
  • CRUD for all the things and raw SQL execution
  • Wizards and graphic tools for many administrative tasks (ACL, backup/restore, etc.)
  • Monitoring dashboard




How is this different than the existing CA template for pgAdmin4?





NOTE: On initial container build there may be a noticeable delay (10-20 seconds) between when the container starts and when the UI becomes available.


=== Migrating from fenglc or bringing your own data ===


Use the Config path (under "Show More Settings") in the template to map your working directory. If you are migrating from fenglc just use the same folder from appdata.


If you use this approach you can safely ignore or remove the Email/Password variables from the template.


=== New Installations ===


You must provide values for Default Email and Default Password in the template or the container will not start. The email is not actually used, it's just a username. After the container has been started for the first time these variables can be removed from the template.




All other configuration for the container can be found in the pgAdmin docs.

Link to comment
  • 2 weeks later...
  • 3 months later...
13 hours ago, Mattyfaz said:

Is there any current issue with this? A completely fresh install the Username and Password don't work, just always says they are invalid.

I just tried a fresh install and am seeing this issue now...it seems the login attempt is redirecting and then not passing the form data correctly. I'm looking to see if there is any troubleshooting info on this...


EDIT: @Mattyfaz can you try setting the Config path to a new (non-existing) location? I was able to login after using a clean path.

Edited by FoxxMD
Link to comment
  • 1 month later...
  • 11 months later...



After installing the docker container, there should be a folder in appdata on the unraid host named pgadmin4.  You must change the permissions on this folder:


Here's how:


On the unraid host, click the terminal button at the top right:



When you get a terminal window, set the permissions on the pgadmin4 folder as follows



  • Thanks 1
Link to comment
  • 6 months later...
On 11/21/2021 at 6:34 PM, bwarlick said:



When you get a terminal window, set the permissions on the pgadmin4 folder as follows



Thank you very much for that info!

I just updated unraid from 6.9.2 to 6.10.2 and could not figure out why at least one CPU core was stuck at 100%! Did check terminal -> top and could only see COMMAND "gunicorn"- which I could not find anything related to unraid with google. And the user was 5050 (and the only process using it, which baffled me).


Then I suspected docker (not runninv VMs currently). First test Plex was not successful, but luckily the second try with pgadmin4 did the trick. When stopping the docker the cpu dropped to ~2-7% instead of permanent 40-100% over all 4 cores.

Then I checked the community application and found your post- which I find interesting- because I did not have this problem before the update.


For anybody reading my post: here is the original pgadmin documentation https://www.pgadmin.org/docs/pgadmin4/latest/container_deployment.html#mapped-files-and-directories


After your suggestion with

sudo chown -R 5050:5050 pgadmin

and starting the docker again, the PID with COMMAND gunicorn and user 5050 did return, but dropped to 0% CPU after a couple of seconds. I assume it tried to access its appdata folder and gut stuck in a loop to try again. Why this did not happen before the unraid os update is beyond me, but not it's fixed. Thanks again 👍

Link to comment
  • 1 month later...

Any hope of this docker template being updated/fixed??


On a clean new Unraid 6.10.3 install, this docker's webUI doesn't even open.


Or is there another way I can restore a backup I took in pdadmin before? File is without extension, not a mysql or dump, or maybe that is a dump, I have no idea what pgadmin saves in by default.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.