Jump to content
Sign in to follow this  
bonienl

Test your translations

13 posts in this topic Last Reply

Recommended Posts

To test your translations, do the following:

1. Go to the github repo of your language and click on "download ZIP file". Store this file locally
2. Go to Tools -> Language in the GUI
3. Select Developer view (top right)
4. Upload the just downloaded ZIP file
5. Select your language name
6. Go to Settings -> Display Settings
7. Select your language as GUI language

Share this post


Link to post
Posted (edited)

Testing first two files after translation. Per instruction i've zipped whole folder, uploaded and switched to Polish. then parts of GUI work ok, but crucially the forms for reverting to english or reuploading the zip file do not work at all.

I know that restarting reverts to english, but how do i change the GUI language back to english via the terminal, to avoid restarting?

Edited by woocash

Share this post


Link to post

Neither Settings - Display - Language or the little switch language icon on the tool bar don't work?

Share this post


Link to post
Posted (edited)
42 minutes ago, Squid said:

Neither Settings - Display - Language or the little switch language icon on the tool bar don't work?

I think the language switch icon, might have been working, but other pages were mostly empty. The problem was caused by wrong format of line ends (CRLF) instead of (LF). Restarting solved that fortunately - unRaid had only English after reboot.

 

Still, out of curiosity - is there any path accessible to the user via ssh, where the config is located?

Edited by woocash

Share this post


Link to post

You can edit /config/plugins/dynamix/dynamix.cfg  on the flash driveand completely remove the line (and don't leave a blank line in its place)

locale="xx_XX"

and then reload any page on the UI to go back to English.

  • Like 1
  • Thanks 1

Share this post


Link to post
6 hours ago, Squid said:

You can edit /config/plugins/dynamix/dynamix.cfg  on the flash driveand completely remove the line (and don't leave a blank line in its place)


locale="xx_XX"

and then reload any page on the UI to go back to English.

Thanks!

Share this post


Link to post

@bonienl would it be possible to update WOFF fonts to include glyps from other languages than presently available?

In my case i have a mix of clear-sans and times new roman which looks quite ugly :)
obraz.png.3fe6038fd8db4e8d8fa30faf93907d45.png

That's just the main navbar, but it;'s the same everywhere.

Apparently according to FontDrop, the Clear Sans version unRaid is using does support only 15 languages, not including polish:

obraz.thumb.png.2724e9e5bad968a582379a44ca71ce5e.png

 

Whereas the TTF font available for download here: https://www.fontsquirrel.com/fonts/clear-sans supports 36 languages including polish.

obraz.thumb.png.f183d29ee479cd5b8d7725b2ecb28a4a.png

 

It seems that even if I locally install this TTF version, my browsers (Chrome and Firefox) default to the woff fonts that do not include polish characters :(

 

Share this post


Link to post

The GUI has 4 different formats installed: eot, svg, ttf and woff

 

It is the browser that decides which format to use, different browsers use different formats.

 

Share this post


Link to post

Is it possible to create a 'dummy' language?   This would help with testing to make sure that I have managed to get all the English translations for my plugins set up correctly as i could then put them into this dummy file to test that the translation file has entries for every English phrase the plugin will use.

Share this post


Link to post

You can upload any language (dummy or real) by uploading a zip file in Tools - Languages (Developer Mode) and then switching to it in Settings - Display

 

Or simply using an existing language already installed and creating your appropriate file in /usr/local/emhttp/language/xx_XX/ (and ensuring to delete all the *.dot files present)

Share this post


Link to post
On 6/22/2020 at 3:35 PM, bonienl said:

The GUI has 4 different formats installed: eot, svg, ttf and woff

 

It is the browser that decides which format to use, different browsers use different formats.

Yes, i'm aware :) Still, all these available formats lack multiple language-specific glyphs, including polish. Would You be so kind as to update the files, or direct me towards a person that is responsible for it, please?

Share this post


Link to post
Posted (edited)

A browser will fall back to its "default" font when a certain character code isn't available in the selected font.

You can change the settings of your browser and choose a different default font, e.g. use Arial instead of New Roman.

 

I have expanded the .woff and .ttf format files and included more languages support (including Polish).

Afrikaans Albanian Belarusian Bosnian Bulgarian Catalan Croatian
Czech Danish Dutch English Estonian Finnish French German
Greek Hungarian Icelandic Italian Latvian Lithuanian Macedonian
Maltese Norwegian Polish Portugese Romanian Russian Serbian 
Slovak Slovenian Spanisch Swedish Turkish Vietnamese Zulu

 

Edited by bonienl

Share this post


Link to post
On 6/27/2020 at 7:15 AM, bonienl said:

I have expanded the .woff and .ttf format files and included more languages support (including Polish).

Thank You, should I expect the change will take effect in the next beta?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this