Setup Windows install for both VM and bare metal, worked fine, now blue screen

Recommended Posts

I had setup Windows 10 on the system, then setup unraid, setup a VM to use that existing Win10 install, and cloned my uuid so the license stays activated both in the VM and when booting Windows on bare metal. Everything was working fine, I could shut down Unraid and boot directly to Windows if needed for some reason(pretty much don't, I just keep the VM running, it works great). But I just went to claim one of those 3 months of Xbox Game Pass codes that came with my GPU. AMD insists that I have to run the product verification tool to claim the code, but the program refuses to run. I assume it doesn't like being run in the VM. So I shut down the VM, shut down Unraid, then booted into the bios and switched to boot directly to the Win10 ssd like I noranlly do. I get the little loading circle/dots/whatever thing for about 20 seconds, then a blue screen that says "inaccessible boot device". No amount of rebooting produces different results. Booting back into Unraid, the VM says it is starting without issue, no errors or warning in the log, but the screen never wakes up, and I have to force stop the VM and then start it a second time to get it working again.


Any idea exactly what is happening with that blue screen, and how I can fix it? I'd like to claim that stupid code before it expires.

Edited by Zhono
Link to comment

I feel like there is a lot of information missing here. How exactly are you booting windows? Did you have a bunch of disks you plugged in and setup with unraid while excluding the windows disk you had windows on or what exactly is happening here? Are you unplugging all the disks except what was there before when this was just a windows pc or what the heck is going on exactly?

Link to comment

I have about the least complicated setup possible. 6 hard drives in the array, with no cache or parity drives. An nvme drive where windows is installed, with the VM setup to use it by selecting manual and pointing it to ”/dev/nvme0n1", and set to sata.(apparently I can't passthrough the drive because [insert technical details about chipsets or whatever that I already forget] so it's setup this way). I don't unplug/disable anything when switching between unraid and windows.


Again, this setup worked just fine, and I have changed nothing about the setup since I configured it. I had no issue previously booting back and forth between unraid and windows to configure rgb related stuff and to compare VR performance between bare metal and VM. The only change that I can think of is not too long ago there was (what seemed like) a larger windows update. The one that triggered the "Welcome to windows, here's a bunch of features no one asked for" screen before you get into the os.

Link to comment
  • 2 weeks later...

Apparently, the solution was to boot into safe mode, do absolutely nothing whatsoever and then reboot. Windows then booted fine. Of course, the AMD product verification tool is broken trash, and I had to download it like 15 times on 3 different browsers to get it to work.


Then, after booting back to Unraid, the VM wouldn't work. I appeared to be booting fine, claimed it was running, no errors or warnings, but my monitors refused to wake. The only way I could fix that, was to delete the VM profile and create an identical duplicate(I literally copy/pasted the XML) and it then booted up fine again.


Still have no idea what the problem was in either case, and I guess I never will. Oh well, it works again. Until next time, when it doesn't.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.