folder permissions help

Recommended Posts

can somebody help me with folder permissions? This is something that has plagued me for years with UnRaid and I'm at my breaking point :)

In this scenerio, I'm trying to set up a Minecraft server for my kid and I need to copy over his existing /world/ folder to the /appdata/minecraft/servers folder so the minecraft server docker can see it and I can import it. But I can not copy over any files to that folder. I've even tried changing "Minecraft Files" container path in the docker to something outside the /appdata/ folder (I tried an unassigned device for example) and I still can't write files to it.


these are the permissions on the /appdata/minecraft/ folder in question:


drwxrwxrwx 1 nobody users 80 Jun 18 19:23 minecraft/

Link to comment
21 hours ago, jpotrz said:

these are the permissions on the       /appdata/minecraft/        folder in question:

Is this really the path that you are using?  I can only assume that you are showing the Linux path.  The first '/' indicates that directory   appdata    is the root of the Linux file system.  (This would be on the RAM disk that Unraid uses for the OS install.  It would be erased every time Unraid is rebooted.)  Normally, the appdata directory is located in the   /mnt/user  directory.


Next thing, The appdata directory is normally used by a Docker.  If you are using a Docker called Minecraft, you should be asking this question in the Minecraft support thread. 

Edited by Frank1940
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.