Jump to content
ThePockets

Can't connect to network on new Unraid build (Maybe Ethernet driver issue?)

24 posts in this topic Last Reply

Recommended Posts

Hello friends! Coming to you for help after a couple days of troubleshooting. I am building a new NAS/HTPC using the Asus TUF Gaming B550m Plus motherboard with the most recent BIOS. Everything is detected correctly, however it is not able to connect to the network even though it is direct connected to the router through Ethernet. Because of this, I can't get a registration key to be able to set up my drives and all.

In my troubleshooting, I have tried using the stable and beta versions of Unraid (6.8.3 & 6.9.0), I have tried both DHCP and setting a static IP, and I have tried putting the Unraid flash drive in different USB slots. None of this made any changes. I then tried booting into a Ubuntu disc, and found I was not able to connect to the network there either. From what I can tell, I don't think Ubuntu nor Unraid has the driver for the Realtek RTL8125B controller that the motherboard uses. I am able to find a Linux driver on Realtek's website here

Do you know if this is the problem? If so, is there a way to add the driver to Unraid? If this isn't the problem, do you have any ideas on what it could be? Thank you!

tommy-diagnostics-20190101-0127.zip

Share this post


Link to post

Unraid has the driver, though IIRC it's not working correctly on v6.8, it should work on v6.9-beta22, please post diags from the beta.

Share this post


Link to post

Well, it appears I was wrong, it does look like a driver issue, you might need to wait for an upcoming release to use that NIC, best bet for now would be an ad-don NIC.

Share this post


Link to post

Dang, thanks for looking into that. Do you know if I'm able to send a request to Limetech for it to be fixed in the next release? 

Also in the mean time, do you know of a cheap 1Gb nic that would work with Unraid? Thanks again!

Share this post


Link to post
Posted (edited)

Having the same issue with the same motherboard, really hope this issue could be fixed in next release

Edited by Lancer

Share this post


Link to post
11 hours ago, ThePockets said:

Do you know if I'm able to send a request to Limetech for it to be fixed in the next release?

You can post on the beta release thread mentioning that your NIC isn't working, don't forget to add the diags.

Share this post


Link to post

I am having the same issue with this motherboard as well.

 

Is there anything I can do to help you test the new drivers?

 

I'm a noob, but I will help if I can.

 

Share this post


Link to post

Update:

I just installed Unraid 6.9 Beta 22, and the Realtek RTL8125B onboard Ethernet controller still does not work on my Asus TUF Gaming B550 Plus motherboard.

 

 

Share this post


Link to post
27 minutes ago, Barnabas said:

Update:

I just installed Unraid 6.9 Beta 22, and the Realtek RTL8125B onboard Ethernet controller still does not work on my Asus TUF Gaming B550 Plus motherboard.

Wait for the next version of Unraid.

Share this post


Link to post
2 hours ago, Barnabas said:

Update:

I just installed Unraid 6.9 Beta 22, and the Realtek RTL8125B onboard Ethernet controller still does not work on my Asus TUF Gaming B550 Plus motherboard.

 

 

I'm troubleshooting an onboard NIC issue as well.  I'd like to try and see if the beta has my NIC drivers.  Where did you find the beta download?  I've been searching for a couple hours to no avail

Share this post


Link to post
2 hours ago, jacksaudio said:

I'm troubleshooting an onboard NIC issue as well.  I'd like to try and see if the beta has my NIC drivers.  Where did you find the beta download?  I've been searching for a couple hours to no avail

Go to "Tools" | "Update OS" in the GUI, and in the branch section select "Next" and you will see the beta version available.

(Only recommended for testing purposes)

 

Share this post


Link to post
Go to "Tools" | "Update OS" in the GUI, and in the branch section select "Next" and you will see the beta version available.
(Only recommended for testing purposes)
 

That’s what I thought. Unfortunately I can’t get my system working on the new hardware cause of the network card issue. Was hoping there was a download somewhere so I could make a usb


Sent from my iPhone using Tapatalk

Share this post


Link to post

Thx but was hoping for a download I could put on a USB for initial setup for a new system. I’m stuck getting my new build up and running because it doesn’t recognize the onboard intel nic.

The nic works cause the asrock uefi bios successfully updated its firmware. I was also successful booting from a Ubuntu 20.04 usb drive and surf the web.

Gonna go pick up a pcie nic card in the morning and try that. Very frustrating....


Sent from my iPhone using Tapatalk

Share this post


Link to post

With the Unraid USB Flash Creator you can select the last beta :

image.png.99f752c637dca2ed46db6b6489b17303.png

 

(I know my USB drive is not the best choice, it was just a test with the first one on hand ;) )

Share this post


Link to post
With the Unraid USB Flash Creator you can select the last beta :
image.png.99f752c637dca2ed46db6b6489b17303.png
 
(I know my USB drive is not the best choice, it was just a test with the first one on hand  )

Omg...lol...I didn’t even check the usb creator cause I’ve had suck bad luck with it so I’ve been downloading the zip, extracting and then make the drive bootable

Thx! I’ll tinker with that tomorrow


Sent from my iPhone using Tapatalk

Share this post


Link to post
On 6/22/2020 at 11:02 AM, ThePockets said:

Hello friends! Coming to you for help after a couple days of troubleshooting. I am building a new NAS/HTPC using the Asus TUF Gaming B550m Plus motherboard with the most recent BIOS. Everything is detected correctly, however it is not able to connect to the network even though it is direct connected to the router through Ethernet. Because of this, I can't get a registration key to be able to set up my drives and all.

In my troubleshooting, I have tried using the stable and beta versions of Unraid (6.8.3 & 6.9.0), I have tried both DHCP and setting a static IP, and I have tried putting the Unraid flash drive in different USB slots. None of this made any changes. I then tried booting into a Ubuntu disc, and found I was not able to connect to the network there either. From what I can tell, I don't think Ubuntu nor Unraid has the driver for the Realtek RTL8125B controller that the motherboard uses. I am able to find a Linux driver on Realtek's website here

Do you know if this is the problem? If so, is there a way to add the driver to Unraid? If this isn't the problem, do you have any ideas on what it could be? Thank you!

tommy-diagnostics-20190101-0127.zip 55.48 kB · 2 downloads

I'm experiencing the same issue now with my ASUS B550 Gaming-E chipset. I tried everything you mentioned. Also running 6.8.3 and tired upgrading to 6.9 beta but it still didn't work. My chipset has Intel's I225-V ethernet controller which Unraid supposedly supports yet no NIC is found. Could there be some other issue between Unraid and the ethernet controllers on the B550 chipsets?

tower-diagnostics-20200630-1756.zip

Share this post


Link to post
8 minutes ago, bubbleman441 said:

I'm experiencing the same issue now with my ASUS B550 Gaming-E chipset. I tried everything you mentioned. Also running 6.8.3 and tired upgrading to 6.9 beta but it still didn't work. My chipset has Intel's I225-V ethernet controller which Unraid supposedly supports yet no NIC is found. Could there be some other issue between Unraid and the ethernet controllers on the B550 chipsets?

tower-diagnostics-20200630-1756.zip 96.67 kB · 0 downloads

In your beta22 syslog it appears the driver is loaded and the interface is working.  Maybe remove the s3.sleep plugin - that might be interfering.

Share this post


Link to post
On 6/22/2020 at 12:16 PM, ThePockets said:

Dang, thanks for looking into that. Do you know if I'm able to send a request to Limetech for it to be fixed in the next release? 

Also in the mean time, do you know of a cheap 1Gb nic that would work with Unraid? Thanks again!

We added the vendor driver to upcoming 6.9.0-beta23

Share this post


Link to post
31 minutes ago, limetech said:

In your beta22 syslog it appears the driver is loaded and the interface is working.  Maybe remove the s3.sleep plugin - that might be interfering.

You nailed it! Removed the plugin and it's working now. Thanks so much!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.