Jump to content
Sign in to follow this  
shrippen

[SOLVED] hanging during boot at bzroot

9 posts in this topic Last Reply

Recommended Posts

Hi,

I recently purchased unraid and build myself a system out of old hardware I had around. This worked all rather well and I started to move all my data onto the system. Yesterday I installed a new SATA Controller (BEYIMEI PCIe 5Port). After booting it seemed to work - but somehow not all attached drives were recognized but at least some so that I though the card seems to be working.

So I shutdown the system and reattached the cables and turned on the system again. But since then I cant boot anymore. It just stops at bzroot....ok

 

- I ran memtest for about 4 hours - no problems there.

- disconnected the Sata Controller - didn't help

- disconnected every SATA device - didn't help

- formated my usb stick and put a new instance of unraid on it - didn't help

- shutdown the system and let it rest for a few hours (i read somewhere that it could be a temperature problem)

 

It could be related to the usb stick (a Sandisk Extreme 32 GB stick) - I ordered a new one from the recommended list. But it only gets here tomorrow. But it worked for two weeks before yesterday... and continues to work on my main machine???

 

As for the installed hardware in General (that I haven't disconnected so far)

 

ASRock Z270M Extreme4

i7 7700k

32GB Ram

M.2 SSD

 

Any ideas what happened here and what I should do to get this working again?

 

And just to reiterate - this worked flawlessly for about 2 weeks, with exactly this USB stick etc. All that changed was the SATA Controller which I removed already.

Edited by shrippen

Share this post


Link to post

Looks like there are USB2 headers on the motherboard.

 

Some people find they have issues with USB3 disconnects with some hardware. Doesn't seem to affect everyone.

Share this post


Link to post

I bought a new USB Stick (Kingston Data Traveler 2.0) and a USB2 connector for the USB2 header on my motherboard. I still get the same error. I used the Unraid USB Creator to prepare the stick.

 

Please help!? What is happening here? Why don't I get any meaningful troubleshoot information from the loading procedure?

Share this post


Link to post
On 6/30/2020 at 7:40 AM, shrippen said:

It just stops at bzroot....ok

When this exact behavior happened on my system a couple of years ago, it was solved by booting in UEFI instead of legacy BIOS.  Nothing had changed on my system other than a new unRAID version with a new kernel.  Flash drive, configuration, hardware was all unchanged. 

 

Some hardware combinations just seem to trigger certain behaviors in drivers/firmware/BIOS, etc.

 

On your unRAID flash drive, try renaming the EFI- folder to EFI (remove the trailing "-" character.  This will tell unRAID to try and boot in UEFI instead of legacy BIOS and perhaps it will make a difference.

 

No guarantee that will solve the problem, but, it is easy to give it a try.

Share this post


Link to post

Well are you shitting me? That worked! Wow! Thanks for the idea! I became really frustrated. But I still don't understand how that happened? Why is this fixed now required but it worked before that?? Still strange after all.

Share this post


Link to post
13 minutes ago, shrippen said:

Why is this fixed now required but it worked before that?

Same situation for me.  Nothing had changed as far as my server hardware and configuration was concerned, but, a new Linux kernel didn't like my hardware like the previous one did.

 

In your case, introducing the SATA controller changed some low-level dynamic in your system and the Linux kernel would no longer boot properly in legacy BIOS mode.  UEFI could handle it.

 

That is why Limetech started includind UEFI boot mode a couple of years ago.  More and more hardware is responding better to UEFI boot than legacy boot.  Some older hardware can't boot UEFI and legacy boot mode remains the default.

 

At some point, I think UEFI will need to become the default as a lot of modern hardware is UEFI only.  Fortunately, unRAID can deal with both.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this