Jump to content
Keexrean

The USB drive thread?

23 posts in this topic Last Reply

Recommended Posts

Hi people!

 

Whether you're running unraid in an refurb enterprise server or in a brand new case boasting a ludicrous amount of DDR4 and an Epyc processor, or have a threadripper or a janktastic set of garbagio parts that assembled themselves through dark magic into a server, there is one thing we, at 99.9% have all in common with unraid: we use an USB stick to boot.

 

And that's where I'm having some concern today.
No, I won't be like 'why not use something else', that's not the point. It's more like "what usb drive to use"

 

My unraid server has been running strong for 3 years on the same USB stick. No write error, nothing, everything's great! Or almost.

That drive is an idon'tremmemberhowmany years old 8GB JetFlash drive that's missing its plastic housing, wraped in kapton tape.

 

I have an esxi box with a drive from 2007, missing its housing too, wrapped in greasy electrician tape.

(I also have a "naked" SSD... I'm a monster 😲)

 

And since I'll be expanding the number of servers in my humble ratsnest of a flat, I decided to replace the old drives from which my boxes are booting, and buy some extra for the new ones.

 

The issue is, it's proven quite hard knowing which drive manufacturer to trust when it comes to this.

 

I already completely ruled out Sandisk. They have been known to produce drives that aren't capable of being boot drive, not following official USB specs. How the f.

This thread is quite interresing on the matter, basically linux can't enumerate the drive. Since I'm gonna order like 10 keys, I don't want to have 10 useless tokens of industrial failure.

Kingston I had a bad time with once, Transcend several times, but I also owned a lot of transcend keys, and some... well are still holding so far 13years strong.

And looking at customer review, basically every key I look up has its fair share of catastrophic failures (like breaking randomely, DoA or stupidly slow speeds, USB3.1 drives running at 1.1 speed).

 

And most comparative reviews are made on sheer speed-and-housinglook&sturdiness-to-price, not durability over years of being powered on.

 

 

 

So here's what I'm looking for: Is there some of you who have been running multiple identical pendrives over the years who can give a fair opinion on their speed and, most importantly, reliability?

I'm basically looking for 8gig (max 16gigs) pendrives with usb3.0 and up, and just decent enough speeds, that with your experience with that particular drive, you would say it won't mind living next a PSU inside a server, with a raging hot CPU and ram bank puking an heat-wave at it, for years, 24/7.

 

I'm keeping religious backups of my bootdrives, but since I host services for other people, including on opposing time zones, I have no hour acceptable to be a down time longer than a simple reboot (which is long enough already, long POST board.), and I prefer stuff to just WORK and not fail, for some madly inconceivable reason.


TLDR: if it's easy for most components, a "server-booting usb drives: almanac of great ones" post is hard to come across. 

Share this post


Link to post

https://www.kingston.com/us/usb-flash-drives/datatraveler-se9-usb-flash-drive

 

Yes, I know, they are a brand you don't like. Also, I don't recommend ANY usb 3.0 sticks.

 

The SE9's are rugged, have been reliable for me, good heatsinking (all metal case), and are still available in USB 2.0, which is important to me.

 

I think (personal opinion here) the extra speed of the 3.0 sticks causes pinpoint heat buildup in the on stick controller chips and contributes to their demise.

 

I personally have 4 for my servers, and a handful more scattered around on keychains and elsewhere.

Share this post


Link to post
Posted (edited)

Thanks for the input. Kingston as I said I had only ONCE a bad experience with (a slow af drive that I gave to my mother, which stored quite important documents on, and basically failed the day of an important meeting just 2 months after purchase!).

 

And given that I only ever had 3 Kingston key, I was just unable to give a proper evaluation of their USB keys, nor willing to risk to waste money into potentially defective drives.

And with the particular environmental parameters inside a server compared to what most people do with USBkeys, I would have had to risk having servers bootings off of keys I don't trust already? Yeah no.

 

Also, the reason I was questioning about usb 3.0key over 2.0 even on USB2.0 port, was for the simple reason I would think that 2.0 nowadays could be a good reason to cut down on flash chip quality to cut costs for manufacturer. Aka, nice chips going to 3.x keys, shitty slow chips going to 2.0 keys.

 

 

But if you tell me you have 4 running strong and reliably, and at the back of/inside servers, I may try these!

Edited by Keexrean

Share this post


Link to post
Posted (edited)

SanDisk 64GB Cruzer Fit USB Flash Drive - SDCZ33-064G-G35

 

This is a 2.0 and runs fine and at a very low temperatures.  Read the reviews on them. I use them on my PBX and they've been running fine for years.

 

I think you're over engineering this one :) 

Edited by johnwhicker

Share this post


Link to post
Posted (edited)

Well, concerning SanDisk, I did linked a bit long post and didn't really pointed out some important piece of informations, to keep it short.
Here are the main points:

For the same "Product Name", they discovered that SanDisk sells under the same name (in this post the user Nejko had a SanDisk Ultra Fit 32 GB, and later bought more) at least 3 different product codes (BM141024848V, BM141224848V and BM150224846D), only the first of the 3 actually successfully booting linux, the two others getting stuck early on on a "(initramfs) Unable to find a medium containg a live file system" issue, accross multiple distros.

 

Worse, same user, Nejko, got a hang of a Sandisk Rep through mail, and here's what they got told:

Quote

 

Dear Nejc,

We understand that you cannot use your Ultra Fit drives as bootable devices. We would like to inform you that we at SanDisk have not tested our flash drive as a bootable device. SanDisk does not provide any utility or instructions to make the flash drives bootable.

So in that case we cannot assist you further with this issue.

 

 

You heard that. They don't test their keys to see if they are bootable!!

Pretty dismissive, and the kind of BS that doesn't make me want to do any business with them when it comes to USB sticks. At least their SSDs are tested to be able to boot... so far.


Later in the post, the user jdb2 went deeper on the issue on their own SanDisk key:

Quote

 

I did extensive debugging : I enabled early kernel debug/printk messages, maximum loglevel, “set -vx” in init and /scripts/casper in a custom initrd.lz and sent everything over to a another machine running “netcat -u -l 6666” with the netconsole directive properly configured on the problem flash drive.

I looked at casper.log but I couldn’t trace down the problem, even with “set -vx” enabled and debugging echos inserted into critical places. The netconsole output did show the possible cause though :


[21.546102] usb 2-1.2: device descriptor read/64, error -110 
[26.733116] usb 2-1.2: device descriptor read/64, error -71 
[26.909409] usb 2-1.2: new high-speed USB device number 4 using ehci-pci 
[26.993284] usb 2-1.2: device descriptor read/64, error -71 
[27.181399] usb 2-1.2: device descriptor read/64, error -71 
[27.357527] usb 2-1.2: new high-speed USB device number 5 using ehci-pci 
[27.773693] usb 2-1.2: device not accepting address 5, error -71 
[27.845809] usb 2-1.2: new high-speed USB device number 6 using ehci-pci 
[28.262016] usb 2-1.2: device not accepting address 6, error -71 
[28.262219] hub 2-1:1.0: unable to enumerate USB device on port 2

So Linux is trying to enumerate the drive but fails, therefore it fails to mount the fat32/vfat partition which contains the filesystem.squashfs and hence “Unable to find a medium containing a live file system.”

I tried this on four different machines, with different hardware.

As a last resort I wanted to rule out the possibility that my byte-by-byte copy from the previous drive had somehow screwed up the new drive’s bootup process, so I wiped the disk and performed a fresh install of Linux Mint 17.1 Cinnamon 64-bit using Unetbootin – same result, on all 4 different machines.

Today I RMA-ed the drive. I own dozens of flash sticks and I have never had a problem with any of them booting Linux. If SanDisk produces devices that somehow deviate from the official USB spec, then I’d strongly recommend anyone looking to boot Linux off of a USB flash drive select another manufacturer. We’ll see – In my RMA I said I wanted a drive with the same specs but with its firmware updated so as to support booting Linux.

 

 

That's why I completely ruled out SanDisk when it comes to bootable USB disks.

 

I may be over-engineering the question, but since I'm planning on buying a pack of 10 keys, I don't wanna play lottery with product codes.

And yes, your Sandisk USB keys boot fine, I have 1 that does too, and doesn't heat up or anything... but had one that never booted and that I gave to a friend for their university stuff.

The user Nejko had one, then went to buy more of the same model "Name", and got done in the rear IO.
 

Given the issues I encountered, that a lot of other people encountered, and SanDisk's apparent policy, if I'm ready to give a chance to any other brand, SanDisk is simply completely ruled out to me.

Edited by Keexrean

Share this post


Link to post

Well well well.

Thank's Kingston, only one of these will be used for unraid then, the 2 others will go for other distros.

 

image.png.9bebd3f7b572de89e6c6a71d62605a30.png

Share this post


Link to post
9 hours ago, Keexrean said:

Well well well.

Thank's Kingston, only one of these will be used for unraid then, the 2 others will go for other distros.

 

image.png.9bebd3f7b572de89e6c6a71d62605a30.png

That is very strange. Where did you purchase them?

 

One of two things is going on, either they very recently quit programming unique GUID's, or what you purchased is counterfeit.

 

A little over a month ago I got 4 more, and they all have unique (and none the same as your) GUID's.

 

Do they have unique serial numbers laser etched on the narrow edge? All mine have a large outline CE, and two lines of text with DTSE9H/16GB 05655-315.A00LF, OS XXXXXXX, 5V, and TAIWAN on them. The XXXXXXX are unique on all my different drives.

Share this post


Link to post

Like Jonathanm mentioned fakes don't usually have this:

imagem.png.f9224ede91991772f98e7608649f63a7.png

They also look different (left is fake)

imagem.png.dc331066ed8148f4ee9a453cad0d49a7.png

Share this post


Link to post

Weird. I wonder if the three pack has something to do with the three identical GUID's.

 

I've always bought single drives, albeit 4 at a time. Strangely, it's cheaper that way for me. Multi packs always seem to be overpriced.

Share this post


Link to post
4 hours ago, jonathanm said:

Do they have unique serial numbers laser etched on the narrow edge?

 

Share this post


Link to post
Posted (edited)

That time it was the cheaper option, by unit it was 6.99, and the 3 pack was 18.99. Basically saving 2€

 

Edit: their narrow edge's etching is fully identical on all 3.

Edited by Keexrean

Share this post


Link to post

Not sure if you have time for this, but it would be interesting to have some feedback from Kingston.

As jonathanm said, it is possible a deliberate choice from Kingston in their 3 pack ?

 

I was looking at this model too since I already have one on my keychain, it is quite tough, I am happy with it. Plus it seems a good model for heat dissipation.

Share this post


Link to post
Posted (edited)

Well, from what we can assume it that pack of 3 seem to be a triplet twin situation.
Probably that by-unit sold ones should still be unique. Damn 2€ saving wasn't worth it.

Edited by Keexrean

Share this post


Link to post
57 minutes ago, Keexrean said:

Upgrades people, upgrades
image.thumb.png.f22b50c0185abd5e710223924a7cf647.png

That looks fine to me, Kapton tape is a perfectly cromulent encasement. 🤣

Share this post


Link to post

Well, the one of the left is basically what have ran my unraid server since 2017... I always broke plastic casings of USB keys (and this particular key also had a mobile workstation dropped on at some point before it became my server's boot device).

Kapton type sounded to me like the less worst tape that would still be better than bare PCB (at least I was sure the adhesive wouldn't deteriorate).

 

But you were warned! I said it was wrapped in kapton tape from the start, in the OG post!

 

And you think kapton-wrapped USB is wrong? What about that!?
image.thumb.png.b3923fb3a7d66f873dd870f7ac0f7d62.png
 

Share this post


Link to post
3 minutes ago, Keexrean said:

And you think kapton-wrapped USB is wrong?

Definitely not, it's meant for permanent insulation on electronics, especially where there could be some movement. I see it as the ideal solution, barring the availability and motivation to use a 3D printer. Even with a replacement protective housing, Kapton should still be used on the bare circuit.

 

Kapton and double sided foam tape is the electronic equivalent of duct tape and baling wire.

 

I was applauding your usage, not mocking it.

Share this post


Link to post

Eeeer, I was mostly seeing the Simpson reference, saying as it's yes effective but with an humorous twist, and I decided to ride that boat and show the next level of "refined jankiness", as in the daily use of electronic and PC parts wrapped in tape, but with the fanciness and luxurious taste in the choice of tape, presented with that naked-kaptonwrapped-SSD in that laptop I use as an IPMI dedicated console on a different VLAN than the rest.

 

 

Share this post


Link to post

Late to the party but I +1 for the Sandisk Cruzer Fit, especially for externally plugged in USB slots.. they have minimal casing to damage.  It's practically impossible to damage one by hitting it or anything like that because there's not really anything sticking out to hit.

 

I'm not going to argue anything about the quality or usability of Sandisk usbs.. all I know is that I've never had any problems with any Sandisk usbs that I've ever had for any purposes.  In fact, when it comes to usb / flash memory in general, Sandisk is my #1 go to... that's my personal opinion and findings.

Share this post


Link to post
On 7/30/2020 at 10:16 AM, Energen said:

+1 for the Sandisk Cruzer Fit

This is what I have in both of my servers, the USB2 version. USB2 is all that's needed in this application, USB2 ports work more reliably in this application, and USB3 in this small form factor is likely to overheat in my experience.

Share this post


Link to post

I'm having a similar experience with USB drives.

 

My current server has been running happily on a 16GB USB 3.0 Sandisk Ultra Fit for around 3 years. 

I'm in the process of upgrading to a new server so I'm running a trial with the intent of converting this to a basic licence and to reuse an old HP N40L as parity protected cold storage. I like the small drives as they are difficult to break, though could use the internal USB port as discussed here.

 

Anyhow, the 16GB USB 3.0 Sandisk Ultra Fit weren't available so then the fun started.

 

16GB Sandisk Ultra Fit USB 3.1 (all black)  - No Guid

32GB Sandisk Ultra Fit USB 3.0 (old one with metal insert) - won't boot in any device, these look identical to the 16GB that works in any device.

32GB Samsung Fit Plus USB 3.1 - won't boot in the N40L at all, will only boot in SuperMicro X10 if I enable  'allow UEFI' in customise during creation. The 16GB Ultra Fit boots without.

 

A 16GB USB 2.0 Cruzer Fit arrived today to I'll see if that still works, and maybe stock up on a few spares for the future as they are very cheap in this size. 

I think larger is better to a point as it helps the wear leveling even though the number of writes is small.

 

I'll also take a look at the Kingston SE09, I have at least one genuine USB 2.0 of these, the other looks fake as there is only a logo on one side and I had a couple stop working in general use but these could have been fake. I also have a couple of later USB 3.0 versions.

The triple pack could be useful if the GUID is common to all sticks and compatible with Unraid. Could these be a good backup option?

If a stick went bad, you could just copy the latest backup to a replacement stick without needing to go through licence replacement which could be handy if you're running through PFSense or something on the server.

 

 

 

Edited by Decto

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.