Vm's in 6.9 beta - do they work - kmode exception not handled

Recommended Posts

My Bad

Model: Custom

M/B: ASUSTeK COMPUTER INC. ROG CROSSHAIR VIII HERO (WI-FI) Version Rev X.0x - s/n: 190856413301420

BIOS: American Megatrends Inc. Version 0803. Dated: 08/01/2019

CPU: AMD Ryzen 9 3900X 12-Core @ 3800 MHz

HVM: Enabled

IOMMU: Enabled

Cache: 768 KiB, 6144 KiB, 65536 KiB

Memory: 64 GiB DDR4 (max. installable capacity 128 GiB)

Network: bond0: fault-tolerance (active-backup), mtu 1500
 eth0: 1000 Mbps, full duplex, mtu 1500
 eth1: interface down

Kernel: Linux 5.7.8-Unraid x86_64


Link to comment

@ernestp I had the same issue caused by Kaspersky Internet Security installed inside the VM. By default KIS checks if any virtualisation features are available and try's to use it. Any time i tried to change some settings in KIS or even uninstalling it, it will crash the VM. I couldn't even dissable this function. Changing it to "host-model" or to "custom" allowed me to dissable this feature in Kaspersky. I guess for you there are features like Hyper-V enabled which sees some CPU features from the host system and tries to use them. Try to dissable Hyper-V if you don't need them or use the "custom"  or "host-model" cpu flag.

Link to comment
  • 4 weeks later...


I just installed the trial version 6.9 beta 25 on my new Ryzen 9 3900X with MSI X570 Tomahawk Wifi mainboard.

Just created a WIN10 VM and having the same issue of blue screen with "kmode-exception-not-handled" message. The VM is empty. Only Chrome and Virtio drivers installed. The VM start fine but when launch Chrome the VM crash.

I tried your suggestion of host-model flag in xml file but still not working. Same behavior.

Any suggestions?

Thank you



Link to comment

I'm just building my first unraid server and facing this issue. (I need to use the beta version because in the stable one the NIC driver of my board is not included yet).

So I added "kvm.ignore_msrs=1" to the syslinux.cfg file but through this the VM Manager and the array want startup anymore. Is it possible that someone shares an example of the syslinux file or briefly describes where the command has to be inserted?

Thanks and best regards

Link to comment

I had a similar issue. Windows 10 VM boot-looping with blue screen. Ryzen 3950x. Solved it by adding the following to the end of the VM xml as suggested elswhere on this forum: 


    <qemu:arg value='-cpu'/>
    <qemu:arg value='host,topoext=on,invtsc=on,hv-time,hv-relaxed,hv-vapic,hv-spinlocks=0x1fff,hv-vpindex,hv-synic,hv-stimer,hv-reset,hv-frequencies,host-cache-info=on,l3-cache=off,-amd-stibp'/>


  • Like 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.