Jump to content
ricreis394

(SOLVED) /dev/dri not found using an intel i5-10600K

6 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hello,

 

I'm new to unRaid, also I recently bought the most recent intel core generation cpu, an i5-10600k with quicksync supported

My goal was to use the iGPU to transcode in plex, after reading some posts in the forum, I realized no one fixes my problem, maybe the cpu isn't compatible??

 

I tried these commands:

modprobe i915
cd /dev/dri

but that directory doesn't exist,

then found something that it needs to add this 

i915.alpha_support=1

to the syslinux.cfg, again no luck

 

anyone can help me?

 

PS: motherboard is this one: MSI MAG Tomahawk Z490

Edited by ricreis394

Share this post


Link to post
1 hour ago, ricreis394 said:

I tried these commands:


modprobe i915
cd /dev/dri

but that directory doesn't exist,

I doubt the iGPU of the 10xxx CPUs is supported in the older 4.19.xxx Linux kernel of the 6.8.3 release.

 

You might try installing the 6.9 beta 25 release to see if the 5.7.8 kernel has the proper support.

 

You can always roll back to stable once you see if the Linux kernel version is the problem.

 

Also, as a general rule with any Linux kernel, make sure the iGPU is the primary graphics adapter (or however it is specified in your BIOS) or the i915 drivers will not load.

Share this post


Link to post
9 hours ago, Hoopster said:

I doubt the iGPU of the 10xxx CPUs is supported in the older 4.19.xxx Linux kernel of the 6.8.3 release.

 

You might try installing the 6.9 beta 25 release to see if the 5.7.8 kernel has the proper support.

 

You can always roll back to stable once you see if the Linux kernel version is the problem.

 

Also, as a general rule with any Linux kernel, make sure the iGPU is the primary graphics adapter (or however it is specified in your BIOS) or the i915 drivers will not load.

iGPU is already defined as primary in BIOS

 

doing

lsmod | grep i915

outputs this, so I guess it means something, right?

i915                 1351680  0
i2c_algo_bit           16384  1 i915
iosf_mbi               16384  1 i915
drm_kms_helper        135168  1 i915
drm                   348160  2 drm_kms_helper,i915
intel_gtt              20480  1 i915
i2c_core               40960  4 drm_kms_helper,i2c_algo_bit,i915,drm
video                  40960  1 i915
backlight              16384  2 video,i915

I'll try checking with another versions of unRaid

Share this post


Link to post
22 hours ago, Hoopster said:

I doubt the iGPU of the 10xxx CPUs is supported in the older 4.19.xxx Linux kernel of the 6.8.3 release.

 

You might try installing the 6.9 beta 25 release to see if the 5.7.8 kernel has the proper support.

 

You can always roll back to stable once you see if the Linux kernel version is the problem.

 

Also, as a general rule with any Linux kernel, make sure the iGPU is the primary graphics adapter (or however it is specified in your BIOS) or the i915 drivers will not load.

Thanks! It worked! 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.