Jump to content
craigr

I've come a long way, but can't do the simplest thing!

7 posts in this topic Last Reply

Recommended Posts

So I had zero experience with VM's and feel I have come along way.  I've read and read, watched tons of Spaceinvader's and Jon's videos on YouTube, and experimented like crazy.  I successfully have my first VM running; Windows 10 booting off of my NVMe with VNC graphics (my next challenge is going to be passing my video card and keyboard through to the VM and get that working).  However, I cannot do the simplest thing, edit the VM's XML file

 

I know from reading "edit xml" used to be in the VM icon's drop down menu in unRAID, but understand that it's not supposed to be there anymore.  I have seen from forum posts that if I go into the VM's edit window in unRAID that I should have an option at the top right to switch the view to XML.  However, I have no such option.  This is driving me nuts.  I thought maybe it has something to do with my unRAID theme, or browser, or something I customized in unRAID, so I tried a different browser (usually use chrome but tried IE).  In IE the VM page looks totally f***** up and is unusable (which leads me to think a display issue in unRAID web GUI for me).  I am so frustrated!!!

 

Also, if I search the page for "view" Chrome finds the word "view" on the screen but I can't see it anywhere.  This leads me again to an issue with my web GUI.  (and also if I go into the Community Applications app, the screen is not quite right there either.  "Search" is not in the correct place and other small issues).  I've attached screen shots.

 

Can somebody please tell me how to edit the XML file for my VM and if there is something up with how unRAID is displaying in the web GUI?  I just want to try Spaceinvader's simple edit to get sound through VNC before my video board arrives.

 

PLEASE HELP & THANK YOU FOR HELPING A NOOB!

 

Kind regards,

craigr

 

 

unraid_vmedit.png

unraid_comapp.png

unraid-diagnostics-20200801-1034.zip

Edited by craigr

Share this post


Link to post

Thank you!

 

I had created a Tampermonkey script to move the IPMI settings to the bottom of the page in the unRAID Dashboard.  Once I saw your screen shot I was sure it was a browser GUI issue.  I disabled the Tampermonkey script and the bottom showed right up.  There went like five hours of wasted time, but I am so glad it's fixed!

 

craigr

Share this post


Link to post
9 hours ago, Energen said:

The original greasemonkey script from that IPMI thread works...

Yes, it works to move the IPMI info to the bottom of the dashboard, but on my system it messes up other pages including community applications and hiding the XML view in the VM window...

 

craigr

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.