Updated to 6.9 beta 25. Ca no longer start Windows VM with GPU passthrough

Recommended Posts

After realising I needed to upgrade to beta25 for my new B550 MB to work, I have since not been able to boot up any of my VM's (through VNC or GPU).

I found a post about fixing my XML to 'host-model' instead of 'host-passthrough' which managed to get my VM booted into VNC.

When I have then gone to change my graphics to my GPU, it wants to add it as a secondary graphics card and use VNC as the primary.

This is incredibly frustrating as I am now going on 2 days of not being able to properly use my VM....

Link to comment
  • 1 month later...

Not sure if you ever resolved this, but I figured I would reply as I ran in to the exact same problem. Ever since upgrading to 6.9, the gui config will not allow me to remove the vnc graphics card. You can do one of two things:


1) Add your passthrough as a secondary card. Then VNC into the the VM and disable the vnc graphic adapter in the device manager. I mirrored the displays before doing the disable. 




2) Remove the VNC graphic adapter in the XML. I just deleted the xml out for the vnc adapter and saved and it now works as expected.


Hope this helps.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.