[SOLVED] How can I force unRAID to boot with iGPU and not dGPU when both are connected to monitors?


Recommended Posts

Hi everyone!

 

I recently got my new server which has an i5-8400 on an Asrock H370 Pro4.

 

The CPU has an integrated GPU. In the BIOS, there is an option to set the Primary Output. I set it to Onboard. Good.

 

Let's boot unRAID with monitors connected to iGPU and to my Radeon GPU. It posts to both monitors, shows the blue boot manager to both monitors but boots and shows the terminal on the Radeon screen and freezes on the iGPU screen.

 

That is not good...

I went back to the BIOS and I found an option which enables the integrated graphics even if there is a dedicated GPU installed. It's called IGPU Multi-Monitor. Good, that is what I need. Still not working... Doing the same thing.

 

Now, if I unplug the dGPU and leave the Intel connected to a monitor, it boots perfectly. GPU Passthrough work like a charm.

 

The only problem is that I would like to use remote gaming on that Windows VM and I need a monitor connected to the AMD because the resolution is only 1600x1200 in headless mode. So I ordered an HDMI Dummy Plug and I think, it will cause the same issue. 

 

Is there any way to tell unRAID to totally ignore the Radeon card on boot and force it to use the Integrated GPU for terminal even if the dummy plug is installed on the Radeon card?

 

Should I follow a guide which shows me how to passthrough the primary GPU? As I read, it disables something.

 

The dGPU is a Radeon HD7770. Everything has the latest firmware. Even the motherboard but I could reinstall it if needed.

 

Thank you very much in advance for your help! 🙏 

Edited by scania471
Link to comment
Unraid has zero role in that.
Deciding what device is used during boot is strictly controlled by the BIOS.
 
You can try booting Unraid in legacy mode (i.e. non-UEFI). Then hopefully the BIOS won't initiate the dedicated card.

Update: My motherboard doesn’t show me any option to boot in non-UEFI mode. I recreated the USB without UEFI but now, it doesn’t even boot.


Sent from my iPhone using Tapatalk
Link to comment
Unraid has zero role in that.
Deciding what device is used during boot is strictly controlled by the BIOS.
 
You can try booting Unraid in legacy mode (i.e. non-UEFI). Then hopefully the BIOS won't initiate the dedicated card.

Update 2.0: I had to enable CSM support. I set everything (PCI ROM, LAN X...something, Storage control) to legacy only. Now, it boots only to the iGPU and I can pass through the AMD! It worked, thank you very much!


Sent from my iPhone using Tapatalk
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.