[Solved] Unraid won't boot after UPS event - Unraid 6.8.3


Recommended Posts

Hi guys,


If anyone can give me some pointers on what to do next, I would be very appreciative! 


I replaced my UPSs batteries by hot-swapping them.  No big deal, Unraid and the server just kept on going thanks to my Supermicro's redundant power supplies.


Anyhow, I noticed that a couple of my dockers were missing their thumbnail icons, and after poking around saw that they were all using wrong IPs (with the bridging dockers set to use


Failing to resolve the problem within my limited skill-set, I rebooted -- only to discover that I could not get past the Starting Samba kernel message.  Odd, this!  So I rebooted into Safe mode, and have provided my diagnostics file.


Any advise on how to get back to normal operations?  Thank you so much! 


Edited by montery
Marking thread as solved.
Link to comment
2 minutes ago, trurl said:

From the command line, what do you get with this?

ls -lah /boot/config/plugins/*.plg


Hi Trurl!


Here's what I got...


root@Tower:~# ls -lah /boot/config/plugins/*.plg
-rw------- 1 root root 8.4K Jan  3  2020 /boot/config/plugins/NerdPack.plg
-rw------- 1 root root 5.1K Apr 13 00:00 /boot/config/plugins/advCPaMV.plg
-rw------- 1 root root 3.1K Jul 12 00:00 /boot/config/plugins/ca.backup2.plg
-rw------- 1 root root 3.5K May 11 08:24 /boot/config/plugins/ca.mover.tuning.plg
-rw------- 1 root root 3.9K Jan 28  2020 /boot/config/plugins/ca.turbo.plg
-rw------- 1 root root 6.1K Jul 27 00:00 /boot/config/plugins/ca.update.applications.plg
-rw------- 1 root root  66K Aug 16 15:43 /boot/config/plugins/community.applications.plg
-rw------- 1 root root 3.0K Nov 11  2019 /boot/config/plugins/customtab.plg
-rw------- 1 root root  21K Mar 21 16:05 /boot/config/plugins/disklocation-master.plg
-rw------- 1 root root 3.6K Jun 20 00:00 /boot/config/plugins/dynamix.active.streams.plg
-rw------- 1 root root 6.1K Aug  7 00:00 /boot/config/plugins/dynamix.cache.dirs.plg
-rw------- 1 root root 3.0K Jun 24 00:00 /boot/config/plugins/dynamix.local.master.plg
-rw------- 1 root root 2.7K Jun 25 00:00 /boot/config/plugins/dynamix.ssd.trim.plg
-rw------- 1 root root 4.2K Aug  8 17:04 /boot/config/plugins/dynamix.wireguard.plg
-rw------- 1 root root 6.0K Jul  1 00:00 /boot/config/plugins/enhanced.log.plg
-rw------- 1 root root 4.7K Aug 15 23:54 /boot/config/plugins/file.activity.plg
-rw------- 1 root root  16K Aug  6 00:00 /boot/config/plugins/fix.common.problems.plg
-rw------- 1 root root 4.1K Jul  1 00:00 /boot/config/plugins/open.files.plg
-rw------- 1 root root  25K May 11 00:00 /boot/config/plugins/preclear.disk.plg
-rw------- 1 root root 2.8K Dec  7  2019 /boot/config/plugins/statistics.sender.plg
-rw------- 1 root root 7.7K Aug  6 00:00 /boot/config/plugins/tips.and.tweaks.plg
-rw------- 1 root root  44K Jul 30 00:00 /boot/config/plugins/unassigned.devices.plg
-rw------- 1 root root 3.4K Oct 28  2019 /boot/config/plugins/unbalance.plg
-rw------- 1 root root 1.9K Jun  4 14:17 /boot/config/plugins/unlimited-width.plg


Link to comment

Ah ha!  I one by one renamed the following plugins back to .plg, and after rebooting I noticed they were no longer to be found:

-rw------- 1 root root 3.1K Jul 12 00:00 /boot/config/plugins/ca.backup2.plg
-rw------- 1 root root 6.1K Jul 27 00:00 /boot/config/plugins/ca.update.applications.plg
-rw------- 1 root root  66K Aug 16 15:43 /boot/config/plugins/community.applications.plg

Is this as simple as re-downloading these plugins?  Or is there more I should be looking into?


Also, I for some reason have lost the ability to view dockers running in the Docker Container panel on the dashboard.

When I view them under Docker, they are there, and operational.  Has anyone heard of this happening before?

Edited by montery
Additional information
Link to comment

If the .plg files exist then they should reinstall themselves. In fact, the old installations are probably still on flash, but without the .plg files they won't be loaded on boot.


Maybe there is something about the old installations that is breaking something. Each of those .plg files probably has a corresponding subfolder in /boot/config/plugins. You might try deleting those subfolders so they can get a clean install.

Link to comment

Thanks guys.  Got my plugins all back and operational again.

I deleted and recreated my docker.img file, and my dockers are back as well.


Unraid was saying my SSD CRC count was going up.  Not sure why, so I did a balance and will keep an eye on future crc errors.  I think my server is not feeling well!


In the end, Unraid did it's job just fine -- it kept my data safe, and kept running during the UPS event.  The plugins and dockers... well, they didn't fare as well, but these are community applications so I guess I can expect this.  Thanks for you help, and I'll mark this as resolved.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.