[Support] chacawaca - post-recording


40 posts in this topic Last Reply

Recommended Posts

Application Name: post-recording

Overview: Watches for .ts files made by Live TV recordings, convert them to a friendly format, extract .srt file, add chapters with comchap or remove them with comcut

Application: https://github.com/chacawaca/docker-post-recording

Docker Hub: https://hub.docker.com/r/chacawaca/post-recording

GitHub: https://github.com/chacawaca/docker-post-recording

Link to post

Hello,

 

Thank you for your effort and I am happy that I can make the first post on your topic.

 

With the first video your program still worked, with the second unfortunately not anymore. Would you take a look at the logs, maybe you can help me.

 

Docker log: https://pastebin.com/2KuPHS8i

 

Unraid logs attached.

tower-diagnostics-20200826-2103.zip

Edited by aurevo
Link to post
1 hour ago, Chacawaca said:

can you PM me your containers config, and do you have a custom comskip.ini or its the original one ? i tested comcut with 3-4 files and it seem to work. In your log is like .edl is deleted before comcut is processed.

 

 

Which files or folders do you need exactly?

 

I did not changed anything on the files, just copied the content from the intel example file to the custom.sh file.

Link to post

everything seem fine there, the only difference with me is i use nvidia, i cant test with intel myself cause i dont have one to test. 

with your log, ffmpeg create the temp mkv but comcut dont have access to open it. I suspected file permission, but i think i will need to find a way to test your exact configuration.

Link to post
5 hours ago, Chacawaca said:

do you mind change your repository to the alpha one, i changed something that can help with UTF-8 name.

 

chacawaca/post-recording:alpha

 

Changed to alpha channel.

 

First it looked good, but conversation failed:

 

Quote

 

[autovideoconverter] starting...
[autovideoconverter] Processing watch folder '/watch'...
[autovideoconverter] Skipping video '/watch/So baut man Traumautos/So baut man Traumautos 2020_08_25_13_15_00 - Jaguar XF.ts' (b8558957576e03120421aa171a6bb710): already processed successfully.
[autovideoconverter] Waiting 10 seconds before processing '/watch/Mythen-Jäger/Mythen-Jäger 2020_08_25_15_00_00 - Der Piratenschatz des Captain Kidd.ts'...
[autovideoconverter] ======================================= CONVERSION START =================================================
[autovideoconverter]
[autovideoconverter] Starting conversion of '/watch/Mythen-Jäger/Mythen-Jäger 2020_08_25_15_00_00 - Der Piratenschatz des Captain Kidd.ts'...
[autovideoconverter] -------------------------------------
[autovideoconverter] FFMPEG START
[autovideoconverter] FFMPEG FINISH WITH STATUS 0
[autovideoconverter] -------------------------------------
[autovideoconverter] COMCUT START
Inputfile '/watch/Mythen-Jäger/.T7uEtj/Mythen-Jäger' doesn't exist. Please check.
[autovideoconverter] COMCUT FINISH WITH STATUS 0
[autovideoconverter] -------------------------------------
[autovideoconverter] -------------------------------------
[autovideoconverter] TMP DIRECTORY REMOVED
[autovideoconverter]
[autovideoconverter] ======================================= CONVERSION DONE =================================================
[autovideoconverter] Conversion failed.

 

 

Log: https://pastebin.com/eB2jETVT

Link to post

you can try the lasted build, check your custom.sh i removed ccextractor from there. Maybe delete your appdata before doing your test. I added 2 more variables to my template. I tested a lot of files with nvidia and cpu ffmpeg, and got no problem.  If you still have problem after this version i think i will need one of your file to test.

 

i added some directory in \config\log that can help a lot if you got some error.

Edited by Chacawaca
Link to post

can you setup the output folder to point somewhere else? my recordings go in a holding folder. once converted the folder structure is the same on my media server folders. so if the recording is in /xxx/Season 01/ then in the media server it will be in /xxx/Season 01/ 

Edited by nicksphone
Link to post

In your custom.sh, do you changed it to have a ffmpeg command that use your gpu ? You have nvidia.sh.example to help you in the script directory.

 

 

subtitle extraction and comchap/comskip are still executed by your cpu, only your ffmpeg command are executed by your gpu.

Edited by Chacawaca
Link to post

nvidia.sh ---- convert to 2 channel audio, big compression

nvidia-hq.sh --- keep original audio channel and better video quality, less compression.    ------------is the one i use with 5.1 audio source.

 

or you can use your own ffmpeg command.

 

If you dont want to code yourself i suggest you test both with the same 5-6 source file and compare result.

Edited by Chacawaca
Link to post
On 8/29/2020 at 6:46 AM, Chacawaca said:

you can try the lasted build, check your custom.sh i removed ccextractor from there. Maybe delete your appdata before doing your test. I added 2 more variables to my template. I tested a lot of files with nvidia and cpu ffmpeg, and got no problem.  If you still have problem after this version i think i will need one of your file to test.

 

i added some directory in \config\log that can help a lot if you got some error.

 

Today after a while I tried it again and got another error messages.

 

Log folder attached.

 

Do you need more information?

log.zip

Link to post

some reason I cant get this thing to convert even one single file. I am testing software for now just to see it work, once and it wont convert one out of a good couple of dozen I have tried already. All of which play just fine all the way through. Anything you can advise I do?

Link to post
On 9/19/2020 at 1:16 AM, Chacawaca said:

do you use default custom.sh or a customized one ?

 

you have no ffmpeg log, its like it cant even open your file.

 

Attached is my whole scripts folder.

 

My ffmpeg logs folder is emty. 

 

Do you need any other files or folders, maybe I can send you all of them.

Or which steps I can do, to test it from the beginning or so?

 

I also attached my whole appdata folder.

scripts.zip post-recording.zip

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.