[Support] FunnyPocketBook - Firefly-III


Recommended Posts

Firefly-III
Application Site: https://www.firefly-iii.org/
Docker Hub: https://hub.docker.com/r/fireflyiii/core
Github: https://github.com/firefly-iii/firefly-iii

Documentation: https://docs.firefly-iii.org/

Check https://github.com/firefly-iii/firefly-iii/blob/main/.env.example for all environment variables.

 

 

Firefly-III-Spectre-Importer
Application Site: https://www.firefly-iii.org/
Docker Hub: https://hub.docker.com/r/fireflyiii/spectre-importer
Github: https://github.com/firefly-iii/spectre-importer

Documentation: https://firefly-iii.gitbook.io/firefly-iii-spectre-importer/

 

 

Firefly-III-CSV-Importer
Application Site: https://www.firefly-iii.org/
Docker Hub: cshttps://hub.docker.com/r/fireflyiii/csv-importer
Github: https://github.com/firefly-iii/csv-importer

Documentation: https://firefly-iii.gitbook.io/firefly-iii-csv-importer/

 

 

Firefly-III-ynab-Importer
Application Site: https://www.firefly-iii.org/
Docker Hub: cshttps://hub.docker.com/r/fireflyiii/ynab-importer
Github: https://github.com/firefly-iii/ynab-importer

Documentation: https://firefly-iii.gitbook.io/firefly-iii-ynab-importer/

 

 

Firefly-III-bunq-Importer
Application Site: https://www.firefly-iii.org/
Docker Hub: cshttps://hub.docker.com/r/fireflyiii/bunq-importer
Github: https://github.com/firefly-iii/bunq-importer

Documentation: https://firefly-iii.gitbook.io/firefly-iii-bunq-importer/

 

 

 

 

 


Post any questions or issues relating to this docker in this thread.

Edited by FunnyPocketBook
Link to comment

Hello,

 

First of all, I'm new to this tool, and it seems very promising ! Being able to auto import all of my bank transactions into a better financial management tool is amazing !

 

But I'm having issues setting everything up..

It seems I can't go to the webUI of the firefly-iii-spectre-importer docker to make an import.

Can you provide some more info on how to make it works with Firefly-III ?

 

Thanks in advance !

Link to comment

@Menthalo I somehow forgot the port mapping in the spectre container, sorry and thanks for reporting! Once the CA has updated the templates, it should be fixed.

If you need it right now, you can just click "Add another Path, Port, Variable, Label or Device" when editing the container, choose "Port" and put in 80 for the container port and 8081 or whichever port you want it to be for the host port 

Edited by FunnyPocketBook
  • Thanks 1
Link to comment

Thanks ! I now have access to the webUI

But, I also have another issue.

image.png.999fb2204b533798dd5205111a288785.png

It seems no .env file is created inside the docker

image.png.13c642748d669037b2023a4f1184e72e.png

I managed to find the .env.example which is filled as in github.

Is there something I must do ?

I also noticed that no folder are created inside the unraid appdata folder. It may be better to map the .env files inside appdata in order for us to update this file easily.

 

Thanks again, and if you need more info on my setup, I'll be glad to share 

Link to comment

@Menthalo The way Firefly-III is configured when using Docker(file) is by setting the environment variables. If you were to host it with a LAMP stack, you would directly edit the .env file, but in our case we have to change the settings using the docker environment variables, which are set when editing the container.

 

Have you created a service key and not an app key on the Spectre website? This issue seems to be the same as yours.

  • Thanks 1
Link to comment

It seems like the CSV importer doesn't set correct port when it is changed from the default into the unraid settings. I changed the port (due to a conflict), and when attempting to load the UI from the dashboard, it attempts to go to the default UI port number.  I can reach the UI when I manually change the port in the address bar.

  • Like 1
Link to comment

Sorry for the n00b question here, but can anyone direct me to a guide or idiot-proof step-by-step guide on how to deploy the app? I need to provide credentials to a mysql DB, but not sure if this is part of the container or if I need to use another docker app / VMware for this?

Link to comment
On 9/10/2020 at 10:11 AM, macem said:

Sorry for the n00b question here, but can anyone direct me to a guide or idiot-proof step-by-step guide on how to deploy the app? I need to provide credentials to a mysql DB, but not sure if this is part of the container or if I need to use another docker app / VMware for this?

You will need a separate docker container for the database. You can use either a MySQL, SQLite or a PostgreSQL database; I'm using the Postgres11 image by postgres, which you can get via CA. Once you have your database container, set the environment variable `DB_CONNECTION` to whichever database type you used ("pgsql" for PostgreSQL, "mysql" for MySQL and MariaDB, "sqlite" for SQLite). It is generally advised to create a new DB user for a new service (Google should be able to help you there, otherwise ask again)

Then provide the IP address and port to the database container and enter a name for the database that Firefly should use. If the database name doesn't exist yet, a new database will be created. Firefly connects to the DB with the credentials you provide in DB_USERNAME and DB_PASSWORD, so enter the credentials of an existing DB user in there. This would give you the most basic setup of Firefly - there's loads of more settings that you can check out here.

Link to comment
  • 2 weeks later...

I've been using Firefly III CSV importer for a few weeks without issue but today I noticed that the web endpoint is refusing connection. The docker logs (below) do not seem out of the ordinary, aside from those seemingly innocuous apache2 warnings.

 

Any thoughts?

 

Log:

Now in entrypoint.sh (v1.4) (2020-09-23) for Firefly III [tool] importer.
Please wait for the container to start...
Dump auto load...
Discover packages...
Firefly III CSV importer v2.2.0
PHP: cli 7.4.10 Linux
Will now run Apache web server:
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.4. Set the 'ServerName' directive globally to suppress this message
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.4. Set the 'ServerName' directive globally to suppress this message
[Mon Sep 28 14:16:31.234299 2020] [mpm_prefork:notice] [pid 1] AH00163: Apache/2.4.38 (Debian) PHP/7.4.10 configured -- resuming normal operations
[Mon Sep 28 14:16:31.234332 2020] [core:notice] [pid 1] AH00094: Command line: 'apache2 -D FOREGROUND'

 

Link to comment
6 minutes ago, FunnyPocketBook said:

@jpheld You need to change the container port from 80 to 8080, then it will work again. Thanks for bringing this issue up, this wasn't documented in the release notes of csv-importer.

I've pushed the changes, though it may take a few hours until the changes are updated in the CA

👍 This works, thank you.

Link to comment
  • 3 weeks later...

Hi! I am having trouble setting up the CSV Importer. No matter which FIREFLY_III_URI I set, it is not being used in the container. When starting the WEBUI, i get this error message:

Tried "http://192.168.0.10:8080/api/v1/about" 5 times but failed: cURL error 28: Connection timed out after 31415 milliseconds (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for http://192.168.0.10:8080/api/v1/about

Any ideas?

Link to comment

@meinnamehier I assume Firefly doesn't run on port 8080?

What did you set FIREFLY_III_URI to, can you send a screenshot of your config?

 

It could also be that you have tried to install the CSV Importer multiple times and are now stuck with multiple templates. Check if /boot/config/plugins/dockerMan/templates-user lists more than one CSV Importer and if so, you can remove the template that you don't want.

Link to comment

Yes, i tried installing several times; I used the  "CA Cleanup AppData" plugin and manually erased files in appdata/ inbetween. I checked the folder you mentioned, but there is only one CSV importer listed there.

Attached you can find the screenshot of the configs for FireflyIII and the CSV importer.

Thanks for your help!

Bildschirmfoto 2020-10-26 um 16.44.14.png

Bildschirmfoto 2020-10-26 um 16.44.29.png

Link to comment

Hm, I have only ever experienced this behaviour when I had duplicate containers that were using different templates.

Go to the console of the CSV importer and execute printenv, that shows you the environment variables of the container. Does the variable FIREFLY_III_ACCESS_TOKEN show up? Is the FIREFLY_III_URI correct?

Edited by FunnyPocketBook
Link to comment

It appears that the Firefly-III CSV Importer saves the URI somewhere internally and doesn't look at the environment variable anymore once it's set. When I changed the URI to something invalid, it still pointed to the old, correct URI.

In the CSV Importer WebUI, have you already clicked "Reauthenticate"? Clicking that fixed the issue for me.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.