Jump to content
testdasi

[SUPPORT] testdasi repo

115 posts in this topic Last Reply

Recommended Posts

So, obviously I'm missing something simple, because I can't do anything in Grafana. The default dashboard is all there is and there is no way to add/import other board nor can you change any of the individual panels. I've been playing with Grafana through another implementation but wanted to try this since it is a "all-in-one". 

 

Any help pointing me in the right direction is appreciated. 

 

Thanks!

Share this post


Link to post
5 hours ago, Aegisnir said:

So I have my own Grafana board setup and do not use this container but you should be able to just edit the telegraf.conf and enable the server and enter unraid IP under [[inputs.apcupsd]].  I don't remember having to do anything else to get my APC UPS stats to appear.

Thank you for the tip :)

Share this post


Link to post
1 hour ago, jmbailey2000 said:

So, obviously I'm missing something simple, because I can't do anything in Grafana. The default dashboard is all there is and there is no way to add/import other board nor can you change any of the individual panels. I've been playing with Grafana through another implementation but wanted to try this since it is a "all-in-one". 

 

Any help pointing me in the right direction is appreciated. 

 

Thanks!

Did you login as admin?

"Go to ip:3006 to access grafana, login with admin/admin and make changes to the default dashboard."

Share this post


Link to post

Hey @testdasi I just added a compatibility section on the UUD topic (first post on page 1) and tagged you.

 

image.thumb.png.a5944f87551e5703a5730dde27d7b729.png

 

Link:

 

Edited by falconexe

Share this post


Link to post
16 hours ago, testdasi said:

 

 

I hate it when apps do that. That 8088 is for Influx backup / restore but their config file doesn't allow disabling that if not used. And to make it worse, they use a rather common value of 8088.

Sounds like something on the to do list. I'll have to add that to the expose port so it's transparent to people (and probably pick a different port from 8088 - I'm probably just gonna pick 58083 or something random like that).

 

 

 

Yeah, I was just ignorant to the fact that InfluxDB uses port 8088, everything seems to be working perfect now. Do appreciate your help! This container is awesome.

Share this post


Link to post
21 hours ago, testdasi said:

kinda wonder if I should make a UUD edition that includes @falconexe's dashboard. That looks pretty damn sleek out of the box.

@testdasi please do :)

 

Love this

  • Like 1
  • Thanks 1

Share this post


Link to post

Update (23/09/2020):

  • Grafana Unraid Stack changes:
    • Expose Influxdb RPC port and change it to a rarer default value (58083) instead of the original common 8088.
    • Added falconexe's Ultimate UNRAID Dashboard

 

34 minutes ago, SDEN said:

@testdasi please do :)

 

Love this

Thanks. It's done.

 

7 hours ago, tuner562 said:

Why are my cpu cores listed/grouped this way?

The GUS dashboard is based on Threadripper 2990WX. You will have to customize the default dashboard to suit your own exact hardware.

Also give UUD a try to see if you like that layout more.

  • Like 1
  • Thanks 1

Share this post


Link to post
2 hours ago, testdasi said:

Update (23/09/2020):

  • Grafana Unraid Stack changes:
    • Expose Influxdb RPC port and change it to a rarer default value (58083) instead of the original common 8088.
    • Added falconexe's Ultimate UNRAID Dashboard

 

2 hours ago, SDEN said:

@testdasi please do :)

 

Love this

Thanks. It's done.

Thank you so much, im gratefull!

  • Like 1
  • Thanks 1

Share this post


Link to post
4 hours ago, testdasi said:

Update (23/09/2020):

  • Grafana Unraid Stack changes:
    • Expose Influxdb RPC port and change it to a rarer default value (58083) instead of the original common 8088.
    • Added falconexe's Ultimate UNRAID Dashboard

Sweet! UUD 1.4 will be out soon. @testdasi You may want to specific that UUD version 1.3 is currently what's added. Thanks for officially integrating the UUD as another option within GUS. This is really cool.

 

@SpencerJ Are you aware of the awesome work that @testdasi did to make a single docker solution for InfluxDB/Telegraf/Grafana? He just integrated the Ultimate UNRAID Dashboard. It is basically a single docker solution for everything for users who appreciate/need that kind of out of the box setup. The timing of his work couldn't have been better!

Edited by falconexe

Share this post


Link to post
52 minutes ago, falconexe said:

Sweet! UUD 1.4 will be out soon. You may want to specific that version 1.3 is currently what's added. Thanks for officially integrating the UUD as another option within GUS. This is really cool.

 

@SpencerJ Are you aware of the awesome work that @testdasi did to make a single docker solution for InfluxDB/Telegraf/Grafana? He just integrated the Ultimate UNRAID Dashboard. It is basically a single docker solution for everything for users who appreciate/need that kind of out of the box setup. The timing of his work couldn't have been better!

I was not aware! Thank you for letting know and big thanks to @testdasi for sharing. I will include this thread in the monthly newsletter.

Share this post


Link to post
2 hours ago, SDEN said:

Thank you so much, im gratefull!

 

Thanks a lot! after deleting appdata/Graf... and reinstall GUS update version with new port for influxdb, it works perfectly!

It's time to look at how it works know ;-)!

Share this post


Link to post
5 hours ago, falconexe said:

Sweet! UUD 1.4 will be out soon. @testdasi You may want to specific that UUD version 1.3 is currently what's added. Thanks for officially integrating the UUD as another option within GUS. This is really cool.

Yep. Specified that it's 1.3 now. I'll keep an eye out for v1.4.

Share this post


Link to post
22 hours ago, Sic79 said:

Did you login as admin?

"Go to ip:3006 to access grafana, login with admin/admin and make changes to the default dashboard."

 

See, something simple and I'm a dumba$$. My other Grafana install has never gone straight in. It has always asked my to log in, so I didn't even realize there was a log in icon in the lower left. What a dufus. 

 

Sorry about that and THANKS!!!

Share this post


Link to post

So now that I can use GUS, was wondering if there is any special gotchas that might exist if I want to migrate my last 2 weeks of data from my stand alone InfluxDB docker to GUS? If a big issue, I'll just scrap the old data and start from scratch. 

 

Was just curious if you have heard of anyone successfully doing it before?

 

Thanks! 

Share this post


Link to post
4 hours ago, jmbailey2000 said:

So now that I can use GUS, was wondering if there is any special gotchas that might exist if I want to migrate my last 2 weeks of data from my stand alone InfluxDB docker to GUS? If a big issue, I'll just scrap the old data and start from scratch. 

 

Was just curious if you have heard of anyone successfully doing it before?

 

Thanks! 

There shouldn't be any gotchas. Compare the folder structure of these:

  • Telegraf docker: the host folder that corresponds to /var/lib/influxdb
  • GUS: the host folder that corresponds to /data/influxdb

They should look identical in terms of structure.

If that is confirmed then just turn the dockers off, backup the data before proceeding further (if the data is important to you), delete the existing GUS /data/influxdb content and then just copy the Telegraf /var/lib/influxdb data over (ensuring no change to the previous folder structure).

 

I suggest to use mc from command line (or Krusader or similar 2-panel docker) so it looks a lot more obvious.

 

 

 

Share this post


Link to post

Hey, I'm having some weirdness with the  HyRoSa container. I am unable to connect to the SABnzbd client either through the web interface or IP:port

Hydra and rTorrent  both work fine.

I ran a test and on a custom IP, it was fine, move back to bridge and it breaks again.

I've tried modifying the ports, I've tried the default ports, but no dice running as a bridge, which unfortunately is required for me...

Any ideas?

Cheers

 

Edit** 

 

Figured it out, It seems SABnzbd itself defaulted to port 8081, with docker trying to route 8081 to 8080, it wasn't finding it. so modifying the template from 8080 to 8081 fixed it. 

Cheers

 

Edited by WeAreTheDynamite

Share this post


Link to post

Hi @testdasi,

 

Playng with your Grafana Unraid Stack, but i am hitting a problem where is seems to use a port that is not advertised as beeing used.

Its 8088 and used by influxdb next to the configured 8086.

Now that 8088 i need as in use on my host. Where is that configured so i can change that ? I looked in influxdb config but dont see it there.

 

┌─[14:32:24]─[root@TACH-UNRAID]:[/mnt/disks/virtuals/appdata/Grafana-Unraid-Stack/influxdb]
└─[!139]─:)─> lsof -i :8088
COMMAND   PID USER   FD   TYPE  DEVICE SIZE/OFF NODE NAME
influxd 47186 root    3u  IPv4 2960037      0t0  TCP TACH-UNRAID:8088 (LISTEN)

┌─[14:45:54]─[root@TACH-UNRAID]:[/mnt/disks/virtuals/appdata/Grafana-Unraid-Stack/influxdb]
└─[!140]─:)─> lsof -i :8086
COMMAND     PID USER   FD   TYPE  DEVICE SIZE/OFF NODE NAME
influxd   47186 root   16u  IPv6 2964767      0t0  TCP *:8086 (LISTEN)
influxd   47186 root   33u  IPv6 3108085      0t0  TCP TACH-UNRAID:8086->TACH-UNRAID:36474 (ESTABLISHED)
influxd   47186 root   34u  IPv6 3090408      0t0  TCP TACH-UNRAID:8086->TACH-UNRAID:36476 (ESTABLISHED)
grafana-s 47408 root   19u  IPv4 3101218      0t0  TCP TACH-UNRAID:36474->TACH-UNRAID:8086 (ESTABLISHED)
grafana-s 47408 root   20u  IPv4 3092129      0t0  TCP TACH-UNRAID:36476->TACH-UNRAID:8086 (ESTABLISHED)

 

 

Tnx

 

Edited by glennv

Share this post


Link to post

Nevermind. Found it myself. Its the default port for RPC service which aparently is 8088

I uncommented this in the config file and am good now. Tnx

# Bind address to use for the RPC service for backup and restore.

bind-address = "127.0.0.1:58083"

Share this post


Link to post

Hi ! First, thanks for the works on this apps ! :)

 

I have an issue with OpenVPN HyDeSa, if I activate the "Label" plugin, the plugin is disabled when I restart OpenVPN HyDeSa.

 

It was working with binhex-delugevpn (another Deluge version).

 

It's pretty annoyng when using Sonarr, Radarr and Lidarr (and the 4K versions of them).

 

Did someone else have the same issue ?

EDIT : some screenshots :

The web.conf file (after a restart)
2.png

 

 

The plugins (after a restart)

1.png

EDIT2: After installing AutoRemovePlus, same issue : I can setting it up, but if I restart OpenVPN HyDeSa, the plugin is disable.

EDIT3: AutoRemovePlus seems to work now, after a restart... I think it wasn't working correctly if activate with the Label plugin in the same time ; so the only issue is with the Label plugin.

Edited by koala784
Add some screenshots (and typo)

Share this post


Link to post
51 minutes ago, ctrlaltd1337 said:

For GUS, is it possible to include Varken?: https://github.com/Boerderij/Varken

 

Worked great before I decided to nuke all of previous installed to install your version. :) I miss it, but don't think I miss it enough to install it again with one of my backups.

 

 @testdasi You may want to consider this. I’m tentatively planning on adding Varken/Plex panels/stat tracking to the Ultimate UNRAID Dashboard (UUD) in version 1.5. Not a guarantee until I get into it, but if I can integrate some/all of it, that would be cool.

Edited by falconexe

Share this post


Link to post

I've set Pihole-DoT-DoH like this on 192.168.1.3 (br0) : 

 

UnRAID.thumb.png.f8d04afd8ae609a0fd7513200ce17ade.png

Pihole is accessible on 192.168.1.3, and the logs show that the DoH proxy server is started :

 

Pihole.thumb.png.2f80f5c01a152282a68c69dd765c3d11.png

 

Logs.png.a1e1fb1ae531e06fe4e337b569babb80.png

 

So i've set the 192.168.1.3 adress as my only DNS server on Windows :

 

Windows.png.42f42e9c669e6de710fab59693500389.png

 

But when I start Wireshark and visit a website, the DNS request are still visible :

 

Wireshark.thumb.png.e3911c02f6505fd48661e2821b0a95af.png

 

I'm not really good yet in networking, so I think i've miss something, but I don't know really what yet...

EDIT: UnRAID DNS is set to 1.1.1.1

Edited by koala784
Typo

Share this post


Link to post
15 hours ago, falconexe said:

 

 @testdasi You may want to consider this. I’m tentatively planning on adding Varken/Plex panels/stat tracking to the Ultimate UNRAID Dashboard (UUD) in version 1.5. Not a guarantee until I get into it, but if I can integrate some/all of it, that would be cool.

 

I just posted a sneak peak here...

 

https://forums.unraid.net/topic/96895-ultimate-unraid-dashboard-uud/?do=findComment&comment=897421

Share this post


Link to post
13 hours ago, falconexe said:

Have you got a test file I can use to test varken? I don't use it personally so need something to verify that it works correclty in GUS.

 

On 9/27/2020 at 1:41 PM, koala784 said:

EDIT3: AutoRemovePlus seems to work now, after a restart... I think it wasn't working correctly if activate with the Label plugin in the same time ; so the only issue is with the Label plugin.

This is a known bug with Deluge (see bug report below). As binhex himself said "if the plugin is not made for deluge v2 then you will be out of luck until the plugin developer updates the plugin to work with python 3.x". Binhex seems to have implemented his own fix so I think you might have no choice but to use his docker instead.

https://github.com/binhex/arch-delugevpn/issues/66

 

On 9/28/2020 at 7:51 AM, ctrlaltd1337 said:

For GUS, is it possible to include Varken?: https://github.com/Boerderij/Varken

 

Worked great before I decided to nuke all of previous installed to install your version. :) I miss it, but don't think I miss it enough to install it again with one of my backups.

I'll look into it but it may take a while.

 

20 hours ago, koala784 said:

I've set Pihole-DoT-DoH like this on 192.168.1.3 (br0) : 

But when I start Wireshark and visit a website, the DNS request are still visible :

 

Wireshark.thumb.png.e3911c02f6505fd48661e2821b0a95af.png

 

I'm not really good yet in networking, so I think i've miss something, but I don't know really what yet...
 

The DNS queries within your network is not encrypted e.g. DNS between the client (192.168.1.202) and the Pihole docker (192.168.1.3).

It's the query out of the docker to the DNS resolver (e.g. from Pihole (192.168.1.3) to google (8.8.8.8)) that is encrypted.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.