[SUPPORT] testdasi repo


Recommended Posts

59 minutes ago, Kloudz said:

In regards to the Grafana Unraid Stack. After install, it seems to keep all my disks (SATA) active.

If you notice the last 5 are not doing anything. The last 5 drives are SAS drives. It's weird that the app is keeping the other drives busy.

 

Is there a way to fix this?

 

It's probably the smartctl call in telegraf.

 

Check your config:

vi /mnt/user/appdata/Grafana-Unraid-Stack/telegraf/telegraf.conf

 

Do you have nocheck = "standby" in inputs.smart?

 

[[inputs.smart]]
#   ## Optionally specify the path to the smartctl executable
   path = "/usr/sbin/smartctl"
#
#   ## On most platforms smartctl requires root access.
#   ## Setting 'use_sudo' to true will make use of sudo to run smartctl.
#   ## Sudo must be configured to to allow the telegraf user to run smartctl
#   ## without a password.
#   # use_sudo = false
#
#   ## Skip checking disks in this power mode. Defaults to
#   ## "standby" to not wake up disks that have stoped rotating.
#   ## See --nocheck in the man pages for smartctl.
#   ## smartctl version 5.41 and 5.42 have faulty detection of
#   ## power mode and might require changing this value to
#   ## "never" depending on your disks.
   nocheck = "standby"
#

          

Otherwise I don't know SAS but I remember some forum discussions of SAS and spindown, maybe you have to customize the call. Worst case you can comment out the whole block which should resolve spindown but will disable SMART stats in grafana.

Link to comment
14 minutes ago, CS01-HS said:

 

It's probably the smartctl call in telegraf.

 

Check your config:

vi /mnt/user/appdata/Grafana-Unraid-Stack/telegraf/telegraf.conf

 

Do you have nocheck = "standby" in inputs.smart?

 

[[inputs.smart]]
#   ## Optionally specify the path to the smartctl executable
   path = "/usr/sbin/smartctl"
#
#   ## On most platforms smartctl requires root access.
#   ## Setting 'use_sudo' to true will make use of sudo to run smartctl.
#   ## Sudo must be configured to to allow the telegraf user to run smartctl
#   ## without a password.
#   # use_sudo = false
#
#   ## Skip checking disks in this power mode. Defaults to
#   ## "standby" to not wake up disks that have stoped rotating.
#   ## See --nocheck in the man pages for smartctl.
#   ## smartctl version 5.41 and 5.42 have faulty detection of
#   ## power mode and might require changing this value to
#   ## "never" depending on your disks.
   nocheck = "standby"
#

          

Otherwise I don't know SAS but I remember some forum discussions of SAS and spindown, maybe you have to customize the call. Worst case you can comment out the whole block which should resolve spindown but will disable SMART stats in grafana.

 

Yep, I have nocheck = "standby". This is installed fresh from the App Store so not sure it would be different.

 

That said, commented the whole block and nope, it did not resolve the issue.

 

Link to comment
3 minutes ago, Kloudz said:

 

Yep, I have nocheck = "standby". This is installed fresh from the App Store so not sure it would be different.

 

That said, commented the whole block and nope, it did not resolve the issue.

 

 

Did you restart the container after (and verify your commenting out the block persisted through restart) ?

 

Can't imagine with no calls to the drives how it would keep them awake.

Edited by CS01-HS
Link to comment
2 hours ago, CS01-HS said:

 

Did you restart the container after (and verify your commenting out the block persisted through restart) ?

 

Can't imagine with no calls to the drives how it would keep them awake.

Yep, restarted the container and verified that the inputs.smart block was commented out

Link to comment
On 11/29/2021 at 4:00 AM, CS01-HS said:

 

And you're sure they sleep with the container stopped?

Maybe you have USE_HDDTEMP set to yes?

1183204964_ScreenShot2021-11-29at6_54_30AM.thumb.png.73e3b89e6c7a9cf885b0567cb8b771b1.png

 

If not I don't know what could be causing it.

 

I'm positive and USE_HDDTEMP does not help. It's OK, I just created a VM that just runs Grafana. Thank's for answering my questions.

  • Like 1
Link to comment
  • 3 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.