[SOLVED] USB Keyboard not working when I use PCIe slot 2


Recommended Posts

Hi everyone!


I have an issue with passing through my USB keyboard/mouse combo to a VM which is using the 2nd PCIe slot as GPU. My server has an i5-8400, so I have iGPU, have an RX 570 in slot 1, works perfectly and I have a FirePro V3900 in slot 2.

The VM boots perfectly, it even installed the graphics driver (I'm trying a Windows 8.1 vm) but the USB Keyboard is not working. Tried other wireless Logitech combo, still not working. I even tried using a Linux VM. No luck. :(


I can't passthrough the whole controller because the entire board has only 1 which is using the unRAID USB as well. The board is an Asrock H370 Pro4.

How can I solve this issue?


Thank you in advance for your help!

Edited by scania471
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.