Strange redirect to "bidr.trellian.com"


LoneTraveler

1 post in this topic Last Reply

Recommended Posts

Hello all,

 

Initially I used Letsencrypt for my reverse proxy then I switched to NginxProxyManager and found it easier to use as I did not have to edit the config files. Today however I tried to switch back as I very much want to use Fail2ban.

 

Upon disabling NginxProxyManager and during the process of setting up Letsencrypt/Swag, whenever I attempted to connect to one of my three remote services (bitwarden, emby or nextcloud), I would be redirected to "bidr.trellian.com".

 

A quick Google search reports that this is potentially malware. Upon checking Cloudflare, I noted the below attempts to access my site during the past 24hrs.

 

20200908_114145.jpg

 

I don't know if these are some kind of false positives, or something I should be genuinely concerned about, regardless, I have switched back to NginxProxyManager. 

 

Anyone have any ideas what caused this? For reference, I was redirected to "bidr.trellian.com" on both devices I tried and no malware has been found on either. 

 

Furthermore, any suggestion(s) to get Fail2ban setup on its own would be greatly appreciated. 

Edited by LoneTraveler
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.