Ultimate UNRAID Dashboard (UUD)


730 posts in this topic Last Reply

Recommended Posts

  • Replies 729
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donate:      Ultimate UNRAID Dashboard (UUD)   Current Release: Version 1.5 (Adds Real Time PLEX Monitoring)       UUD NEWS: 2021-01-12: The Ultima

Something really cool happened. I woke up this morning and my profile had this green wording on it.       I just officially became the newest UNRAID "Community Developer". I

The Ultimate UNRAID Dashboard Version 1.5 is here! This is another HUGE 😁 update adding INTEGRATED PLEX Monitoring via Varken/Tautulli. This update is loosely derived from the official Varken dashboar

Posted Images

I have a Cache I/O graph in version 1.4, but I’ll add this type of graph to version 1.5, as I can see the value in it. High volume cache writes have been a hot topic for the last few months, especially for people like myself who have invested in expensive NVMe drives and/or large pools. I’ll add you as an official contributor once this is done. 

Link to post
6 minutes ago, falconexe said:

I have a Cache I/O graph in version 1.4, but I’ll add this type of graph to version 1.5, as I can see the value in it. High volume cache writes have been a hot topic for the last few months, especially for people like myself who have invested in expensive NVMe drives and/or large pools. I’ll add you as an official contributor once this is done. 

i/o graph is ok but it shows performances and you can't really see impact on ssd endurance.

With my previous ssds i didn't see writes could be a problem until it was too late. If i remember correctly i had 700Tb written in 9 months. 

Link to post
7 minutes ago, caplam said:

i/o graph is ok but it shows performances and you can't really see impact on ssd endurance.

With my previous ssds i didn't see writes could be a problem until it was too late. If i remember correctly i had 700Tb written in 9 months. 


Agreed. I’ll add them. You mind DMing me your 2 panel JSONs (or posting them here) as a reference?

Link to post
On 10/11/2020 at 5:05 PM, Forty Two said:

I just got 1.3 to work in full. :D

Very little works in 1.4, at least for me.

 

Just for example this is the code to get fan dials to work on my system:


SELECT last("fan_input") FROM "sensors" WHERE ("feature" =~ /fan./) AND $timeFilter GROUP BY time($__interval), "feature"

Set ALIAS BY to: 


$tag_feature

 

Excellent!

 

Works a treat on my AMD A10 CPU.

 

Now, I just need to plug the fans into the MoBo headers instead of the case header. Maybe it'll recognize more than 1 fan and show some different speeds... :)

 

Interesting... I updated the "fan speed dials" panel

image.png.819b8c71eb9ac45a0ff65bb43fd83e5a.png

 

With that query. When I did, I noted that there's a disabled query in there:

SELECT last("value") FROM "sensors" WHERE ("feature" = 'select tag value') AND $timeFilter GROUP BY time($__interval)

I enabled it and it doesn't seem to make any difference. What's it supposed to do?

Edited by FreeMan
Link to post

Hey, this is spiffy! I installed telegraph on my backup server and copied the telegraph.conf file from my primary to the backup. Now, I'm getting data for both, and all I have to do is change the "Host" name to switch!

 

I guess I need to go through all the drive graphs and add overrides for the backup server's drives to map the serial numbers to names, eh? Sadly, it seems that I have to designate which "Drive 1" is which myself, since it shows legend info for all drives in the array whether there's data for them on this host or not. There's worse things, I suppose...

 

Any other tips on using the 1 Grafana display for 2 servers?

 

Update:

The cache I/O graph is showing only the single drive for the backup machine but the array I/O graph is showing all drives from both machines, even though it's showing nothing for the primary machine.

 

Also, of note, it's impossible to assign the boot drive for both machines at the same time. In general, this makes perfect sense, since a machine can have only one boot drive, but for those monitoring multiple machines, it's a tad inconvenient.

Edited by FreeMan
Link to post

Once you have dealt with LIFE, there is one little thing that would need fixing.

 

The Docker RAM graph starts at 1 GB instead of 0 as do all other graphs (except drives temp, but that's fine).

When I select one particular docker, the value changes, but never starts at 0.

image.png.90f6dabfbb6f6b45aac6173fd78e450a.png

 

It is a bit confusing at first glance and I didn't find a way to correct that myself.

 

It would be nice if I could be fixed for v1.5, and maybe provide a fix for the earlier versions.

Link to post

I noticed that my Array I/O (Read) and (Write) were showing data from drives from both of my servers no matter which HOST I'd selected in the variable up top. Not exactly what I was after. I tracked it down to a misplaced close paren in the query.

 

Original:

SELECT non_negative_derivative(last("read_bytes"), 1s) FROM "diskio" WHERE ("ID_SERIAL" =~ /^$Drives_Array$/ OR "ID_SERIAL" =~ /^$Drives_Parity$/ AND "host" =~ /^$Host$/) AND $timeFilter GROUP BY time($__interval), "ID_SERIAL"

Fixed:

SELECT non_negative_derivative(last("read_bytes"), 1s) FROM "diskio" WHERE ("ID_SERIAL" =~ /^$Drives_Array$/ OR "ID_SERIAL" =~ /^$Drives_Parity$/) AND "host" =~ /^$Host$/ AND $timeFilter GROUP BY time($__interval), "ID_SERIAL"

Note the paren moved to after the "ID_SERIAL" condition to group the OR conditions on "ID_SERIAL" separate it from the AND conditions to get the order of operation correct. The original includes the 'and "host"...' in the parens and it essentially gets ignored.

 

This may be an issue elsewhere, as well, but I haven't looked through all the queries yet to be sure.

Link to post
  • 2 weeks later...

Our move was successful, bit I'm still unpacking over here. Finally got my servers setup into my new dedicated sever room. I'll circle back on the previous posts (questions and bug fixes) and start working on the UUD again soon. My current plan is to release version 1.5 by Thanksgiving. Thanks for your continued patience and support everyone. Hope you guys are good and staying safe out there...

Link to post

Hello,

 

thanks for this awesome dashboard!

One thing I always add to my dashboard are the running Docker/VM Icons and some switches to control the container/VMS from by overall IT Dashboard.

Maybe you would implement this as an optional row?
For this i'm using the unraid-api as direct json datasource and the dynamic image plugin in grafana.

firefox_GsoQG6hJBH.png

Edited by corgan
Link to post
On 11/12/2020 at 1:15 AM, corgan said:

Hello,

 

thanks for this awesome dashboard!

One thing I always add to my dashboard are the running Docker/VM Icons and some switches to control the container/VMS from by overall IT Dashboard.

Maybe you would implement this as an optional row?
For this i'm using the unraid-api as direct json datasource and the dynamic image plugin in grafana.
 

 

Yeah that is freakin sweet. If you want to DM me the code/documentation, I'll add that to version 1.6 (maybe 1.5), credit you, and add you as a contributor. This is what I love about this community. Keep stuff like this coming... 👍 

Link to post

Hello! I'm having some issues getting this working. I've got all dockers installed and running, but it doesn't appear that the telegraf database is being created when I start telegraf because Grafana isn't finding it.

 

My ports for influxDB are 8083 and 8086, which I've left at defaults and I've tried pointing Telegraf.conf at both of those and Grafana at both of those.

 

Any ideas?

 

Here is a telegraf.conf: https://pastebin.com/N0bGbjVe

Link to post
On 11/12/2020 at 3:15 AM, corgan said:

One thing I always add to my dashboard are the running Docker/VM Icons and some switches to control the container/VMS from by overall IT Dashboard.

Or, you could post the code here and some of us n00bs could try getting it implemented ourselves! ;)

Link to post
7 hours ago, Vaggeto said:

Hello! I'm having some issues getting this working. I've got all dockers installed and running, but it doesn't appear that the telegraf database is being created when I start telegraf because Grafana isn't finding it.

 

My ports for influxDB are 8083 and 8086, which I've left at defaults and I've tried pointing Telegraf.conf at both of those and Grafana at both of those.

 

Any ideas?

 

Here is a telegraf.conf: https://pastebin.com/N0bGbjVe

 

I don't have time right now to deep dive, but I would suggest following the link on Page 1 > Post 3 where I linked GilbN's great tutorial website for getting started. Here it is again below. Also have a good look at my instructions in post 1. If anyone else wants to take a crack at supporting Vaggeto, it would be much appreciated. I'm still unpacking and dealing with house related activities. Good luck!

 

https://technicalramblings.com/blog/how-to-setup-grafana-influxdb-and-telegraf-to-monitor-your-unraid-system/

 

Edited by falconexe
Link to post
4 hours ago, jbartlett said:

I stumbled across this thread and promptly had a nerdgasm.

 

Loving the Dashboard! Only change I've made so far is to add an Y axis cap of 100 so the CPU graphs don't scale to 125% after a core hits 100%.

 

Almost spit out my water when I read this. That is hilarious. Glad you are loving it! I'll add your suggestion and add you as a contributor once it is LIVE.

Link to post

is there some kind of tutorial video on the basic setup? im already lost at the telegraf settings... 😕

 

or is there someone willing to help with discord voice and maybe screenshare? ^^

Edited by stFfn
Link to post
16 hours ago, stFfn said:

is there some kind of tutorial video on the basic setup? im already lost at the telegraf settings... 😕

 

or is there someone willing to help with discord voice and maybe screenshare? ^^

Have you looked at this Tutorial which is actually really good https://technicalramblings.com/blog/how-to-setup-grafana-influxdb-and-telegraf-to-monitor-your-unraid-system/

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.