Cache Drive "Unmountable: No file system"


Team_Dango

4 posts in this topic Last Reply

Recommended Posts

My server experienced an unexpected shutdown over the weekend and now one of the cache drives is acting up. Unfortunately I was not home, so I don't know for sure what happened. The server is on a UPS and there was no power outage as far as I can tell. When I booted the server back up, the first thing I noticed was all of my dockers and VMs were missing. This freaked me out, then I noticed that my first cache drive was listed as "Unmountable: No file system". I run two 250GB SSD's in BTRFS RAID 1 as a cache. The drive looks fine when the array is stopped, it lists its file system as BTRFS, it can be selected as a cache drive and URAID says "Configuration valid". The array even starts fine, but once started the drive shows the error. I ran a SMART self test and everything looks alright, though I'm not really sure what I'd be looking for, so I'm attaching the full text.

 

My question is, where do I go from here? Is it safe to rebuild the BTRFS array using the second drive, or do I need to replace the bad drive altogether? How would I go about rebuilding the array safely? This isn't even getting to the issue of the missing dockers, I'm really hoping that will all come back once I fix the cache. If not I do have backups, but it'd be a pain. Finally, any ideas why the server crashed in the first place? I'm using desktop hardware mostly, an Asrock Z75 Pro3 motherboard, i7 2600K, and 16GB of DDR3 memory at 1600MHz. The RAM is not ECC, so maybe a bit flipped and broke everything? Any advice would be much appreciated.

 

Thanks so much,
TD

 

 

Annotation 2020-09-14 110238.png

Samsung_SSD_840_EVO_250GB_S1DBNSBF440459L-20200913-2132.txt

Link to post

Go to Tools - Diagnostics and attach the complete Diagnostics ZIP file to your NEXT post in this thread.

 

Diagnostics includes syslog, SMART for all attached disks, settings and hardware info that give a more complete understanding of your configuration and current situation all in a neat package.

 

We always prefer complete diagnostics instead of just one part of that which often doesn't contain a complete enough picture to make any recommendations.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.