Unraid 10gbps Network Troubleshooting


UnBeastRaid

Recommended Posts

Hello, thanks for reading into my post.

This is post does not specifically target one issue, it is generally aimed at 10gbps network performance and how to actually achieve 10gbps transfer throughput.

 

I guess the problem that I'm having is that I'm not fully taking advantage of my 10gbps hardware and I do not really know where to start in order to fix it. On average, If I transfer a (10GB) cached (NVMEe) file from my Unraid media server, to my workstation destination which is also NVMe storage, the max speed that I have been able to achieve is roughly ~370MB/s or 2.96gbps. I know with the hardware that I am using, I should theoretically reach 8gbps transfer speeds. I don't really know where the bottleneck is.

image.png.2dbea470ebe2f4a8e00bc4e302685c69.png

 

The hardware I am using (lvl1-2 OSI) is as follows:

- CAT-8 Ethernet cable (max distance is 20')

- 2x ASUS 10gig NICs (updated firmware)

- MikroTik 5-Port Desktop Switch, 1 Gigabit Ethernet Port, 4 SFP+ 10Gbps Ports (CRS305-1G-4S+IN)

- 10G SFP+ RJ45 Copper Transceivers, 10GBase-T Module for Cisco SFP-10G-T-S

- Western Digital WDS500G3X0C 500GB NVMe M.2 SSD

- Samsung 970 Pro 500GB NVMe M.2 SSD

 

If you know of any diagnosing/troubleshooting tips to help me achieve higher transfer speeds, by all means please post the info down below.

Also, if I have missed any information that you need, I will provide it.

 

- Thanks for your help

 

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.