[Support] Linuxserver.io - digiKam


11 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png?v=4&s=4000

 

Application Name: digiKam
Application Site: https://www.digikam.org/
Docker Hub: https://hub.docker.com/r/linuxserver/digikam/
Github: https://github.com/linuxserver/docker-digikam

 

Please post any questions/issues relating to this docker you have in this thread.

If you are not using Unraid (and you should be!) then please do not post here, rather use the linuxserver.io forum for support.

Link to post

Hi.

Thanks, was just about to install aptalca's version, but already has some containers from linuxserver.io (sharing the base image?).

Anyway, just a quick question/suggestion - is it possible to change the networking from "host" to "bridge"? what ports are needed for that?

Another suggestion is adding a dedicated "Pictures" folder mapping to the settings, so not to use the appdata folder (as the program suggests by default to use /config/Pictures).

BTW - is there a known reverse proxy configuration for SWAG to make it available over WAN?

 

 

Thanks 🙂

Edited by gshlomi
Link to post
31 minutes ago, gshlomi said:

Hi.

Thanks, was just about to install aptalca's version, but already has some containers from linuxserver.io (sharing the base image?).

Anyway, just a quick question/suggestion - is it possible to change the networking from "host" to "bridge"? what ports are needed for that?

Another suggestion is adding a dedicated "Pictures" folder mapping to the settings, so not to use the appdata folder (as the program suggests by default to use /config/Pictures).

BTW - is there a known reverse proxy configuration for SWAG to make it available over WAN?

 

 

Thanks 🙂

I don't think aptalca have not made any containers in his private repo since he joined linuxserver a long time ago.

 

I don't know the app, but seeing it is a photo management software, I don't see a reason why it would need host networking. So bridge mapping port 3000 should be good.

 

As for folders, you can add your own mappings as you see fit. I like that approach better.

 

You will have to check the proxy conf repo or the proxy-conf folder of swag for a RP conf.

Link to post
1 hour ago, saarg said:

I don't think aptalca have not made any containers in his private repo since he joined linuxserver a long time ago.

 

They're all from prior to his joining lsio, and since DigiKam had no direct replacement in another active repository, it stayed within Apps.  Now it's officially deprecated, (along with JDownloader2 - as there's other replacements for that one also)

Link to post

It looks as if the RDP session is timing out if window is left open without any user interaction:

Quote

guacd[353]: ERROR: User is not responding.
guacd[353]: INFO: User "@5065b63a-ecc8-46de-bda6-9939f02548e0" disconnected (0 users remain)
guacd[353]: INFO: Last user of connection "$b5d0262b-19d1-40c5-86f6-b05a14205cec" disconnected
guacd[332]: INFO: Connection "$b5d0262b-19d1-40c5-86f6-b05a14205cec" removed.

Any way of removing this limitation?

No way to access the app again without restarting the container.

 

Thanks

Link to post
  • 3 weeks later...
  • 1 month later...

I'm in the process of switching from aptalca/docker-digikam to linuxserver/digikam.  Is there an easy way to use an existing db from previous install?  Also, I've set the container to Privileged, but I can't access /media/user/Pictures within the Digikam UI.  Any suggestions? (I apologize for my ignorance.  I'm a relatively new linux/unraid user).  Thanks in advance!

Edited by barbarossa
Link to post
  • 1 month later...

I've installed Digikam and have not yet been able to point it to use my my photo storage shares..  before getting fully stuck in to troubleshooting I wanted to see if many people are actually  using DigiKam docker on unraid, there doesn't seem to be much activity under this forum subject despite Digikam looking like a very well featured photos manager/editor etc..    any comments apreciated.

Link to post
7 hours ago, Gazza said:

I've installed Digikam and have not yet been able to point it to use my my photo storage shares..  before getting fully stuck in to troubleshooting I wanted to see if many people are actually  using DigiKam docker on unraid, there doesn't seem to be much activity under this forum subject despite Digikam looking like a very well featured photos manager/editor etc..    any comments apreciated.

I never tried it, so how can you add photos in the container? If it's a path, then add your photo share as a new path to the container and use the container path you set in Digikam.

Link to post
On 1/8/2021 at 11:22 PM, saarg said:

I never tried it, so how can you add photos in the container? If it's a path, then add your photo share as a new path to the container and use the container path you set in Digikam.

Great suggestion, I'll try that and report back.  On a side note, I've temporarilly gone back to managing/organising my photo libraries on local machines and backing up to unraid. With AC1700- Wifi I'm still finding browsing thumbnails too slow over the LAN especially via the Macbook.  I'm interested to discover if Digikam will improve the situation, hopefully at least bringing me up to the speed of managing photos via popular cloud based solutions.

 

The Problem with having a main library on the Macbook is that it only has a 250Gb hard drive and I can't easily administer/use the library from many devices..   I'll experiment with Seafile or Resillio - The amount of hours I've spent researching/testing to try find a good self hosted Photo Library management solution, has made me realise that I would have been better off paying the money for US Amazon Prime or Smugmug even though it means my stuff is less private!

Link to post

Is there a way to connect through a Guacamole client to the digikam remote session? I have a Guacamole docker in the same subnet as the digikam docker, but I'm not able to connect to the digikam container, no matter what I try.I suppose the protocol is RDP so I tried to connect through this with abc/abc as credentials and also without credentials but with no success.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.