[Support] Linuxserver.io - Chevereto


10 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png?v=4&s=4000

 

Application Name: Chevereto
Application Site: https://github.com/Chevereto/Chevereto-Free
Docker Hub: https://hub.docker.com/r/linuxserver/chevereto/
Github: https://github.com/linuxserver/docker-chevereto

 

Please post any questions/issues relating to this docker you have in this thread.

If you are not using Unraid (and you should be!) then please do not post here, rather use the linuxserver.io forum for support.

Link to post

Hi Team,

 

Thanks for this Docker. I gave it a try and found a potential show-stopper issue.

 

I tried dragging a .jpeg file that is about 8MB. On the UI I get a message that says "File too big". The UI does say:

"JPG PNG BMP GIF 2 MB"

 

This maximum file size is way too small for any modern recent camera file.

 

I googled a bit and found this posting. It basically says that the hosting service is the one limiting the file size to 2MB. I figured since I am the host, there should be a setting somewhere to change this. I found this, which states:

 

Quote

In our last article, we’ve explained about limiting user file upload size in Apache. In this article, we will explain how to limit user file upload size in Nginx. Restricting file upload size is useful to prevent some types of denial-of-service (DOS) attacks and many other related issues.

 

By default, Nginx has a limit of 1MB on file uploads. To set file upload size, you can use the client_max_body_size directive, which is part of Nginx’s ngx_http_core_module module. This directive can be set in the http, server or location context.

 

It sets the maximum allowed size of the client request body, specified in the “Content-Length” request header field. Here’s an example of increasing the limit to 100MB in /etc/nginx/nginx.conf file.

 

Set in http block which affects all server blocks (virtual hosts).

        http { ... client_max_body_size 100M; }

Set in server block, which affects a particular site/app.

        server { ... client_max_body_size 100M; }

 

 

So I went into /appdata/chevereto/nginx/nginx.conf and in the http: block changed: "client_max_body_size 100M;" It was originally set to 0 (a bad sign).

 

I restarted the docker and still had the same issue. 😦

 

Is there a way to increase this minimum? Did I do this in the wrong place? There is no "server" block in the .conf file.

 

Thanks again.

 

H.

 

Link to post
  • 2 months later...
On 10/1/2020 at 1:37 PM, hernandito said:

 

Thanks.... that is where I saw the note about client_max_body_size potential solution... They also note other PHP configuration items.

@hernandito you want to check the php-local.ini file located at /chevereto/php/ and make sure its got the sizes you want (restart the container for changes to take effect)

 

After that, go into chevereto's webUI settings under image upload and change the limits there as well.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.