(SOLVED) Almost all movies inside Plex share is gone


Recommended Posts



Just went ahead and tried to watch a movie from my Plex share, and saw that almost all movies are gone.

It seems like only files from the cache disk and the folder on Disk 6 is present (Disk 1-5 had movies, but the share folder for Plex are gone).

When I see the current usage on disks it seems like the data is still there, but it's not visible.


Does anyone have any idea on what could be causing this?


I tried running the Tools > DockerSafeNewPerms as suggested in another thread, and also uninstalled the network stats plugin that I've used for a while. Did 3-4 reboots but files are still gone. 


If anyone have any ideas, please let me know! 😬


Edited by Linus
Link to comment

When i connect through SFTP it seems like something happened yesterday (01.10.2020) at 05:50 AM

The folders inside the share /mnt/user/plex has a "latest change date" around the same time.

When browsing the different folders:





They show up but are almost empty, only thwe few stuff that is on the cache drive shows up. Everything on the disks seems to have disappeared. The array still says 28 TB is used, so it seems like the data is still there somewhere, just not visible?

Edit: At around 05:00 yesterday my monthly backup of the appdata folder ran with the "CA Backup / Restore Appdata"-plugin. I don't know that could be related, but just throwing it out here if it could give any clues.

Edited by Linus
Link to comment

Ok, I just checked the log for the Plex Docker. And maybe the "folder changed" date was changed at 05:50 because the Plex Docker was updated at that time. Maybe it's not related with the files gone? Just that it checkes folders for correct permissions etc?

_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/

Brought to you by linuxserver.io

To support LSIO projects visit:

User uid: 99
User gid: 100

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 40-chown-files: executing...
[cont-init.d] 40-chown-files: exited 0.
[cont-init.d] 45-plex-claim: executing...
[cont-init.d] 45-plex-claim: exited 0.
[cont-init.d] 50-gid-video: executing...
[cont-init.d] 50-gid-video: exited 0.
[cont-init.d] 60-plex-update: executing...
Atempting to upgrade to:
2020-10-01 05:50:27 URL:https://downloads.plex.tv/plex-media-server-new/ [80485854/80485854] -> "/tmp/plexmediaserver_1.20.2.3370-b1b651549_amd64.deb" [1]
(Reading database ... 10460 files and directories currently installed.)
Preparing to unpack .../plexmediaserver_1.20.2.3370-b1b651549_amd64.deb ...
PlexMediaServer install: Pre-installation Validation.
PlexMediaServer install: Docker detected. Preinstallation validation not required.
Unpacking plexmediaserver ( over ( ...
Setting up plexmediaserver ( ...
PlexMediaServer install: Docker detected. Postinstallation tasks not required. Continuing.
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
[cont-init.d] 60-plex-update: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Starting Plex Media Server.
Critical: libusb_init failed

[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 01-envfile: executing...
[cont-init.d] 01-envfile: exited 0.
[cont-init.d] 10-adduser: executing...
usermod: no changes


Link to comment

Checking the Plex logs it seems like something must have happened later yesterday at 05:53 PM (not AM as the above)

It started an automatic scan of the library it seems and everything was gone. Here's a snippet from one of the huge Plex Media Scanner.log-files:


Oct 01, 2020 17:53:31.590 [0x15419eaf2bc0] DEBUG - Updating deletion state for metadata item 7926, is has a dead item count of 0.
Oct 01, 2020 17:53:31.591 [0x15419eaf2bc0] DEBUG - Updating deletion state for metadata item 7891, is has a dead item count of 0.
Oct 01, 2020 17:53:31.605 [0x15419eaf2bc0] DEBUG - Deleting media item 13885.
Oct 01, 2020 17:53:31.606 [0x15419eaf2bc0] DEBUG - Downloading document
Oct 01, 2020 17:53:31.606 [0x15419eaf2bc0] DEBUG - HTTP requesting GET
Oct 01, 2020 17:53:31.608 [0x15419eaf2bc0] DEBUG - HTTP 200 response from GET
Oct 01, 2020 17:53:31.608 [0x15419eaf2bc0] DEBUG - Was connected to metadata item 7932, count is now 0.
Oct 01, 2020 17:53:31.609 [0x15419eaf2bc0] DEBUG - Destroying metadata item 7932 (Consumed)
Oct 01, 2020 17:53:31.610 [0x15419eaf2bc0] DEBUG - Downloading document
Oct 01, 2020 17:53:31.610 [0x15419eaf2bc0] DEBUG - HTTP requesting GET
Oct 01, 2020 17:53:31.612 [0x15419eaf2bc0] DEBUG - HTTP 200 response from GET
Oct 01, 2020 17:53:31.612 [0x15419eaf2bc0] DEBUG - Updating deletion state for metadata item 7926, is has a dead item count of 0.
Oct 01, 2020 17:53:31.613 [0x15419eaf2bc0] DEBUG - Updating deletion state for metadata item 7891, is has a dead item count of 0.
Oct 01, 2020 17:53:31.628 [0x15419eaf2bc0] DEBUG - Deleting media item 13886.

Link to comment
12 minutes ago, Squid said:

Can you navigate through disks 1-5 via the webUI?  Are the files there or not (Main, click the folder icon at the right right of each disk)

Thank you for your answer. Yes, I can navigate through all disks in the web UI without any problems. The Plex share however is missing. All other shares seems to be intact. Plex share folder is shown in Disk 6, but it's empty there. And on the cache disk it seems to be intact (Plex share is there and containing the stuff that has not been moved to the array yet).

Edited by Linus
Link to comment

1.) Open WebGUI -> Webterminal and enter this command:

du -hs $(ls -A) /mnt/disk6/Moviesharename/*

Which sizes does it return?


Or use this for real usage:

du -hs $(ls -A) -block-size=1 --apparent-size /mnt/disk6/Moviesharename/*

2.) When was the last scan of Plex or when did you saw a movie before yesterday? The problem could happen much earlier.


3.) Has a user write access to your movie collection? If yes: Don't do that. The Plex docker container should only have read-access for your media. And your users, too. I enabled Disk Share access, enabled only the cache disk for my user and rip my movies to /mnt/cache/Movies. After the mover does its work, they are out of all user permissions. By that my Movie collection is protected against deleting by accident and ransomware as long I'm not using the Root Login through my browser.


4.) If 3.) is yes, did you check your clients regarding Ransomware?


5.) Is your server accessible through the Internet (open ports on your router)?

Edited by mgutt
  • Like 1
Link to comment

Thanks a lot for your help mgutt. Your first line there actually helped finding this weird error.

Tried running the du -hs command and it returned something like "cannot access /mnt/disk6/plex/*: no such file or directory.

Weird thing is that there is a directory there named plex. Thought I should try and run the command on the other share on the disk: /mnt/disk6/nextcloud
The command returned the size of the folders inside the nextcloud share and there it said /mnt/disk6/nextcloud/plex and 1 TB data on Disk 6.


Seems like all Plex shares has been moved from /mnt/user/plex to /mnt/user/nextcloud, so I moved them back and everything is now perfectly fine it seems.
I have no idea on how they got moved there in the first place though. No user has write access other than me through Filezilla.

Really weird, but so happy all the files are back now. Thanks again! 😅

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.