Disk Errors - can't find disk through terminal


Recommended Posts

My backup NAS was victim of a power outage and since it restarted, one disk shows errors and sometimes "Unmountable: No File System". 


As I'm only able to access it remotely through a VM I'm not able to stop the array. At first I tried to repair it:

xfs_repair -v /dev/md6
xfs_repair: cannot open /dev/md6: Device or resource busy

Then I unmounted it:

umount /dev/md6

And repaired it again:

xfs_repair -v /dev/md6
Phase 1 - find and verify superblock...
superblock read failed, offset 0, size 524288, ag 0, rval -1

fatal error -- Input/output error

Tried remounting:

mount -t xfs /dev/sdg1 /mnt/disk6
mount: /mnt/disk6: special device /dev/sdg1 does not exist

Checked all existing disks and it seems to be dead as sdg / sdg1 is missing completely:

loop0    7:0    0   9.1M  1 loop /lib/modules
loop1    7:1    0   7.1M  1 loop /lib/firmware
loop2    7:2    0    20G  0 loop /var/lib/docker
loop3    7:3    0     1G  0 loop /etc/libvirt
sda      8:0    1  14.2G  0 disk 
└─sda1   8:1    1  14.2G  0 part /boot
sdb      8:16   0  12.8T  0 disk 
└─sdb1   8:17   0  12.8T  0 part 
sdc      8:32   0  12.8T  0 disk 
└─sdc1   8:33   0  12.8T  0 part 
sdd      8:48   0  12.8T  0 disk 
└─sdd1   8:49   0  12.8T  0 part 
sde      8:64   0 223.6G  0 disk 
└─sde1   8:65   0 223.6G  0 part /mnt/cache
sdf      8:80   0  12.8T  0 disk 
└─sdf1   8:81   0  12.8T  0 part 
sdh      8:112  0  12.8T  0 disk 
└─sdh1   8:113  0  12.8T  0 part 
md1      9:1    0  12.8T  0 md   /mnt/disk1
md2      9:2    0  12.8T  0 md   /mnt/disk2
md3      9:3    0  12.8T  0 md   /mnt/disk3
md4      9:4    0  12.8T  0 md   /mnt/disk4
md5      9:5    0  12.8T  0 md   /mnt/disk5
md6      9:6    0  12.8T  0 md

Could I check something else? If not I would pick up the NAS in a few days and replace the disk and restore from backup.

Edited by mgutt
Link to comment
4 minutes ago, trurl said:

Maybe try rebooting

This is not possible. I tried it multiple times. It does not shutdown. My friend on the external location needed to hold the power button to reboot the server and finally after restart I'm in the same situation (not seeing the disk through terminal).


Does anyone have an idea to accces the WebGUI remotely without starting the array (I'm not able to open ports on the remote side)?


It's strange how the disk is listed (8.1 GB total size ^^):


Edited by mgutt
Link to comment
Just now, jonathanm said:

Not sure what you are getting at.

This is my external backup NAS. Its located in an other city. I'm able to control it remotely through a Lubuntu VM + VNC Viewer (Real VNC). If I would stop the array, the VM would be killed and I loose the ability to access it.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.